summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kontact/kontact-4.4.2015.06.ebuild')
-rw-r--r--kde-apps/kontact/kontact-4.4.2015.06.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/kde-apps/kontact/kontact-4.4.2015.06.ebuild b/kde-apps/kontact/kontact-4.4.2015.06.ebuild
new file mode 100644
index 000000000000..21c119e03eae
--- /dev/null
+++ b/kde-apps/kontact/kontact-4.4.2015.06.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KMNAME="kdepim"
+KDE_HANDBOOK=optional
+inherit kde4-meta
+
+DESCRIPTION="KDE personal information manager (noakonadi branch)"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdeapps_dep kdepimlibs '' 4.6)
+ $(add_kdeapps_dep libkdepim '' 4.4.2015)
+"
+RDEPEND="${DEPEND}"
+
+KMLOADLIBS="libkdepim"
+KMSAVELIBS="true"
+
+# We remove plugins that are related to external kdepim programs. This way
+# kontact doesn't have to depend on all programs it has plugins for.
+# kcontactmanager gone from kdesvn
+#
+# xml targets from kmail/ are being uncommented by kde4-meta.eclass
+KMEXTRACTONLY="
+ kmail/
+ kontact/plugins/akregator/
+ kontact/plugins/kaddressbook/
+ kontact/plugins/kjots/
+ kontact/plugins/kmail/
+ kontact/plugins/knode/
+ kontact/plugins/knotes/
+ kontact/plugins/korganizer/
+ kontact/plugins/ktimetracker/
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+"
+
+src_unpack() {
+ if use handbook; then
+ KMEXTRA+="
+ doc/kontact-admin/
+ "
+ fi
+
+ kde4-meta_src_unpack
+}