summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/singularity')
-rw-r--r--games-simulation/singularity/Manifest2
-rw-r--r--games-simulation/singularity/metadata.xml11
-rw-r--r--games-simulation/singularity/singularity-0.30c-r1.ebuild49
3 files changed, 62 insertions, 0 deletions
diff --git a/games-simulation/singularity/Manifest b/games-simulation/singularity/Manifest
new file mode 100644
index 000000000000..26372813ea67
--- /dev/null
+++ b/games-simulation/singularity/Manifest
@@ -0,0 +1,2 @@
+DIST endgame-singularity-music-006.zip 28250705 SHA256 469697285c00564d831249898204d3e532f2685a17b4cf47ee4abc3ffc29276f SHA512 47e489112309cc742c2dcffec004aff25c54488fdf2a5f2dc67b7dcf67ca55996fe8e8403e4a16712fbc4e22289f12e612ad9d4322cd1d1aaab871f0ffb27e19 WHIRLPOOL bb94d4a5c50ef9fdc55e1384132c3ebb8788aa3746b70f8440b1855598682f7d6c99fb058d398012ca0b8bbe47d9b1362e070c3815ec96c05c9c9a66469da4bf
+DIST singularity-0.30c-src.tar.gz 2265133 SHA256 f4759fc059ef136c2d4d9668a021b14922dd7300ab5f37ed318ad6778c83f28f SHA512 ffca50c179b745561a25e3fb3525abb862d72f63f533f8a41472067d0ce94c8a236486c9c40a5040335d84e903c498805d591dc546a92d0a7651105103fe114f WHIRLPOOL f7b95b170df3aa5bd5080f1d7480b655fb63bb513a9b16b5e5d9873779bf478d8c19e537c1274bbdbd04cc688c1c9ce3ba1507c28a503904703afff678a0bf0b
diff --git a/games-simulation/singularity/metadata.xml b/games-simulation/singularity/metadata.xml
new file mode 100644
index 000000000000..32317f01b561
--- /dev/null
+++ b/games-simulation/singularity/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name="music">Install music files</flag>
+ </use>
+ <upstream>
+ <remote-id type="google-code">endgame-singularity</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-simulation/singularity/singularity-0.30c-r1.ebuild b/games-simulation/singularity/singularity-0.30c-r1.ebuild
new file mode 100644
index 000000000000..a69ffa265cc8
--- /dev/null
+++ b/games-simulation/singularity/singularity-0.30c-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 games
+
+MUSIC=endgame-${PN}-music-006
+DESCRIPTION="A simulation of a true AI. Go from computer to computer, pursued by the entire world"
+HOMEPAGE="http://www.emhsoft.com/singularity/"
+SRC_URI="http://endgame-singularity.googlecode.com/files/${P}-src.tar.gz
+ music? ( http://endgame-singularity.googlecode.com/files/${MUSIC}.zip )"
+
+LICENSE="GPL-2 CC-BY-SA-2.5"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+music"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/pygame[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/sdl-mixer[vorbis]"
+DEPEND="${DEPEND}
+ app-arch/unzip"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ rm -f code/{,*}/*.pyc data/*.html || die # Remove unecessary files
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r code data ${PN}.py || die
+ python_optimize "${ED%/}/${GAMES_DATADIR}"/${PN}
+
+ if use music ; then
+ doins -r ../${MUSIC}/music || die
+ fi
+ games_make_wrapper ${PN} "${EPYTHON} ${PN}.py" "${GAMES_DATADIR}/${PN}"
+ dodoc README.txt TODO Changelog AUTHORS
+ prepgamesdirs
+}