summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/notpacman/notpacman-1.0.4.ebuild')
-rw-r--r--games-arcade/notpacman/notpacman-1.0.4.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/games-arcade/notpacman/notpacman-1.0.4.ebuild b/games-arcade/notpacman/notpacman-1.0.4.ebuild
new file mode 100644
index 000000000000..74e7eeed3c04
--- /dev/null
+++ b/games-arcade/notpacman/notpacman-1.0.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils gnome2-utils games
+
+DESCRIPTION="A mashup of \"Not\" and \"Pacman\""
+HOMEPAGE="http://stabyourself.net/notpacman/"
+SRC_URI="http://stabyourself.net/dl.php?file=notpacman-1004/notpacman-linux.zip -> ${P}.zip
+ http://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+LVSLOT="0.7"
+RDEPEND=">=games-engines/love-0.7.2:${LVSLOT}
+ media-libs/devil[png]"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+src_install() {
+ local dir=${GAMES_DATADIR}/love/${PN}
+
+ exeinto "${dir}"
+ newexe not_pacman.love ${PN}.love
+
+ dodoc README
+
+ doicon -s 32 "${DISTDIR}"/${PN}.png
+ games_make_wrapper ${PN} "love-${LVSLOT} ${PN}.love" "${dir}"
+ make_desktop_entry ${PN}
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}