summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cmocka')
-rw-r--r--dev-util/cmocka/cmocka-1.1.5-r1.ebuild (renamed from dev-util/cmocka/cmocka-1.1.5.ebuild)6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-util/cmocka/cmocka-1.1.5.ebuild b/dev-util/cmocka/cmocka-1.1.5-r1.ebuild
index b2f60df8bddb..15f0abdd3156 100644
--- a/dev-util/cmocka/cmocka-1.1.5.ebuild
+++ b/dev-util/cmocka/cmocka-1.1.5-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake-multilib
+inherit cmake-multilib flag-o-matic
DESCRIPTION="Unit testing framework for C"
HOMEPAGE="https://cmocka.org/"
@@ -18,6 +18,8 @@ RESTRICT="!test? ( test )"
BDEPEND="doc? ( app-doc/doxygen[dot] )"
multilib_src_configure() {
+ append-lfs-flags
+
local mycmakeargs=(
-DWITH_EXAMPLES=$(usex examples)
-DWITH_STATIC_LIB=$(usex static-libs)