summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/buildbot-prometheus/buildbot-prometheus-17.7.2-r1.ebuild')
-rw-r--r--dev-util/buildbot-prometheus/buildbot-prometheus-17.7.2-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/buildbot-prometheus/buildbot-prometheus-17.7.2-r1.ebuild b/dev-util/buildbot-prometheus/buildbot-prometheus-17.7.2-r1.ebuild
new file mode 100644
index 000000000000..a930624175f3
--- /dev/null
+++ b/dev-util/buildbot-prometheus/buildbot-prometheus-17.7.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="A Prometheus metrics exporter for Buildbot"
+HOMEPAGE="https://github.com/claws/buildbot-prometheus"
+SRC_URI="https://github.com/claws/buildbot-prometheus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/prometheus_client[${PYTHON_USEDEP}]
+ dev-util/buildbot[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"
+
+python_prepare_all() {
+ sed -i -e "/^install_reqs.*$/d" -e "/^from pip.*$/d" -e "s/requires = .*/requires = ['buildbot', 'prometheus_client']/" setup.py || die
+ distutils-r1_python_prepare_all
+}