summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tclx')
-rw-r--r--dev-tcltk/tclx/tclx-8.4.4-r2.ebuild (renamed from dev-tcltk/tclx/tclx-8.4.4-r1.ebuild)9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-tcltk/tclx/tclx-8.4.4-r1.ebuild b/dev-tcltk/tclx/tclx-8.4.4-r2.ebuild
index 34d1fe02ea60..38ea1746b9a3 100644
--- a/dev-tcltk/tclx/tclx-8.4.4-r1.ebuild
+++ b/dev-tcltk/tclx/tclx-8.4.4-r2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
+
DESCRIPTION="A set of extensions to TCL"
HOMEPAGE="http://tclx.sourceforge.net"
SRC_URI="https://github.com/flightaware/${PN}/archive/v${PV}.tar.gz
@@ -26,11 +28,16 @@ PATCHES=(
"${FILESDIR}"/${P}-configure-clang16-deux.patch
)
+QA_CONFIG_IMPL_DECL_SKIP=(
+ stat64 # used to test for Large File Support
+)
+
src_prepare() {
sed \
-e '/CC=/s:-pipe::g' \
-i tclconfig/tcl.m4 configure || die
default
+ eautoreconf
}
src_configure() {