summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rr/rr-3.1.0.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-ruby/rr/rr-3.1.0.ebuild b/dev-ruby/rr/rr-3.1.0.ebuild
index f00aea0655f5..651fc3ce0eb5 100644
--- a/dev-ruby/rr/rr-3.1.0.ebuild
+++ b/dev-ruby/rr/rr-3.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,19 +13,19 @@ RUBY_FAKEGEM_GEMSPEC=rr.gemspec
inherit ruby-fakegem
DESCRIPTION="A double framework featuring a selection of double techniques and a terse syntax"
-HOMEPAGE="https://rr.github.io/rr"
+HOMEPAGE="https://rr.github.io/rr/"
SRC_URI="https://github.com/rr/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE=""
+IUSE="test"
ruby_add_bdepend "test? (
dev-ruby/minitest
dev-ruby/diff-lcs
dev-ruby/test-unit-rr )"
-all_ruby_prepare() {
- rm Gemfile || die
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
}