summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/daemons/daemons-1.1.9-r1.ebuild')
-rw-r--r--dev-ruby/daemons/daemons-1.1.9-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/daemons/daemons-1.1.9-r1.ebuild b/dev-ruby/daemons/daemons-1.1.9-r1.ebuild
new file mode 100644
index 000000000000..71e9bab85f89
--- /dev/null
+++ b/dev-ruby/daemons/daemons-1.1.9-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_EXTRADOC="Releases README TODO"
+RUBY_FAKEGEM_DOCDIR="html"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrap existing ruby scripts to be run as a daemon"
+HOMEPAGE="https://github.com/thuehlinger/daemons"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="examples"
+
+all_ruby_prepare() {
+ sed -e '/gempackagetask/ s:^:#:' \
+ -e '/GemPackageTask/,/end/ s:^:#:' \
+ -e 's:rake/rdoctask:rdoc/task:' \
+ -i Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ use examples || return
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples
+}