summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosbag_storage')
-rw-r--r--dev-ros/rosbag_storage/rosbag_storage-1.15.8-r1.ebuild6
-rw-r--r--dev-ros/rosbag_storage/rosbag_storage-9999.ebuild6
2 files changed, 12 insertions, 0 deletions
diff --git a/dev-ros/rosbag_storage/rosbag_storage-1.15.8-r1.ebuild b/dev-ros/rosbag_storage/rosbag_storage-1.15.8-r1.ebuild
index ecde5f7cc189..b4ede837ca4e 100644
--- a/dev-ros/rosbag_storage/rosbag_storage-1.15.8-r1.ebuild
+++ b/dev-ros/rosbag_storage/rosbag_storage-1.15.8-r1.ebuild
@@ -39,3 +39,9 @@ DEPEND="${RDEPEND}
dev-cpp/gtest
)
"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ export CATKIN_PREFIX_PATH="${BUILD_DIR}/devel/:${CATKIN_PREFIX_PATH}"
+ ros-catkin_src_test
+}
diff --git a/dev-ros/rosbag_storage/rosbag_storage-9999.ebuild b/dev-ros/rosbag_storage/rosbag_storage-9999.ebuild
index ecde5f7cc189..b4ede837ca4e 100644
--- a/dev-ros/rosbag_storage/rosbag_storage-9999.ebuild
+++ b/dev-ros/rosbag_storage/rosbag_storage-9999.ebuild
@@ -39,3 +39,9 @@ DEPEND="${RDEPEND}
dev-cpp/gtest
)
"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ export CATKIN_PREFIX_PATH="${BUILD_DIR}/devel/:${CATKIN_PREFIX_PATH}"
+ ros-catkin_src_test
+}