summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/astroid/Manifest1
-rw-r--r--dev-python/astroid/astroid-2.15.5.ebuild65
-rw-r--r--dev-python/flit-core/Manifest (renamed from dev-python/flit_core/Manifest)1
-rw-r--r--dev-python/flit-core/flit-core-3.8.0.ebuild (renamed from dev-python/flit_core/flit_core-3.8.0.ebuild)0
-rw-r--r--dev-python/flit-core/flit-core-3.9.0.ebuild35
-rw-r--r--dev-python/flit-core/metadata.xml (renamed from dev-python/flit_core/metadata.xml)0
-rw-r--r--dev-python/flit/flit-3.8.0.ebuild4
-rw-r--r--dev-python/flit_scm/flit_scm-1.7.0.ebuild2
-rw-r--r--dev-python/ipyparallel/ipyparallel-8.4.1.ebuild2
-rw-r--r--dev-python/ipyparallel/ipyparallel-8.5.1.ebuild2
-rw-r--r--dev-python/ipyparallel/ipyparallel-8.6.0.ebuild2
-rw-r--r--dev-python/ipyparallel/ipyparallel-8.6.1.ebuild2
-rw-r--r--dev-python/json5/Manifest1
-rw-r--r--dev-python/json5/json5-0.9.14.ebuild28
-rw-r--r--dev-python/poetry-core/Manifest1
-rw-r--r--dev-python/poetry-core/poetry-core-1.6.0.ebuild67
-rw-r--r--dev-python/snakeoil/snakeoil-0.10.5.ebuild2
-rw-r--r--dev-python/snakeoil/snakeoil-9999.ebuild2
18 files changed, 208 insertions, 9 deletions
diff --git a/dev-python/astroid/Manifest b/dev-python/astroid/Manifest
index cb4777aa7d05..f48397826226 100644
--- a/dev-python/astroid/Manifest
+++ b/dev-python/astroid/Manifest
@@ -1 +1,2 @@
DIST astroid-2.15.4.gh.tar.gz 461609 BLAKE2B 0dc54a0a99c16698e025f01361d67a5aa248e091f757184bfeb8b6287d656afbb56706a99058c0105252c6925dbe51e8ee260020d7512d7aa9bbf3d92d0a0b7e SHA512 1725676cd55fde0359e7210b917663fa82a87bbec052fda27a80a08e7d2308ab1de7a5c1f1a052fd76575d9945d55743e6c23684754e03e84bb2facb51f2a5a2
+DIST astroid-2.15.5.gh.tar.gz 461755 BLAKE2B 4af28becb14d767c3fa162be93cd1d3f99e42a476a7b1ee57225a6d5603876cbfde7a58e17412d1142baa42288cbb2cfe3ecdbaafe5195c777f04a3ad9fe4427 SHA512 9862a2f4703b36284d14a3b09f80b4b0a1e0948e306b4906ec663fc133d07966e24a711a90067b369b166ce4d53859327e1da84406a023d1a911fff7bb0ed026
diff --git a/dev-python/astroid/astroid-2.15.5.ebuild b/dev-python/astroid/astroid-2.15.5.ebuild
new file mode 100644
index 000000000000..553be35505ca
--- /dev/null
+++ b/dev-python/astroid/astroid-2.15.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/pylint-dev/astroid/
+ https://pypi.org/project/astroid/
+"
+SRC_URI="
+ https://github.com/pylint-dev/astroid/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Version specified in pyproject.toml
+RDEPEND="
+ >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ <dev-python/wrapt-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # no clue why they're broken
+ tests/test_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
+ tests/test_regrtest.py::NonRegressionTests::test_numpy_distutils
+ tests/brain/test_regex.py::TestRegexBrain::test_regex_pattern_and_match_subscriptable
+ # some problem with warnings (our options?)
+ tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_one_arg
+ tests/test_decorators.py::TestDeprecationDecorators::test_deprecated_default_argument_values_two_args
+ tests/test_scoped_nodes.py::test_deprecation_of_doc_attribute
+ # requires six bundled in urllib3, sigh
+ tests/test_modutils.py::test_file_info_from_modpath__SixMetaPathImporter
+ # requires pip, and looks suspicious anyway
+ tests/test_manager.py::IsolatedAstroidManagerTest::test_no_user_warning
+ )
+
+ # Faker causes sys.path_importer_cache keys to be overwritten
+ # with PosixPaths
+ epytest -p no:faker
+}
diff --git a/dev-python/flit_core/Manifest b/dev-python/flit-core/Manifest
index 836007983c05..b951ff5fec13 100644
--- a/dev-python/flit_core/Manifest
+++ b/dev-python/flit-core/Manifest
@@ -1 +1,2 @@
DIST flit_core-3.8.0.tar.gz 41224 BLAKE2B 20d0b1e245280938b1edfa83531907775af9da30cc6e1446d578eafc7e14184d3c8fb80f446d265456ea5ea587c51edfdb706793a8894916525b3ebba322b3b0 SHA512 914804e3f2040762381afe039272d9d6fdbcd3f3cf8b9eea854f2f1d95edcb01718fd6685476bc1cdc251dfc46ef80b40f087df881d8b963dcc3f3332fd32a46
+DIST flit_core-3.9.0.tar.gz 41917 BLAKE2B 2fb053655a494736f5f9ce2d2c193d5d98622e410c0c0f18c92eb62d32ff98cbe830a1728461ed7e7e087d2fcf5f6a0c912717c2d534be688d688c4714c6865b SHA512 1205589930d2c51d6aa6b2533a122a912e63b157e94adba2a0649a58d324fa98a5b84609d9b53e9d236f1cdb6a6984de2cefcf2f11abc2cd83956df21f269ad6
diff --git a/dev-python/flit_core/flit_core-3.8.0.ebuild b/dev-python/flit-core/flit-core-3.8.0.ebuild
index 2e0af2ca62fa..2e0af2ca62fa 100644
--- a/dev-python/flit_core/flit_core-3.8.0.ebuild
+++ b/dev-python/flit-core/flit-core-3.8.0.ebuild
diff --git a/dev-python/flit-core/flit-core-3.9.0.ebuild b/dev-python/flit-core/flit-core-3.9.0.ebuild
new file mode 100644
index 000000000000..020992e541b4
--- /dev/null
+++ b/dev-python/flit-core/flit-core-3.9.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simplified packaging of Python modules (core module)"
+HOMEPAGE="
+ https://pypi.org/project/flit-core/
+ https://github.com/pypa/flit/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ dev-python/tomli[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( dev-python/testpath[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ rm -r flit_core/vendor || die
+ sed -i -e 's:from \.vendor ::' flit_core/*.py || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/flit_core/metadata.xml b/dev-python/flit-core/metadata.xml
index 3f418d3bf441..3f418d3bf441 100644
--- a/dev-python/flit_core/metadata.xml
+++ b/dev-python/flit-core/metadata.xml
diff --git a/dev-python/flit/flit-3.8.0.ebuild b/dev-python/flit/flit-3.8.0.ebuild
index df4d7ba2fcdd..48819d18d3e4 100644
--- a/dev-python/flit/flit-3.8.0.ebuild
+++ b/dev-python/flit/flit-3.8.0.ebuild
@@ -16,7 +16,7 @@ KEYWORDS="~amd64 ~mips ~x86"
RDEPEND="
dev-python/docutils[${PYTHON_USEDEP}]
- >=dev-python/flit_core-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/flit-core-${PV}[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/requests_download[${PYTHON_USEDEP}]
dev-python/tomli[${PYTHON_USEDEP}]
@@ -49,6 +49,6 @@ distutils_enable_sphinx doc \
src_prepare() {
# make sure system install is used
- rm -r flit_core || die
+ rm -r flit-core || die
distutils-r1_src_prepare
}
diff --git a/dev-python/flit_scm/flit_scm-1.7.0.ebuild b/dev-python/flit_scm/flit_scm-1.7.0.ebuild
index d6ea2b8ac92e..5797cc218d54 100644
--- a/dev-python/flit_scm/flit_scm-1.7.0.ebuild
+++ b/dev-python/flit_scm/flit_scm-1.7.0.ebuild
@@ -22,7 +22,7 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
- >=dev-python/flit_core-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/flit-core-3.5.0[${PYTHON_USEDEP}]
>=dev-python/setuptools-scm-6.4.2[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
<dev-python/tomli-3[${PYTHON_USEDEP}]
diff --git a/dev-python/ipyparallel/ipyparallel-8.4.1.ebuild b/dev-python/ipyparallel/ipyparallel-8.4.1.ebuild
index 0c12d4a898f1..a3d735fe0687 100644
--- a/dev-python/ipyparallel/ipyparallel-8.4.1.ebuild
+++ b/dev-python/ipyparallel/ipyparallel-8.4.1.ebuild
@@ -35,7 +35,7 @@ RDEPEND="
>=dev-python/tornado-5.1[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/flit_core[${PYTHON_USEDEP}]
+ dev-python/flit-core[${PYTHON_USEDEP}]
test? (
dev-python/ipython[test]
dev-python/mock[${PYTHON_USEDEP}]
diff --git a/dev-python/ipyparallel/ipyparallel-8.5.1.ebuild b/dev-python/ipyparallel/ipyparallel-8.5.1.ebuild
index 0595348e1407..d8c4c8ac4031 100644
--- a/dev-python/ipyparallel/ipyparallel-8.5.1.ebuild
+++ b/dev-python/ipyparallel/ipyparallel-8.5.1.ebuild
@@ -35,7 +35,7 @@ RDEPEND="
>=dev-python/tornado-5.1[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/flit_core[${PYTHON_USEDEP}]
+ dev-python/flit-core[${PYTHON_USEDEP}]
test? (
dev-python/ipython[test]
dev-python/mock[${PYTHON_USEDEP}]
diff --git a/dev-python/ipyparallel/ipyparallel-8.6.0.ebuild b/dev-python/ipyparallel/ipyparallel-8.6.0.ebuild
index 20f0af6cba42..cbef2b46e711 100644
--- a/dev-python/ipyparallel/ipyparallel-8.6.0.ebuild
+++ b/dev-python/ipyparallel/ipyparallel-8.6.0.ebuild
@@ -35,7 +35,7 @@ RDEPEND="
>=dev-python/tornado-5.1[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/flit_core[${PYTHON_USEDEP}]
+ dev-python/flit-core[${PYTHON_USEDEP}]
test? (
dev-python/ipython[test]
dev-python/mock[${PYTHON_USEDEP}]
diff --git a/dev-python/ipyparallel/ipyparallel-8.6.1.ebuild b/dev-python/ipyparallel/ipyparallel-8.6.1.ebuild
index 20f0af6cba42..cbef2b46e711 100644
--- a/dev-python/ipyparallel/ipyparallel-8.6.1.ebuild
+++ b/dev-python/ipyparallel/ipyparallel-8.6.1.ebuild
@@ -35,7 +35,7 @@ RDEPEND="
>=dev-python/tornado-5.1[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/flit_core[${PYTHON_USEDEP}]
+ dev-python/flit-core[${PYTHON_USEDEP}]
test? (
dev-python/ipython[test]
dev-python/mock[${PYTHON_USEDEP}]
diff --git a/dev-python/json5/Manifest b/dev-python/json5/Manifest
index a0492fac5922..c1ba27ce2b26 100644
--- a/dev-python/json5/Manifest
+++ b/dev-python/json5/Manifest
@@ -1 +1,2 @@
DIST pyjson5-0.9.11.gh.tar.gz 111445 BLAKE2B 038ac1fab6e56e6dc45dc9bff1fc5e0da21c594cb0ac1f6d888f0207fddace9663b0dbd6abbfabce857cb9fcb40348002b10a6b4133e2f2ebb2081c543e1ad9c SHA512 aca3f38cd79d4bf52ceaf1b3dd27e30bf7598fa0b369216ac820f0c913797ebf542c9eaac17e562ee07006bf83c09210c799bc1b715c7b6e7689d2dcd702d414
+DIST pyjson5-0.9.14.gh.tar.gz 111681 BLAKE2B 7e341f1054da169e95885762f6f801eb9698007c735bfa7d4eb811a4e28a76265cf7215197e16a76184abc41f180ba8895b8120fb8f79bbf1e5f8b397d90c18d SHA512 586746398227d6dfd85c1f5e2cf69f6b4dce9529ffafcbf8d4be49c61196df3f466d5701873d0ab1b0c8851227db0874e1841d1daffcaf18d43efc0e8a171048
diff --git a/dev-python/json5/json5-0.9.14.ebuild b/dev-python/json5/json5-0.9.14.ebuild
new file mode 100644
index 000000000000..24c2cc9239dc
--- /dev/null
+++ b/dev-python/json5/json5-0.9.14.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=pyjson5-${PV}
+DESCRIPTION="A Python implementation of the JSON5 data format"
+HOMEPAGE="
+ https://github.com/dpranke/pyjson5/
+ https://pypi.org/project/json5/
+"
+# no tests in sdist, as of 0.9.14
+SRC_URI="
+ https://github.com/dpranke/pyjson5/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
diff --git a/dev-python/poetry-core/Manifest b/dev-python/poetry-core/Manifest
index b28d93f31e05..96c65feff1ed 100644
--- a/dev-python/poetry-core/Manifest
+++ b/dev-python/poetry-core/Manifest
@@ -1 +1,2 @@
DIST poetry-core-1.5.2.gh.tar.gz 484004 BLAKE2B 56fe974bb37233ee75a220d35dab3d246b9a4145a3abd88981a0c2b9f51cb894b3534746638d7fa75a41451c856261b0b8e737af8778f78fcc9ae894a4b2430f SHA512 e0eab97bcf678f8fd329074d14cb394db8732666b0387384d273db49ec020ff34e15e9982e049bce62e9ba80443404de7646e66433164a2358f9802a8ce2fbb1
+DIST poetry-core-1.6.0.gh.tar.gz 476282 BLAKE2B 9c78b60b0578c9e882c468d8523587e8ddf799764efc1d343fdbcbc7e1ac56cc642ecfa5e74a6b134d190491e06105579951fd4bc8d41264358032c2a6bd5fb7 SHA512 a8a36feda81fdf5b74de77cb718680a12edda44d0b6e87f5b80704d7a5898780b89dfa8168c55e4e8b2352f1a6051072e7e9f35dc5936d1b0b24a1704063ed1d
diff --git a/dev-python/poetry-core/poetry-core-1.6.0.ebuild b/dev-python/poetry-core/poetry-core-1.6.0.ebuild
new file mode 100644
index 000000000000..6a16a851d629
--- /dev/null
+++ b/dev-python/poetry-core/poetry-core-1.6.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Poetry PEP 517 Build Backend"
+HOMEPAGE="
+ https://github.com/python-poetry/poetry-core/
+ https://pypi.org/project/poetry-core/
+"
+SRC_URI="
+ https://github.com/python-poetry/poetry-core/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# check inside src/poetry/core/_vendor/vendor.txt
+# (note that some are indirect deps)
+RDEPEND="
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lark[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pep517[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # These "fail" bacause of glob file path resulting from newer versions
+ # in our tree than vendored. But those don't affect anything.
+ tests/masonry/builders/test_sdist.py::test_default_with_excluded_data
+ tests/masonry/builders/test_wheel.py::test_default_src_with_excluded_data
+)
+
+src_prepare() {
+ # remove vendoring of dependencies
+ rm -r src/poetry/core/_vendor || die
+ sed -e '/__vendor_site__/d' -i src/poetry/core/__init__.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # needed for migration from <1.1
+ distutils_write_namespace poetry
+ epytest
+}
diff --git a/dev-python/snakeoil/snakeoil-0.10.5.ebuild b/dev-python/snakeoil/snakeoil-0.10.5.ebuild
index 2aad99caa00b..482fefe4c744 100644
--- a/dev-python/snakeoil/snakeoil-0.10.5.ebuild
+++ b/dev-python/snakeoil/snakeoil-0.10.5.ebuild
@@ -27,7 +27,7 @@ RDEPEND="
dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
"
BDEPEND="
- >=dev-python/flit_core-3.8[${PYTHON_USEDEP}]
+ >=dev-python/flit-core-3.8[${PYTHON_USEDEP}]
"
distutils_enable_tests pytest
diff --git a/dev-python/snakeoil/snakeoil-9999.ebuild b/dev-python/snakeoil/snakeoil-9999.ebuild
index fece6e6a0bc8..74a0f38c31af 100644
--- a/dev-python/snakeoil/snakeoil-9999.ebuild
+++ b/dev-python/snakeoil/snakeoil-9999.ebuild
@@ -27,7 +27,7 @@ RDEPEND="
dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
"
BDEPEND="
- >=dev-python/flit_core-3.8[${PYTHON_USEDEP}]
+ >=dev-python/flit-core-3.8[${PYTHON_USEDEP}]
"
distutils_enable_tests pytest