summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-evdev/python-evdev-0.7.0-r1.ebuild (renamed from dev-python/python-evdev/python-evdev-0.7.0.ebuild)8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/python-evdev/python-evdev-0.7.0.ebuild b/dev-python/python-evdev/python-evdev-0.7.0-r1.ebuild
index 4a7a95efedad..8f45fd510f8f 100644
--- a/dev-python/python-evdev/python-evdev-0.7.0.ebuild
+++ b/dev-python/python-evdev/python-evdev-0.7.0-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
inherit distutils-r1
@@ -16,3 +16,9 @@ KEYWORDS="~amd64 ~arm ~x86"
IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_compile() {
+ distutils-r1_python_compile build_ecodes \
+ --evdev-headers \
+ "${SYSROOT}"/usr/include/linux/input.h:"${SYSROOT}"/usr/include/linux/input-event-codes.h
+}