summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild')
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
index e2189976b477..e56c6cce8a45 100644
--- a/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.10.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
DESCRIPTION="Library for testing asyncio code with pytest"
@@ -27,6 +27,10 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
)"
+PATCHES=(
+ "${FILESDIR}"/pytest-asyncio-0.10.0-py38.patch
+)
+
python_test() {
distutils_install_for_testing
pytest -vv || die "Tests fail with ${EPYTHON}"