summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyclipper/pyclipper-1.1.0_p3-r1.ebuild')
-rw-r--r--dev-python/pyclipper/pyclipper-1.1.0_p3-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pyclipper/pyclipper-1.1.0_p3-r1.ebuild b/dev-python/pyclipper/pyclipper-1.1.0_p3-r1.ebuild
new file mode 100644
index 000000000000..e01613c52f83
--- /dev/null
+++ b/dev-python/pyclipper/pyclipper-1.1.0_p3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Cython wrapper for the C++ translation of the Angus Johnson's Clipper library"
+HOMEPAGE="https://github.com/fonttools/pyclipper"
+SRC_URI="https://github.com/fonttools/pyclipper/archive/${PV/_p/.post}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools-git[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest-runner[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+DEPEND=""
+
+distutils_enable_tests pytest
+
+S="${WORKDIR}/${P/_p/.post}"
+
+src_prepare() {
+ distutils-r1_src_prepare
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV/_p/.post}"
+}