summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jupyter_client')
-rw-r--r--dev-python/jupyter_client/Manifest1
-rw-r--r--dev-python/jupyter_client/jupyter_client-7.1.0.ebuild44
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/jupyter_client/Manifest b/dev-python/jupyter_client/Manifest
index b8817cac93e7..dbb435536101 100644
--- a/dev-python/jupyter_client/Manifest
+++ b/dev-python/jupyter_client/Manifest
@@ -1,2 +1 @@
-DIST jupyter_client-7.1.0.tar.gz 323501 BLAKE2B fa431f70b327a98be3958b2c39a2aa07ab0ec3752f069bc5e6d0645ac0660074974c871b159002dcbf3054c97860dc6b0e289c34826d929f0493479cd9f37ed2 SHA512 eb9456088c19d3780d943fb9457ded5e006afb7e7ebd726d8a253f91107d8e1839cac16e25466c902ff33ed2777e97e18b08e24092ddbb062aa9cf6336dc8921
DIST jupyter_client-7.1.2.tar.gz 326163 BLAKE2B 0cc11210cc3a472585d21acb836e316540d768c8c9ccc4a024720b278f3e2425e645080d8dcd501c118b3759bd354bf4f384821e87f1be0b7525addad6c267e0 SHA512 7baadc7d508c25ea588d0d7a6da8eb5a28fe4dbce32c9dfa1f9b2b82c7c3d7ae8c034cc03414b3eafec620931bd760c0844421197c01a3d25597af18f6e60060
diff --git a/dev-python/jupyter_client/jupyter_client-7.1.0.ebuild b/dev-python/jupyter_client/jupyter_client-7.1.0.ebuild
deleted file mode 100644
index 33d4c5b50950..000000000000
--- a/dev-python/jupyter_client/jupyter_client-7.1.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
-
-DESCRIPTION="Jupyter protocol implementation and client libraries"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/entrypoints[${PYTHON_USEDEP}]
- >=dev-python/jupyter_core-4.6.0[${PYTHON_USEDEP}]
- >=dev-python/nest_asyncio-1.5[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
- >=www-servers/tornado-4.1[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-7.0.6-test-timeout.patch
-)
-
-EPYTEST_DESELECT=(
- jupyter_client/tests/test_kernelmanager.py::TestKernelManagerShutDownGracefully::test_signal_kernel_subprocesses
- jupyter_client/tests/test_kernelmanager.py::TestKernelManagerShutDownGracefully::test_async_signal_kernel_subprocesses
-)
-
-distutils_enable_tests pytest