summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/identify')
-rw-r--r--dev-python/identify/Manifest1
-rw-r--r--dev-python/identify/identify-2.5.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index 850de231ad30..5bf01b3f2948 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1,2 +1,3 @@
DIST identify-2.4.12.gh.tar.gz 101366 BLAKE2B 55c1b7642d3f273beb415fabc683bfff46c1039fcf146d7c9c09f53b2beffab82e5e687849cbae6b7d2d9d0502a340e635ced730afa6610d20d75f0412943635 SHA512 8b9554a0a726e6fd25ca0fe1031b0a8a114fe98e13e41e73ad6549495a0dc02a2047c151f7717d8df705aba661e11ab1c0e48eff0bcf4d2a0dcff00f5ace1eec
DIST identify-2.5.0.gh.tar.gz 101367 BLAKE2B f927861976aaa2c53e5bd131b84f299c7290111e18a167040298784ebc3b562180b69d4a22661c858e7e56abde69c2e0fd5048c023d0c84af069748a85ccc4fb SHA512 d7b9d7b31262fdb97fdb16caea01ae0e0e0cee2b5a10b0224b53b84842c3c1e0e1914829bc89439718ae25c68cfde23328f79780b847087d445bdbf3a64aef1b
+DIST identify-2.5.1.gh.tar.gz 101393 BLAKE2B 8586721838c427b00a7c70e842d2ab1a2f0437909d84d5cba6614aff3f8265f17b5137628bdd78e5f324fbf6a0fef8b5ca0246e6861af023c2d9a1a323cc43f6 SHA512 8b61dd03bcdb8908a1a7f3b13d66121bb4f4bb3aab57672bff55a84232dcff310214ed0a90cfcf79846da9abc111bff08761ec9dd40c8b9b183bfbbf365efac4
diff --git a/dev-python/identify/identify-2.5.1.ebuild b/dev-python/identify/identify-2.5.1.ebuild
new file mode 100644
index 000000000000..8ce2bd5b0e7d
--- /dev/null
+++ b/dev-python/identify/identify-2.5.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest