summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/audioread/audioread-1.0.1-r1.ebuild')
-rw-r--r--dev-python/audioread/audioread-1.0.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/audioread/audioread-1.0.1-r1.ebuild b/dev-python/audioread/audioread-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..5c8a480f88b7
--- /dev/null
+++ b/dev-python/audioread/audioread-1.0.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for decoding audio files using whichever backend is available"
+HOMEPAGE="https://pypi.python.org/pypi/audioread"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="|| ( dev-python/pymad media-video/ffmpeg )"
+
+PATCHES=(
+ "${FILESDIR}/0001-Use-the-print-function-instead-of-the-print-keyword.patch"
+ )
+
+pkg_postinst() {
+ einfo "You might need to enable additional USE flags in backends to"
+ einfo "decode some types of audio files. Priority of backends:"
+ einfo " * mad"
+ einfo " * ffmpeg"
+}