summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Crypt-Twofish')
-rw-r--r--dev-perl/Crypt-Twofish/Crypt-Twofish-2.180.0-r1.ebuild (renamed from dev-perl/Crypt-Twofish/Crypt-Twofish-2.180.0.ebuild)6
-rw-r--r--dev-perl/Crypt-Twofish/files/Crypt-Twofish-2.180.0-configure-clang16.patch13
2 files changed, 18 insertions, 1 deletions
diff --git a/dev-perl/Crypt-Twofish/Crypt-Twofish-2.180.0.ebuild b/dev-perl/Crypt-Twofish/Crypt-Twofish-2.180.0-r1.ebuild
index 08416159288b..5468e3cab0b2 100644
--- a/dev-perl/Crypt-Twofish/Crypt-Twofish-2.180.0.ebuild
+++ b/dev-perl/Crypt-Twofish/Crypt-Twofish-2.180.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,6 +12,10 @@ DESCRIPTION="The Twofish Encryption Algorithm"
SLOT="0"
KEYWORDS="amd64 ~ia64 ~ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.180.0-configure-clang16.patch
+)
+
src_compile() {
mymake=(
"OPTIMIZE=${CFLAGS}"
diff --git a/dev-perl/Crypt-Twofish/files/Crypt-Twofish-2.180.0-configure-clang16.patch b/dev-perl/Crypt-Twofish/files/Crypt-Twofish-2.180.0-configure-clang16.patch
new file mode 100644
index 000000000000..4dbb15364190
--- /dev/null
+++ b/dev-perl/Crypt-Twofish/files/Crypt-Twofish-2.180.0-configure-clang16.patch
@@ -0,0 +1,13 @@
+https://gitlab.com/fweimer-rh/fedora-modernc/-/commit/1dfd7bb468b91abb93f6b3c54c8b1dcdaf8ccdff
+https://rt.cpan.org/Public/Bug/Display.html?id=145461
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -6,6 +6,7 @@ use ExtUtils::MakeMaker;
+
+ ($stdint = <<"TEST") =~ s/^\| {0,3}//gm;
+ | #include <stdint.h>
++| #include <stdio.h>
+ | int main(void) {
+ | printf("%d%d", sizeof(uint16_t), sizeof(uint32_t));
+ | return 0;
+