summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/roswell/Manifest1
-rw-r--r--dev-lisp/roswell/files/roswell-21.10.14.111.patch27
-rw-r--r--dev-lisp/roswell/roswell-23.10.14.114.ebuild36
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-lisp/roswell/Manifest b/dev-lisp/roswell/Manifest
index c903d88e30f5..07a47ae5562f 100644
--- a/dev-lisp/roswell/Manifest
+++ b/dev-lisp/roswell/Manifest
@@ -1,3 +1,4 @@
DIST roswell-20.05.14.106.tar.gz 164302 BLAKE2B bd2387bea78a746d5cfedc27e9d636ef7bc0f5118036ae2270c49a4361268527fafe2683850a2dcaeb1bf3f14db6a24fecd98f395081fdc1b4db620838d2936f SHA512 03a923accc4d6ac9a3a3e0fd1853441bf4be0268571e8b6ffffc122170befad6b1dcda6f062a566b54229bb325efb6a5d39459ce22a89355e927e3fea1e08cee
DIST roswell-21.10.14.111.tar.gz 172464 BLAKE2B 816f2fbbf99be21f7416456fb724faf5e290090ad2130bdd6feb03573cb059bf21bd5419cbf5928c84d2a977c123b31597df6676f65a11ded0121acc37c589aa SHA512 d6979974807385e1e7be993610b5ed6ef5297ded21727162b6bc3240d402168cfe32b6b243f535c69b91620d0af4a3b7e046080be2881610ffbe0d3babfa3b23
DIST roswell-22.12.14.113.tar.gz 170253 BLAKE2B ddb59d1778b0d0becfc8914edec850203aea979357ac8f33988053afaaa21c8302800af0b44a3e00e694b5deedf1c5d3306f47f8bce5d5f5b4aa5f8c8961e173 SHA512 f102297af67b5d5414f853fc428f39347cb09a604bff95ad50c7f5249582a053e00fa3bb59a52846e3afc8244b8de1a7ee4667847b829f7d176121c496fd038f
+DIST roswell-23.10.14.114.tar.gz 171258 BLAKE2B 107c6d7c70077236ed588c84238c2d44b693742f787c5db17923c14a30c870121eed8aadfabfce98d373b06c090aaa77f5152085ff38e699f8e571d2e913386a SHA512 9bc4962d5e132c20a896342fff28138692e79a91657aa1d8642f431eaa2f757d72d92a792b079cfb9cf55e196af453f0e420d0f9e927a1c8f0daf93d54506bf4
diff --git a/dev-lisp/roswell/files/roswell-21.10.14.111.patch b/dev-lisp/roswell/files/roswell-21.10.14.111.patch
new file mode 100644
index 000000000000..ff82a1013d41
--- /dev/null
+++ b/dev-lisp/roswell/files/roswell-21.10.14.111.patch
@@ -0,0 +1,27 @@
+--- roswell-21.10.14.111/configure.ac.ORIG 2022-04-11 14:29:44.336778578 +0000
++++ roswell-21.10.14.111/configure.ac 2022-04-11 14:31:42.549505141 +0000
+@@ -59,9 +59,11 @@
+
+ AC_CHECK_HEADERS(gnu/libc-version.h)
+
+-AC_CHECK_HEADERS(windows.h,[with_windows=true])
++#AC_CHECK_HEADERS(windows.h,[with_windows=true])
++with_windows=
+ AM_CONDITIONAL([WITH_WINDOWS], [test "$with_windows" != ""])
+-AC_CHECK_TOOL([WINDRES], [windres], [])
++#AC_CHECK_TOOL([WINDRES], [windres], [])
++WINDRES=
+ AM_CONDITIONAL([WITH_WIN_ICON], [test "$WINDRES" != ""])
+
+ AC_CHECK_MEMBERS([struct dirent.d_type],,,[#include <dirent.h>])
+--- roswell-21.10.14.111/Makefile.am.ORIG 2022-04-11 14:28:16.220579397 +0000
++++ roswell-21.10.14.111/Makefile.am 2022-04-11 14:28:56.773113318 +0000
+@@ -167,7 +167,7 @@
+
+ pack: $(PACK).tar.bz2
+
+-WINPACK = roswell_$(VERSION)_$(shell if [ $$MSYSTEM = 'MINGW64' ];then echo amd64 ;else echo i686; fi)
++#WINPACK = roswell_$(VERSION)_$(shell if [ $$MSYSTEM = 'MINGW64' ];then echo amd64 ;else echo i686; fi)
+
+ pack.zip: $(PACK).tar.bz2
+ 7z a $(WINPACK).zip roswell \ No newline at end of file
diff --git a/dev-lisp/roswell/roswell-23.10.14.114.ebuild b/dev-lisp/roswell/roswell-23.10.14.114.ebuild
new file mode 100644
index 000000000000..4cc2bc188d97
--- /dev/null
+++ b/dev-lisp/roswell/roswell-23.10.14.114.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A lisp installer and launcher for major environment"
+HOMEPAGE="https://github.com/roswell/roswell"
+SRC_URI="https://github.com/roswell/roswell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+
+# File collision with librouteros (#691754)
+RDEPEND="!net-libs/librouteros
+ net-misc/curl"
+DEPEND="${RDEPEND}"
+
+# Patch from #822126
+src_prepare() {
+ PATCHES=( "${FILESDIR}/roswell-21.10.14.111.patch" )
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/856106
+ # https://github.com/roswell/roswell/issues/584
+ filter-lto
+
+ default
+}