summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libdynd/files')
-rw-r--r--dev-libs/libdynd/files/libdynd-0.6.0-dont-install-test.patch15
-rw-r--r--dev-libs/libdynd/files/libdynd-0.6.0-optional-cblosc.patch27
-rw-r--r--dev-libs/libdynd/files/libdynd-0.6.0-out-of-git-versioning.patch14
-rw-r--r--dev-libs/libdynd/files/libdynd-0.6.0-respect-libdir.patch15
-rw-r--r--dev-libs/libdynd/files/libdynd-0.6.2-out-of-git-versioning.patch15
5 files changed, 86 insertions, 0 deletions
diff --git a/dev-libs/libdynd/files/libdynd-0.6.0-dont-install-test.patch b/dev-libs/libdynd/files/libdynd-0.6.0-dont-install-test.patch
new file mode 100644
index 000000000000..9659372b05ea
--- /dev/null
+++ b/dev-libs/libdynd/files/libdynd-0.6.0-dont-install-test.patch
@@ -0,0 +1,15 @@
+--- tests/CMakeLists.txt.orig 2014-02-10 14:25:18.041841087 -0800
++++ tests/CMakeLists.txt 2014-02-10 14:25:40.224975614 -0800
+@@ -105,12 +105,6 @@
+ )
+ endif()
+
+-# If installation is requested, install the program
+-if (DYND_INSTALL_LIB)
+- install(TARGETS test_libdynd
+- RUNTIME DESTINATION bin)
+-endif()
+-
+ # Compile-time tests: test code that is supposed to produce compile errors
+ # I couldn't find a properly specified way to do this, so hacked together
+ # this function.
diff --git a/dev-libs/libdynd/files/libdynd-0.6.0-optional-cblosc.patch b/dev-libs/libdynd/files/libdynd-0.6.0-optional-cblosc.patch
new file mode 100644
index 000000000000..d801eb65b437
--- /dev/null
+++ b/dev-libs/libdynd/files/libdynd-0.6.0-optional-cblosc.patch
@@ -0,0 +1,27 @@
+--- CMakeLists.txt.orig 2014-02-10 14:26:48.299381259 -0800
++++ CMakeLists.txt 2014-02-10 14:51:16.401051546 -0800
+@@ -56,8 +56,22 @@
+ set(CMAKE_VERBOSE_MAKEFILE 1)
+
+ # Embedded libraries
+-add_subdirectory(thirdparty/blosc)
+-include_directories(thirdparty/blosc/blosc)
++option(DYND_INTERNAL_CBLOSC
++ "Build and use the bundled c-blosc library"
++ OFF)
++if(DYND_INTERNAL_CBLOSC)
++ add_subdirectory(thirdparty/blosc)
++ include_directories(thirdparty/blosc/blosc)
++else()
++ find_path(CBLOSC_INCLUDE_DIR blosc.h)
++ find_library(CBLOSC_LIBRARY NAMES blosc)
++ if (CBLOSC_INCLUDE_DIR AND CBLOSC_LIBRARY)
++ message(STATUS "Found c-blosc library: ${CBLOSC_LIBRARY}")
++ else ()
++ message(ERROR "No c-blosc found. Consider using internal sources.")
++ endif()
++endif(DYND_INTERNAL_CBLOSC)
++
+ add_subdirectory(thirdparty/datetime)
+ include_directories(thirdparty/datetime/include)
+
diff --git a/dev-libs/libdynd/files/libdynd-0.6.0-out-of-git-versioning.patch b/dev-libs/libdynd/files/libdynd-0.6.0-out-of-git-versioning.patch
new file mode 100644
index 000000000000..65c32da8a55c
--- /dev/null
+++ b/dev-libs/libdynd/files/libdynd-0.6.0-out-of-git-versioning.patch
@@ -0,0 +1,14 @@
+--- CMakeLists.txt.orig 2014-02-10 14:26:48.299381259 -0800
++++ CMakeLists.txt 2014-02-10 14:55:48.245644726 -0800
+@@ -86,9 +86,8 @@
+ endif()
+
+ # Get the git revision
+-include(GetGitRevisionDescriptionDyND)
+-get_git_head_revision("${CMAKE_CURRENT_SOURCE_DIR}" GIT_REFSPEC DYND_GIT_SHA1)
+-git_describe("${CMAKE_CURRENT_SOURCE_DIR}" DYND_VERSION_STRING --dirty --match "v[0-9]*")
++set(DYND_GIT_SHA1 "9f2e102e3b0c44da82feaa431bb89a5d71b40498")
++set(DYND_VERSION_STRING "v0.6.0")
+ message(STATUS "DyND version: ${DYND_VERSION_STRING}")
+ configure_file(
+ "${CMAKE_CURRENT_SOURCE_DIR}/src/dynd/git_version.cpp.in"
diff --git a/dev-libs/libdynd/files/libdynd-0.6.0-respect-libdir.patch b/dev-libs/libdynd/files/libdynd-0.6.0-respect-libdir.patch
new file mode 100644
index 000000000000..b3639802808c
--- /dev/null
+++ b/dev-libs/libdynd/files/libdynd-0.6.0-respect-libdir.patch
@@ -0,0 +1,15 @@
+--- CMakeLists.txt.orig 2014-02-10 14:26:48.299381259 -0800
++++ CMakeLists.txt 2014-02-10 14:27:42.511704585 -0800
+@@ -481,9 +481,9 @@
+ if (DYND_INSTALL_LIB)
+ # Install the libdynd binary
+ install(TARGETS libdynd
+- RUNTIME DESTINATION lib
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib/static)
++ RUNTIME DESTINATION lib${LIB_SUFFIX}
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
++ ARCHIVE DESTINATION lib${LIB_SUFFIX}/static)
+ # Install the libdynd headers
+ install(DIRECTORY "include/dynd" DESTINATION "${CMAKE_INSTALL_PREFIX}/include")
+ # Install the libdynd-config script
diff --git a/dev-libs/libdynd/files/libdynd-0.6.2-out-of-git-versioning.patch b/dev-libs/libdynd/files/libdynd-0.6.2-out-of-git-versioning.patch
new file mode 100644
index 000000000000..92b7ec027ec2
--- /dev/null
+++ b/dev-libs/libdynd/files/libdynd-0.6.2-out-of-git-versioning.patch
@@ -0,0 +1,15 @@
+--- CMakeLists.txt.orig 2014-05-01 20:43:13.000000000 +0400
++++ CMakeLists.txt 2014-05-12 13:56:55.000000000 +0400
+@@ -112,9 +112,9 @@
+ endif()
+
+ # Get the git revision
+-include(GetGitRevisionDescriptionDyND)
+-get_git_head_revision("${CMAKE_CURRENT_SOURCE_DIR}" GIT_REFSPEC DYND_GIT_SHA1)
+-git_describe("${CMAKE_CURRENT_SOURCE_DIR}" DYND_VERSION_STRING --dirty --always --match "v*")
++SET(DYND_GIT_SHA1 "@DYND_GIT_SHA1@")
++SET(DYND_VERSION_STRING "@DYND_VERSION@")
++
+ message(STATUS "DyND version: ${DYND_VERSION_STRING}")
+ configure_file(
+ "${CMAKE_CURRENT_SOURCE_DIR}/src/dynd/git_version.cpp.in"