summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/spidermonkey/spidermonkey-78.10.1.ebuild')
-rw-r--r--dev-lang/spidermonkey/spidermonkey-78.10.1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-lang/spidermonkey/spidermonkey-78.10.1.ebuild b/dev-lang/spidermonkey/spidermonkey-78.10.1.ebuild
index e5bacf41b892..b6cfe9ac6336 100644
--- a/dev-lang/spidermonkey/spidermonkey-78.10.1.ebuild
+++ b/dev-lang/spidermonkey/spidermonkey-78.10.1.ebuild
@@ -113,6 +113,11 @@ RDEPEND="${CDEPEND}"
S="${WORKDIR}/firefox-${MY_PV}/js/src"
llvm_check_deps() {
+ if ! has_version -b "sys-devel/llvm:${LLVM_SLOT}" ; then
+ ewarn "sys-devel/llvm:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
+ return 1
+ fi
+
if use clang ; then
if ! has_version -b "sys-devel/clang:${LLVM_SLOT}" ; then
ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2