summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/perl/perl-5.32.0.ebuild')
-rw-r--r--dev-lang/perl/perl-5.32.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-lang/perl/perl-5.32.0.ebuild b/dev-lang/perl/perl-5.32.0.ebuild
index b375dbc322bb..86be1e04a1c1 100644
--- a/dev-lang/perl/perl-5.32.0.ebuild
+++ b/dev-lang/perl/perl-5.32.0.ebuild
@@ -464,6 +464,10 @@ src_configure() {
[[ ${CHOST} == *-darwin* && ${CHOST##*darwin} -le 9 ]] && tc-is-gcc && \
append-cflags -Dinline=__inline__
+ # flock on 32-bit sparc Solaris is broken, fall back to fcntl
+ [[ ${CHOST} == sparc-*-solaris* ]] && \
+ myconf -Ud_flock
+
# Prefix: the host system needs not to follow Gentoo multilib stuff, and in
# Prefix itself we don't do multilib either, so make sure perl can find
# something compatible.
@@ -471,7 +475,7 @@ src_configure() {
# Set a hook to check for each detected library whether it actually works.
export libscheck="
( echo 'main(){}' > '${T}'/conftest.c &&
- $(tc-getCC) -o '${T}'/conftest '${T}'/conftest.c -l\$thislib >/dev/null 2>/dev/null
+ $(tc-getCC) -o '${T}'/conftest '${T}'/conftest.c -l\$thislib >/dev/null 2>/dev/null
) || xxx=/dev/null"
# Use all host paths that might contain useful stuff, the hook above will filter out bad choices.