summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/gnat-gpl/gnat-gpl-2017-r1.ebuild')
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2017-r1.ebuild29
1 files changed, 13 insertions, 16 deletions
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2017-r1.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2017-r1.ebuild
index bff11256c1f6..bdbf1fafb6e7 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2017-r1.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2017-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -51,9 +51,18 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/${MYP}
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
-pkg_setup() {
- toolchain_pkg_setup
+src_unpack() {
+ if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
+ eerror "You need a gcc compiler that provides the Ada Compiler:"
+ eerror "1) use gcc-config to select the right compiler or"
+ eerror "2) set the bootstrap use flag"
+ die "ada compiler not available"
+ fi
+
+ toolchain_src_unpack
+}
+src_prepare() {
if use amd64; then
BTSTRP=${BTSTRP_AMD64}
else
@@ -73,23 +82,11 @@ pkg_setup() {
if [[ ${gnatpath} != "." ]] ; then
GNATMAKE="${gnatpath}/${GNATMAKE}"
fi
-}
-src_unpack() {
- if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
- eerror "You need a gcc compiler that provides the Ada Compiler:"
- eerror "1) use gcc-config to select the right compiler or"
- eerror "2) set the bootstrap use flag"
- die "ada compiler not available"
- fi
-
- toolchain_src_unpack
if use bootstrap; then
- rm ${BTSTRP}/libexec/gcc/*/4.7.4/ld || die
+ rm "${WORKDIR}"/${BTSTRP}/libexec/gcc/*/4.7.4/ld || die
fi
-}
-src_prepare() {
CC=${GCC}
CXX="${gnatbase/gcc/g++}"
GNATBIND="${gnatbase/gcc/gnatbind}"