summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/edit-distance/edit-distance-0.2.1.2.ebuild')
-rw-r--r--dev-haskell/edit-distance/edit-distance-0.2.1.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/edit-distance/edit-distance-0.2.1.2.ebuild b/dev-haskell/edit-distance/edit-distance-0.2.1.2.ebuild
new file mode 100644
index 000000000000..f1fe33eca530
--- /dev/null
+++ b/dev-haskell/edit-distance/edit-distance-0.2.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Levenshtein and restricted Damerau-Levenshtein edit distances"
+HOMEPAGE="http://github.com/batterseapower/edit-distance"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND=">=dev-haskell/random-1.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+src_prepare() {
+ sed -e 's@LANGUAGE @LANGUAGE FlexibleContexts, @' \
+ -i "${S}/Text/EditDistance/STUArray.hs" || die
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=splitbase \
+ --flag=-benchmark \
+ --flag=-tests
+}