summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/clhpp/clhpp-2023.04.17.ebuild5
-rw-r--r--dev-cpp/clhpp/clhpp-2023.12.14.ebuild5
2 files changed, 4 insertions, 6 deletions
diff --git a/dev-cpp/clhpp/clhpp-2023.04.17.ebuild b/dev-cpp/clhpp/clhpp-2023.04.17.ebuild
index 9c106083d8d2..d52bb6938cc5 100644
--- a/dev-cpp/clhpp/clhpp-2023.04.17.ebuild
+++ b/dev-cpp/clhpp/clhpp-2023.04.17.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,7 +15,6 @@ SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/refs/tags/v${PV}.tar.g
LICENSE="Khronos-CLHPP"
SLOT="0"
KEYWORDS="amd64 ppc64 x86"
-IUSE="test"
# Tests require CMock (NOT cmocka), which is currently not in Gentoo
# and has been found to be extremely awkward to package.
@@ -33,7 +32,7 @@ src_configure() {
local mycmakeargs=(
-DBUILD_DOCS=OFF
-DBUILD_EXAMPLES=OFF
- -DBUILD_TESTING=$(usex test)
+ -DBUILD_TESTING=OFF
)
cmake_src_configure
}
diff --git a/dev-cpp/clhpp/clhpp-2023.12.14.ebuild b/dev-cpp/clhpp/clhpp-2023.12.14.ebuild
index a9a4c55d1789..624fd2782101 100644
--- a/dev-cpp/clhpp/clhpp-2023.12.14.ebuild
+++ b/dev-cpp/clhpp/clhpp-2023.12.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,7 +15,6 @@ SRC_URI="https://github.com/KhronosGroup/${MY_PN}/archive/refs/tags/v${PV}.tar.g
LICENSE="Khronos-CLHPP"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
-IUSE="test"
# Tests require CMock (NOT cmocka), which is currently not in Gentoo
# and has been found to be extremely awkward to package.
@@ -33,7 +32,7 @@ src_configure() {
local mycmakeargs=(
-DBUILD_DOCS=OFF
-DBUILD_EXAMPLES=OFF
- -DBUILD_TESTING=$(usex test)
+ -DBUILD_TESTING=OFF
)
cmake_src_configure
}