summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0.ebuild')
-rw-r--r--dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0.ebuild b/dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0.ebuild
new file mode 100644
index 000000000000..a41d26101436
--- /dev/null
+++ b/dev-cpp/cpp-taskflow/cpp-taskflow-2.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Modern C++ Parallel Task Programming"
+HOMEPAGE="https://cpp-taskflow.github.io"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND=""
+
+HTML_DOCS=( docs/. )
+
+src_install() {
+ insinto /usr/include
+ doins -r taskflow
+
+ if $(use doc); then
+ einstalldocs
+ fi
+}