summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/openpaperwork-core/openpaperwork-core-2.2.1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/app-text/openpaperwork-core/openpaperwork-core-2.2.1.ebuild b/app-text/openpaperwork-core/openpaperwork-core-2.2.1.ebuild
index ec1063f19429..add748104564 100644
--- a/app-text/openpaperwork-core/openpaperwork-core-2.2.1.ebuild
+++ b/app-text/openpaperwork-core/openpaperwork-core-2.2.1.ebuild
@@ -18,8 +18,15 @@ KEYWORDS="~amd64 ~x86"
RDEPEND="dev-python/distro[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
-BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ sys-devel/gettext"
S=${WORKDIR}/paperwork-${PV}/${PN}
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_compile() {
+ emake l10n_compile
+
+ distutils-r1_python_compile
+}