summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/vertico/vertico-9999.ebuild')
-rw-r--r--app-emacs/vertico/vertico-9999.ebuild23
1 files changed, 15 insertions, 8 deletions
diff --git a/app-emacs/vertico/vertico-9999.ebuild b/app-emacs/vertico/vertico-9999.ebuild
index 8623d46e2c78..49dee1806f65 100644
--- a/app-emacs/vertico/vertico-9999.ebuild
+++ b/app-emacs/vertico/vertico-9999.ebuild
@@ -1,36 +1,43 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-NEED_EMACS=27.1
+NEED_EMACS="28.1"
inherit elisp
DESCRIPTION="Vertical interactive completion"
HOMEPAGE="https://github.com/minad/vertico/"
-if [[ ${PV} == *9999* ]] ; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+
+ EGIT_REPO_URI="https://github.com/minad/${PN}"
else
SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
+ -> ${P}.gh.tar.gz"
+
KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-3+"
SLOT="0"
-RDEPEND=">=app-emacs/compat-29.1.4.0"
-BDEPEND="${RDEPEND}"
+RDEPEND="
+ >=app-emacs/compat-30.0.2.0
+"
+BDEPEND="
+ ${RDEPEND}
+"
DOCS=( CHANGELOG.org README.org )
SITEFILE="50${PN}-gentoo.el"
src_prepare() {
default
- mv extensions/*.el ./ || die
+
+ mv ./extensions/*.el ./ || die
}
src_compile() {