summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/openssl-tpm-engine/openssl-tpm-engine-0.4.2.ebuild')
-rw-r--r--app-crypt/openssl-tpm-engine/openssl-tpm-engine-0.4.2.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/app-crypt/openssl-tpm-engine/openssl-tpm-engine-0.4.2.ebuild b/app-crypt/openssl-tpm-engine/openssl-tpm-engine-0.4.2.ebuild
index 9539e900227a..377fb2d56211 100644
--- a/app-crypt/openssl-tpm-engine/openssl-tpm-engine-0.4.2.ebuild
+++ b/app-crypt/openssl-tpm-engine/openssl-tpm-engine-0.4.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit autotools eutils
@@ -21,15 +21,23 @@ RDEPEND="
>=app-crypt/trousers-0.2.8"
DEPEND="${RDEPEND}"
+DOCS=(
+ openssl.cnf.sample
+)
+
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+)
+
S="${WORKDIR}/${MY_P}"
src_prepare() {
+ default
mv configure.in configure.ac || die
- epatch "${FILESDIR}/${P}-build.patch"
eautoreconf
}
src_install() {
default
- dodoc openssl.cnf.sample
+ prune_libtool_files --modules
}