summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/zpipe/zpipe-2.01-r1.ebuild')
-rw-r--r--app-arch/zpipe/zpipe-2.01-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-arch/zpipe/zpipe-2.01-r1.ebuild b/app-arch/zpipe/zpipe-2.01-r1.ebuild
new file mode 100644
index 000000000000..53985a440783
--- /dev/null
+++ b/app-arch/zpipe/zpipe-2.01-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+MY_P=${PN}.${PV/./}
+DESCRIPTION="Pipe compressor/decompressor for ZPAQ"
+HOMEPAGE="http://mattmahoney.net/dc/zpaq.html"
+SRC_URI="http://mattmahoney.net/dc/${MY_P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="<app-arch/libzpaq-7"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" LDLIBS=-lzpaq "${PN}"
+}
+
+src_install() {
+ dobin ${PN}
+}