summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/lz4/files/lz4-0_p106-cflags.patch')
-rw-r--r--app-arch/lz4/files/lz4-0_p106-cflags.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-arch/lz4/files/lz4-0_p106-cflags.patch b/app-arch/lz4/files/lz4-0_p106-cflags.patch
new file mode 100644
index 000000000000..6fc0fbb47dd8
--- /dev/null
+++ b/app-arch/lz4/files/lz4-0_p106-cflags.patch
@@ -0,0 +1,22 @@
+--- a/cmake/pack/CMakeLists.txt
++++ b/cmake/pack/CMakeLists.txt
+@@ -36,7 +36,7 @@
+ ADD_DEFINITIONS("-Wundef")
+ ADD_DEFINITIONS("-Wcast-align")
+ ADD_DEFINITIONS("-Wno-implicit-function-declaration")
+-ADD_DEFINITIONS("-O3 -march=native -std=c99")
++ADD_DEFINITIONS("-std=c99")
+ INCLUDE_DIRECTORIES (${SRC_DIR})
+
+
+--- a/cmake/CMakeLists.txt
++++ b/cmake/CMakeLists.txt
+@@ -99,7 +99,7 @@
+ ADD_DEFINITIONS("-Wundef")
+ ADD_DEFINITIONS("-Wcast-align")
+ ADD_DEFINITIONS("-Wno-implicit-function-declaration")
+-ADD_DEFINITIONS("-Os -march=native -std=c99")
++ADD_DEFINITIONS("-std=c99")
+ INCLUDE_DIRECTORIES (${SRC_DIR})
+
+