summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/clamav-1.0.5.ebuild10
-rw-r--r--app-antivirus/clamav/clamav-1.3.1-r2.ebuild (renamed from app-antivirus/clamav/clamav-1.3.1-r1.ebuild)14
2 files changed, 7 insertions, 17 deletions
diff --git a/app-antivirus/clamav/clamav-1.0.5.ebuild b/app-antivirus/clamav/clamav-1.0.5.ebuild
index 8995c36a41b5..5759a6890ff1 100644
--- a/app-antivirus/clamav/clamav-1.0.5.ebuild
+++ b/app-antivirus/clamav/clamav-1.0.5.ebuild
@@ -291,14 +291,8 @@ src_install() {
if ! use libclamav-only ; then
if use systemd ; then
- # The tmpfiles entry is behind USE=systemd because the
- # upstream OpenRC service files should (and do) ensure that
- # the directories they need exist and have the correct
- # permissions without the help of opentmpfiles. There are
- # years-old root exploits in opentmpfiles, the design is
- # fundamentally flawed, and the maintainer is not up to
- # the task of fixing it.
- dotmpfiles "${FILESDIR}/tmpfiles.d/clamav.conf"
+ # OpenRC services do not need tmpfiles
+ dotmpfiles "${FILESDIR}/tmpfiles.d/clamav-r1.conf"
systemd_newunit "${FILESDIR}/clamd_at.service-0.104.0" "clamd@.service"
systemd_dounit "${FILESDIR}/clamd.service"
systemd_newunit "${FILESDIR}/freshclamd.service-r1" \
diff --git a/app-antivirus/clamav/clamav-1.3.1-r1.ebuild b/app-antivirus/clamav/clamav-1.3.1-r2.ebuild
index 04fcfda4d498..58e80f89a976 100644
--- a/app-antivirus/clamav/clamav-1.3.1-r1.ebuild
+++ b/app-antivirus/clamav/clamav-1.3.1-r2.ebuild
@@ -296,14 +296,10 @@ src_install() {
if ! use libclamav-only ; then
if use systemd ; then
- # The tmpfiles entry is behind USE=systemd because the
- # upstream OpenRC service files should (and do) ensure that
- # the directories they need exist and have the correct
- # permissions without the help of opentmpfiles. There are
- # years-old root exploits in opentmpfiles, the design is
- # fundamentally flawed, and the maintainer is not up to
- # the task of fixing it.
- dotmpfiles "${FILESDIR}/tmpfiles.d/clamav.conf"
+ # OpenRC services ensure their own permissions, so we can avoid
+ # a dependency on sys-apps/systemd-utils[tmpfiles] here, though
+ # we can change our minds and use it if we want to.
+ dotmpfiles "${FILESDIR}/tmpfiles.d/clamav-r1.conf"
fi
if use clamapp ; then
@@ -373,7 +369,7 @@ src_install() {
pkg_postinst() {
if ! use libclamav-only ; then
if use systemd ; then
- tmpfiles_process clamav.conf
+ tmpfiles_process clamav-r1.conf
fi
fi