summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/elisp-common.eclass40
-rw-r--r--eclass/elisp.eclass26
-rw-r--r--profiles/package.mask5
-rw-r--r--x11-misc/xlockmore/Manifest1
-rw-r--r--x11-misc/xlockmore/xlockmore-5.50-r1.ebuild108
5 files changed, 24 insertions, 156 deletions
diff --git a/eclass/elisp-common.eclass b/eclass/elisp-common.eclass
index 832fc19e4675..bce3fd0cec02 100644
--- a/eclass/elisp-common.eclass
+++ b/eclass/elisp-common.eclass
@@ -10,6 +10,7 @@
# Mamoru Komachi <usata@gentoo.org>
# Christian Faulhammer <fauli@gentoo.org>
# Ulrich Müller <ulm@gentoo.org>
+# @SUPPORTED_EAPIS: 5 6 7
# @BLURB: Emacs-related installation utilities
# @DESCRIPTION:
#
@@ -165,7 +166,7 @@
# to above calls of elisp-site-regen().
case ${EAPI:-0} in
- 4|5|6) inherit eapi7-ver ;;
+ 5|6) inherit eapi7-ver ;;
7) ;;
*) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
@@ -219,7 +220,9 @@ _ELISP_EMACS_VERSION=""
# Output version of currently active Emacs.
elisp-emacs-version() {
- local version ret
+ local version ret tmout="timeout -k 5 55"
+ # Run without timeout if the command is not available
+ ${tmout} true &>/dev/null || tmout=""
# The following will work for at least versions 18-24.
echo "(princ emacs-version)" >"${T}"/emacs-version.el
version=$(
@@ -228,7 +231,7 @@ elisp-emacs-version() {
# Redirecting stdin and unsetting TERM and DISPLAY will cause
# most of them to exit with an error.
unset TERM DISPLAY
- ${EMACS} ${EMACSFLAGS} -l "${T}"/emacs-version.el </dev/null
+ ${tmout} ${EMACS} ${EMACSFLAGS} -l "${T}"/emacs-version.el </dev/null
)
ret=$?
rm -f "${T}"/emacs-version.el
@@ -274,27 +277,6 @@ elisp-check-emacs-version() {
fi
}
-# Test if the eselected Emacs version is at least the major version
-# of GNU Emacs specified as argument.
-# Return 0 if true, 1 if false, 2 if trouble.
-# Deprecated, use elisp-check-emacs-version instead.
-
-elisp-need-emacs() {
- local need_emacs=$1 have_emacs
- have_emacs=$(elisp-emacs-version) || return 2
- einfo "Emacs version: ${have_emacs}"
- if [[ ${have_emacs} =~ XEmacs|Lucid ]]; then
- eerror "This package needs GNU Emacs."
- return 1
- fi
- if ! [[ ${have_emacs%%.*} -ge ${need_emacs%%.*} ]]; then
- eerror "This package needs at least Emacs ${need_emacs%%.*}."
- eerror "Use \"eselect emacs\" to select the active version."
- return 1
- fi
- return 0
-}
-
# @FUNCTION: elisp-compile
# @USAGE: <list of elisp files>
# @DESCRIPTION:
@@ -380,7 +362,7 @@ elisp-modules-install() {
shift
# Don't bother inheriting multilib.eclass for get_libdir(), but
# error out in old EAPIs that don't support it natively.
- [[ ${EAPI} == [45] ]] \
+ [[ ${EAPI} == 5 ]] \
&& die "${ECLASS}: Dynamic modules not supported in EAPI ${EAPI}"
ebegin "Installing dynamic modules for GNU Emacs support"
( # subshell to avoid pollution of calling environment
@@ -408,8 +390,8 @@ elisp-site-file-install() {
[[ ${sf%-gentoo*.el} != "${sf}" ]] && sf="${sf%-gentoo*.el}-gentoo.el"
sf="${T}/${sf}"
ebegin "Installing site initialisation file for GNU Emacs"
- [[ $1 = "${sf}" ]] || cp "$1" "${sf}"
- if [[ ${EAPI} == [45] ]]; then
+ [[ $1 == "${sf}" ]] || cp "$1" "${sf}"
+ if [[ ${EAPI} == 5 ]]; then
grep -q "@EMACSMODULES@" "${sf}" \
&& die "${ECLASS}: Dynamic modules not supported in EAPI ${EAPI}"
else
@@ -439,7 +421,7 @@ elisp-site-regen() {
local sf i ret=0 null="" page=$'\f'
local -a sflist
- if [[ ${EBUILD_PHASE} = *rm && ! -e ${sitelisp}/site-gentoo.el ]]; then
+ if [[ ${EBUILD_PHASE} == *rm && ! -e ${sitelisp}/site-gentoo.el ]]; then
ewarn "Refusing to create site-gentoo.el in ${EBUILD_PHASE} phase."
return 0
fi
@@ -494,7 +476,7 @@ elisp-site-regen() {
mv "${T}"/site-gentoo.el "${sitelisp}"/site-gentoo.el
eend $? "elisp-site-regen: Replacing site-gentoo.el failed" || die
case ${#sflist[@]} in
- 0) [[ ${PN} = emacs-common ]] \
+ 0) [[ ${PN} == emacs-common ]] \
|| ewarn "... Huh? No site initialisation files found." ;;
1) einfo "... ${#sflist[@]} site initialisation file included." ;;
*) einfo "... ${#sflist[@]} site initialisation files included." ;;
diff --git a/eclass/elisp.eclass b/eclass/elisp.eclass
index a092041009bf..d763a4944d2d 100644
--- a/eclass/elisp.eclass
+++ b/eclass/elisp.eclass
@@ -9,7 +9,7 @@
# Jeremy Maitin-Shepard <jbms@attbi.com>
# Christian Faulhammer <fauli@gentoo.org>
# Ulrich Müller <ulm@gentoo.org>
-# @SUPPORTED_EAPIS: 4 5 6 7
+# @SUPPORTED_EAPIS: 6 7
# @BLURB: Eclass for Emacs Lisp packages
# @DESCRIPTION:
#
@@ -40,7 +40,7 @@
# Space separated list of patches to apply after unpacking the sources.
# Patch files are searched for in the current working dir, WORKDIR, and
# FILESDIR. This variable is semi-deprecated, preferably use the
-# PATCHES array instead if the EAPI supports it.
+# PATCHES array instead.
# @ECLASS-VARIABLE: ELISP_REMOVE
# @DEFAULT_UNSET
@@ -62,8 +62,8 @@
# will be generated in src_compile() and installed in src_install().
inherit elisp-common
+
case ${EAPI:-0} in
- 4|5) inherit epatch ;;
6|7) ;;
*) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
@@ -73,8 +73,7 @@ EXPORT_FUNCTIONS src_{unpack,prepare,configure,compile,install} \
RDEPEND=">=app-editors/emacs-${NEED_EMACS}:*"
case ${EAPI} in
- 4) RDEPEND="${RDEPEND%:*}"; DEPEND="${RDEPEND}" ;;
- 5|6) DEPEND="${RDEPEND}" ;;
+ 6) DEPEND="${RDEPEND}" ;;
*) BDEPEND="${RDEPEND}" ;;
esac
@@ -118,17 +117,11 @@ elisp_src_prepare() {
else
die "Cannot find ${patch}"
fi
- case ${EAPI} in
- 4|5) epatch "${file}" ;;
- *) eapply "${file}" ;;
- esac
+ eapply "${file}"
done
- # apply PATCHES (if supported in EAPI), and any user patches
- case ${EAPI} in
- 4|5) epatch_user ;;
- *) default ;;
- esac
+ # apply PATCHES and any user patches
+ default
if [[ -n ${ELISP_REMOVE} ]]; then
rm ${ELISP_REMOVE} || die
@@ -172,10 +165,7 @@ elisp_src_install() {
doinfo ${@/%.*/.info*}
fi
# install documentation only when explicitly requested
- case ${EAPI} in
- 4|5) [[ -n ${DOCS} ]] && dodoc ${DOCS} ;;
- *) [[ $(declare -p DOCS 2>/dev/null) == *=* ]] && einstalldocs ;;
- esac
+ [[ $(declare -p DOCS 2>/dev/null) == *=* ]] && einstalldocs
if declare -f readme.gentoo_create_doc >/dev/null; then
readme.gentoo_create_doc
fi
diff --git a/profiles/package.mask b/profiles/package.mask
index db3945919656..56407bbbeccf 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -32,6 +32,11 @@
#--- END OF EXAMPLES ---
+# Jonas Stein <jstein@gentoo.org> (2021-04-19)
+# Bad SRC_URI, missing license files
+# Removal on 2021-07-01. Bug #784221.
+x11-apps/amlc
+
# Miroslav Šulc <fordfrog@gentoo.org> (2021-04-18)
# our version is outdated with security issues, new version
# uses gradle to build which we don't support atm,
diff --git a/x11-misc/xlockmore/Manifest b/x11-misc/xlockmore/Manifest
index 0a192762fa69..e84a09111c5b 100644
--- a/x11-misc/xlockmore/Manifest
+++ b/x11-misc/xlockmore/Manifest
@@ -1,4 +1,3 @@
-DIST xlockmore-5.50.tar.xz 1632968 BLAKE2B 2e692d16d70e3186ec1f31c192414b286f8815f2f428a6f7f43b3de0117c51c4ad2fbdfb91debe2ecb75c8683212b5d33bee62d81374552703d578b02d3af036 SHA512 627a905c4641d6083676a766931f23c06e2ac5af9b43447ccf03143d329d24b786aac6b248318929399b5fae98f1ec17e676466b5cbd09f180377c483694c569
DIST xlockmore-5.65.tar.xz 1945636 BLAKE2B d026975551e8ceafdcc7b8d8b6e404634f329d8d1f65e153b51798981103a023479dd58f2485c774aaf58f5928ea28a9f409c733ccfc75f98b65302e7e478ac5 SHA512 ecbf7e5c087843265eb4a537b3fe06a0d86d5f67d88c45137b6a7f4f5b30522d44fb87b5628cd9e042f90af129863fd3a4c2b5e2305df2dc3dfd867a03469ad8
DIST xlockmore-5.66.tar.xz 1995064 BLAKE2B 630643f2968a5015dd35b4e1a24cd3d4e7ef9d6d75b0916416e93ab28bacb5a161983b036d9042a5686b2f17ba493ad510e2df9f7443488f9b988662e644ec7a SHA512 d0a4665e23b32cc3370703e55396cd5c9659f836aa13a1737dd709632746cf9221acd66a529b9e05af981e5bef539e70582959b9d821854b93ef735ad1cd928d
DIST xlockmore-5.66ALPHA12.tar.xz 2083320 BLAKE2B 271c3e67076086759e325315bebb63a509adde6ee93a9cdae7c1022649231a34a9d944a94676ecee5fb53b3105766095f3e9f4f17df60de14fee1e6742b729c2 SHA512 e495dac3ce0cb1983ee2757198babc05adbadf3cad90c576af8dc83f4c49a45cdc3411106df910ccdc9701b842d7ead96cb2f253ccad094464e900e9548f963a
diff --git a/x11-misc/xlockmore/xlockmore-5.50-r1.ebuild b/x11-misc/xlockmore/xlockmore-5.50-r1.ebuild
deleted file mode 100644
index 4879af0b09f0..000000000000
--- a/x11-misc/xlockmore/xlockmore-5.50-r1.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools flag-o-matic pam
-
-DESCRIPTION="Just another screensaver application for X"
-HOMEPAGE="https://www.sillycycle.com/xlockmore.html"
-SRC_URI="
- https://www.sillycycle.com/xlock/${P}.tar.xz
- https://www.sillycycle.com/xlock/recent-releases/${P}.tar.xz
-"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ppc ppc64 sparc x86"
-IUSE="crypt debug gtk imagemagick motif nas opengl pam truetype xinerama xlockrc vtlock"
-
-REQUIRED_USE="
- || ( crypt pam )
- pam? ( !xlockrc )
- xlockrc? ( !pam )
-"
-RDEPEND="
- gtk? ( x11-libs/gtk+:2 )
- imagemagick? ( media-gfx/imagemagick:= )
- motif? ( >=x11-libs/motif-2.3:0 )
- nas? ( media-libs/nas )
- opengl? (
- virtual/opengl
- virtual/glu
- truetype? ( >=media-libs/ftgl-2.1.3_rc5 )
- )
- pam? ( sys-libs/pam )
- truetype? ( media-libs/freetype:2 )
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXmu
- x11-libs/libXpm
- x11-libs/libXt
- xinerama? ( x11-libs/libXinerama )
-"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
- x11-base/xorg-proto
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-5.46-freetype261.patch
- "${FILESDIR}"/${PN}-5.47-CXX.patch
- "${FILESDIR}"/${PN}-5.47-strip.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myconf=()
-
- if use opengl && use truetype; then
- myconf=( --with-ftgl )
- append-flags -DFTGL213
- else
- myconf=( --without-ftgl )
- fi
-
- myconf+=(
- $(use_enable pam)
- $(use_enable xlockrc)
- $(use_enable vtlock)
- $(use_with crypt)
- $(use_with debug editres)
- $(use_with gtk gtk2)
- $(use_with imagemagick magick)
- $(use_with motif)
- $(use_with nas)
- $(use_with opengl mesa)
- $(use_with opengl)
- $(use_with truetype freetype)
- $(use_with truetype ttf)
- $(use_with xinerama)
- --disable-mb
- --enable-appdefaultdir=/usr/share/X11/app-defaults
- --enable-syslog
- --enable-vtlock
- --without-esound
- --without-gtk
- )
- econf "${myconf[@]}"
-}
-
-src_install() {
- local DOCS=( README docs/{3d.howto,cell_automata,HACKERS.GUIDE,Purify,Revisions,TODO} )
- default
-
- if use pam; then
- pamd_mimic_system xlock auth
- fperms 755 /usr/bin/xlock
- else
- fperms 4755 /usr/bin/xlock
- fi
-
- docinto html
- dodoc docs/xlock.html
-}