summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/ansi2html/Manifest1
-rw-r--r--dev-python/ansi2html/ansi2html-1.2.0.ebuild45
-rw-r--r--eclass/java-utils-2.eclass10
-rw-r--r--media-libs/lcms/lcms-2.8-r1.ebuild2
-rw-r--r--net-misc/dahdi/dahdi-2.11.1.ebuild4
5 files changed, 54 insertions, 8 deletions
diff --git a/dev-python/ansi2html/Manifest b/dev-python/ansi2html/Manifest
index 278cf6e34613..938ccf1480c4 100644
--- a/dev-python/ansi2html/Manifest
+++ b/dev-python/ansi2html/Manifest
@@ -1 +1,2 @@
DIST ansi2html-1.1.1.tar.gz 46591 SHA256 5c8a482e92fd49005c083d5ed5aa946d424a71eda60be27fda005bbb5ed8c53f SHA512 5f08e6e3e89797f23759da7aac8cbd17e86ffcac37af8db8c345423c69744d88a1517cb0f17dc9c366b509b972484d25877cce8c7466a7a463eea24af17133de WHIRLPOOL 3d2555784c7077b6541df30b485af5f7f4884c40018b11c8a78afaac8c942f7f0903bf2fe442cdc75ddbb09b7be77cf58cc6a1f980617ded3b6eb68324d441d1
+DIST ansi2html-1.2.0.tar.gz 46748 SHA256 3e5d5ada557e0bbe3e204a686f959de17f76c86c20615c034767e5ebdc0740f1 SHA512 3106488da19cd093d7ae2a7499a66baf77877f47da0e497791cea2a63079c184f1d36743e78116b3faf08ab145ca97b5774151114b9ca193020578c8a3bdc860 WHIRLPOOL d19a79d21c630ccbb5ad7a66fd076c47d93d06879f493cb1e6c2e2eed5b66f8a9208c38ada9ef37159d9d27bc2915abdbdec5869b53cb8678c8316c98eedf04d
diff --git a/dev-python/ansi2html/ansi2html-1.2.0.ebuild b/dev-python/ansi2html/ansi2html-1.2.0.ebuild
new file mode 100644
index 000000000000..f5e27583bdda
--- /dev/null
+++ b/dev-python/ansi2html/ansi2html-1.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="https://pypi.python.org/pypi/ansi2html https://github.com/ralphbean/ansi2html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+# They miserably fail.
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+
+python_test() {
+ chmod -x "${S}"/tests/* || die
+ esetup.py check
+ esetup.py test
+}
+
+python_install_all() {
+ doman man/"${PN}.1"
+ DOCS=( README.rst man/"${PN}".1.txt )
+ distutils-r1_python_install_all
+}
diff --git a/eclass/java-utils-2.eclass b/eclass/java-utils-2.eclass
index d2af9f292a37..503aae35cab8 100644
--- a/eclass/java-utils-2.eclass
+++ b/eclass/java-utils-2.eclass
@@ -590,13 +590,13 @@ java-pkg_sointo() {
java-pkg_dohtml() {
debug-print-function ${FUNCNAME} $*
- [[ ${#} -lt 1 ]] && die "At least one argument required for ${FUNCNAME}"
+ [[ ${#} -lt 1 ]] && die "At least one argument required for ${FUNCNAME}"
- # from /usr/lib/portage/bin/dohtml -h
- # -f Set list of allowed extensionless file names.
- dohtml -f package-list "$@"
+ # Do away with dohtml and rely on dodoc instead to do the deed.
+ docinto html
+ dodoc "$@"
- # this probably shouldn't be here but it provides
+ # This probably shouldn't be here but it provides
# a reasonable way to catch # docs for all of the
# old ebuilds.
java-pkg_recordjavadoc
diff --git a/media-libs/lcms/lcms-2.8-r1.ebuild b/media-libs/lcms/lcms-2.8-r1.ebuild
index 2728e7896e65..7ebf424b2222 100644
--- a/media-libs/lcms/lcms-2.8-r1.ebuild
+++ b/media-libs/lcms/lcms-2.8-r1.ebuild
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/${PN}/lcms2-${PV}.tar.gz"
LICENSE="MIT"
SLOT="2"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ~ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="doc jpeg static-libs +threads test tiff zlib"
RDEPEND="jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
diff --git a/net-misc/dahdi/dahdi-2.11.1.ebuild b/net-misc/dahdi/dahdi-2.11.1.ebuild
index 699e31f10a41..6612871f846f 100644
--- a/net-misc/dahdi/dahdi-2.11.1.ebuild
+++ b/net-misc/dahdi/dahdi-2.11.1.ebuild
@@ -36,7 +36,7 @@ http://www.junghanns.net/downloads/jnet-dahdi-drivers-${JNET}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="flash"
RESTRICT="test"
@@ -76,6 +76,6 @@ src_compile() {
src_install() {
einfo "Installing kernel module"
- emake V=1 CC=$(tc-getCC) LD=$(tc-getLD) KSRC="${KV_OUT_DIR}" DESTDIR="${D}" DAHDI_MODULES_EXTRA="cwain.o qozap.o ztgsm.o" install
+ emake V=1 CC=$(tc-getCC) LD=$(tc-getLD) KSRC="${KV_OUT_DIR}" DESTDIR="${D}" DAHDI_MODULES_EXTRA="cwain.o qozap.o ztgsm.o" LDFLAGS="$(raw-ldflags)" install
rm -rf "$D"/lib/modules/*/modules.*
}