summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-qt/qtcore/qtcore-5.15.12-r1.ebuild (renamed from dev-qt/qtcore/qtcore-5.15.12.ebuild)45
-rw-r--r--eclass/cmake.eclass4
-rw-r--r--eclass/qt5-build.eclass18
-rw-r--r--sci-mathematics/form/Manifest1
-rw-r--r--sci-mathematics/form/form-4.3.0-r1.ebuild100
5 files changed, 56 insertions, 112 deletions
diff --git a/dev-qt/qtcore/qtcore-5.15.12.ebuild b/dev-qt/qtcore/qtcore-5.15.12-r1.ebuild
index a5a67b73e2a5..fc74cab8e807 100644
--- a/dev-qt/qtcore/qtcore-5.15.12.ebuild
+++ b/dev-qt/qtcore/qtcore-5.15.12-r1.ebuild
@@ -24,7 +24,50 @@ DEPEND="
icu? ( dev-libs/icu:= )
!icu? ( virtual/libiconv )
"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !<dev-qt/designer-${QT5_PV}:5
+ !<dev-qt/qt3d-${QT5_PV}:5
+ !<dev-qt/qtbluetooth-${QT5_PV}:5
+ !<dev-qt/qtcharts-${QT5_PV}:5
+ !<dev-qt/qtconcurrent-${QT5_PV}:5
+ !<dev-qt/qtdatavis3d-${QT5_PV}:5
+ !<dev-qt/qtdbus-${QT5_PV}:5
+ !<dev-qt/qtdeclarative-${QT5_PV}:5
+ !<dev-qt/qtgamepad-${QT5_PV}:5
+ !<dev-qt/qtgraphicaleffects-${QT5_PV}:5
+ !<dev-qt/qtgui-${QT5_PV}:5
+ !<dev-qt/qthelp-${QT5_PV}:5
+ !<dev-qt/qtimageformats-${QT5_PV}:5
+ !<dev-qt/qtlocation-${QT5_PV}:5
+ !<dev-qt/qtmultimedia-${QT5_PV}:5
+ !<dev-qt/qtnetwork-${QT5_PV}:5
+ !<dev-qt/qtnetworkauth-${QT5_PV}:5
+ !<dev-qt/qtopengl-${QT5_PV}:5
+ !<dev-qt/qtpositioning-${QT5_PV}:5
+ !<dev-qt/qtprintsupport-${QT5_PV}:5
+ !<dev-qt/qtquickcontrols-${QT5_PV}:5
+ !<dev-qt/qtquickcontrols2-${QT5_PV}:5
+ !<dev-qt/qtquicktimeline-${QT5_PV}:5
+ !<dev-qt/qtscript-${QT5_PV}:5
+ !<dev-qt/qtscxml-${QT5_PV}:5
+ !<dev-qt/qtsensors-${QT5_PV}:5
+ !<dev-qt/qtserialbus-${QT5_PV}:5
+ !<dev-qt/qtserialport-${QT5_PV}:5
+ !<dev-qt/qtspeech-${QT5_PV}:5
+ !<dev-qt/qtsql-${QT5_PV}:5
+ !<dev-qt/qtsvg-${QT5_PV}:5
+ !<dev-qt/qttest-${QT5_PV}:5
+ !<dev-qt/qtvirtualkeyboard-${QT5_PV}:5
+ !<dev-qt/qtwayland-${QT5_PV}:5
+ !<dev-qt/qtwebchannel-${QT5_PV}:5
+ !<dev-qt/qtwebengine-${QT5_PV}:5
+ !<dev-qt/qtwebsockets-${QT5_PV}:5
+ !<dev-qt/qtwebview-${QT5_PV}:5
+ !<dev-qt/qtwidgets-${QT5_PV}:5
+ !<dev-qt/qtx11extras-${QT5_PV}:5
+ !<dev-qt/qtxml-${QT5_PV}:5
+ !<dev-qt/qtxmlpatterns-${QT5_PV}:5
+"
QT5_TARGET_SUBDIRS=(
src/tools/bootstrap
diff --git a/eclass/cmake.eclass b/eclass/cmake.eclass
index 10749e9a2f31..ef5e6dd678a1 100644
--- a/eclass/cmake.eclass
+++ b/eclass/cmake.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: cmake.eclass
@@ -541,6 +541,8 @@ cmake_src_configure() {
set(CMAKE_INSTALL_DOCDIR "${EPREFIX}/usr/share/doc/${PF}" CACHE PATH "")
set(BUILD_SHARED_LIBS ON CACHE BOOL "")
set(Python3_FIND_UNVERSIONED_NAMES FIRST CACHE STRING "")
+ set(FETCHCONTENT_FULLY_DISCONNECTED ON CACHE BOOL "")
+ set(CMAKE_DISABLE_PRECOMPILE_HEADERS ON CACHE BOOL "")
_EOF_
if [[ -n ${_ECM_ECLASS} ]]; then
diff --git a/eclass/qt5-build.eclass b/eclass/qt5-build.eclass
index 0e416e253cc2..76a089b2908d 100644
--- a/eclass/qt5-build.eclass
+++ b/eclass/qt5-build.eclass
@@ -179,6 +179,15 @@ fi
qt5-build_src_prepare() {
qt5_prepare_env
+ # Workaround for bug #915203
+ # Upstream: https://bugreports.qt.io/browse/QTBUG-111514
+ if [[ ${PN} != qtcore ]]; then
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+ fi
+
+ # many bugs, no one to fix
+ filter-lto
+
if [[ ${QT5_BUILD_TYPE} == live ]] || [[ -n ${KDE_ORG_COMMIT} ]]; then
if [[ -n ${KDE_ORG_COMMIT} ]]; then
einfo "Preparing KDE Qt5PatchCollection snapshot at ${KDE_ORG_COMMIT}"
@@ -231,15 +240,6 @@ qt5-build_src_configure() {
qt5_tools_configure
fi
- # Workaround for bug #915203
- # Upstream: https://bugreports.qt.io/browse/QTBUG-111514
- if [[ ${PN} != qtcore ]] ; then
- append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
- fi
-
- # many bugs, no one to fix
- filter-lto
-
qt5_foreach_target_subdir qt5_qmake
}
diff --git a/sci-mathematics/form/Manifest b/sci-mathematics/form/Manifest
index 9066a4b62e67..d0a67bee26d0 100644
--- a/sci-mathematics/form/Manifest
+++ b/sci-mathematics/form/Manifest
@@ -1,4 +1,3 @@
-DIST form-4.3.0.tar.gz 1457721 BLAKE2B 029c62b0e1d92cf66be0290e45467e9de47f8ac9a593e7d012c13d877fb84aa1a212bb99b7a1a7b8b5b04c4cb056b58da80812faf5f0af5d33629c7632768ae6 SHA512 3f7f9cabf37d33fce0dcb7e091ac5ce60412ebe840fcea432655ab7f0c86c620200d60df085af3011d92d8057d9501583f16686257e5d097f6d0571d7f1b6742
DIST form-4.3.1.tar.gz 1470480 BLAKE2B 210ff3b97a18a495c2d81de0cba7945d9c5a8e5e2ab3dc833ed01fedf701c15f459f0e1b171597d1997b892916a571295407eea75a631b83ce49c0b52e343c85 SHA512 7fdf925b4843e2a853340fc74cc9cf1b603100ddcab2c6ac3752a18e646296761e2c9ee3036a098e2168800f10b4e9a8512b6c871d6d61b5505c3403be9bbdad
DIST form-5.0.0_beta1.tar.gz 1415449 BLAKE2B c919442941366488520b1ba0c058261de0261096548e752308f14db2dd0416172f8a6ccabe9a0e7ddccbb6f6ad605ba6ee4f15fbcd1fc9539ea9ab116bc27cbe SHA512 5bbdbdb3ccc865b33bc346d458d1927af13825320ad1ad795b3a5562732338ed119dc3a2ae5981d1bc8d89dd55c46febc66b7632560d27843aacc6e42f8904eb
DIST form-mode.el.gz 6657 BLAKE2B 41d014e4ca8036249d53f5361012095e2ed2ef5e43543ba809a058f0ed241bd3ec984d9b61ab13a5b447faf07decf4e696362f24cacea3af5870cccdf43b1415 SHA512 aa81cc9c45a90af982179d56b874de0d152538653242ea028450675ab8421df2e0d53988c7efa3527845dae145c8047b71574191eedd90511fa89ad812851e25
diff --git a/sci-mathematics/form/form-4.3.0-r1.ebuild b/sci-mathematics/form/form-4.3.0-r1.ebuild
deleted file mode 100644
index d3d5800ac1e2..000000000000
--- a/sci-mathematics/form/form-4.3.0-r1.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools flag-o-matic toolchain-funcs elisp-common
-
-DESCRIPTION="Symbolic Manipulation System"
-HOMEPAGE="https://www.nikhef.nl/~form/ https://github.com/vermaseren/form/"
-SRC_URI="https://github.com/vermaseren/${PN}/releases/download/v${PV}/${P}.tar.gz
- emacs? ( https://dev.gentoo.org/~grozin/form-mode.el.gz )"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="devref doc doxygen emacs gmp mpi threads zlib"
-
-RDEPEND="
- gmp? ( dev-libs/gmp:0= )
- mpi? ( virtual/mpi )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- devref? ( dev-texlive/texlive-latexrecommended )
- doc? ( dev-texlive/texlive-latexrecommended )
- doxygen? ( app-doc/doxygen )
- emacs? ( app-editors/emacs:* )"
-
-SITEFILE="64${PN}-gentoo.el"
-
-src_prepare() {
- default
- sed -i 's/LINKFLAGS = -s/LINKFLAGS =/' sources/Makefile.am || die
- eautoreconf
-}
-
-src_configure() {
- # Workaround for GCC -fchecking ICE, bug #904339
- append-cxxflags $(test-flags-CXX -Wno-uninitialized)
-
- econf \
- --enable-scalar \
- --enable-largefile \
- --disable-debug \
- --disable-static-link \
- --with-api=posix \
- $(use_with gmp ) \
- $(use_enable mpi parform ) \
- $(use_enable threads threaded ) \
- $(use_with zlib ) \
- CC="$(tc-getCC)" \
- CXX="$(tc-getCXX)" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- CXXFLAGS="${CXXFLAGS}"
-}
-
-src_compile() {
- default
- if use devref; then
- pushd doc/devref > /dev/null || die "doc/devref does not exist"
- LANG=C VARTEXFONTS="${T}/fonts" emake pdf
- popd > /dev/null
- fi
- if use doc; then
- pushd doc/manual > /dev/null || die "doc/manual does not exist"
- LANG=C VARTEXFONTS="${T}/fonts" emake pdf
- popd > /dev/null
- fi
- if use doxygen; then
- pushd doc/doxygen > /dev/null || die "doc/doxygen does not exist"
- emake html
- popd > /dev/null
- fi
-}
-
-src_install() {
- default
- if use devref; then
- dodoc doc/devref/devref.pdf
- fi
- if use doc; then
- dodoc doc/manual/manual.pdf
- fi
- if use doxygen; then
- docinto html
- dodoc -r doc/doxygen/html/.
- fi
- if use emacs; then
- elisp-install ${PN} "${WORKDIR}"/*.el
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}