summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/fields/fields-5.0.0-r2.ebuild2
-rw-r--r--dev-python/lazy-object-proxy/lazy-object-proxy-1.4.3.ebuild2
-rw-r--r--dev-python/markupsafe/markupsafe-1.1.1.ebuild2
-rw-r--r--dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild2
-rw-r--r--dev-python/tox/tox-3.14.4.ebuild2
-rw-r--r--eclass/flag-o-matic.eclass19
-rwxr-xr-xeclass/tests/flag-o-matic.sh10
-rw-r--r--sys-kernel/linux-headers/linux-headers-5.4.ebuild2
8 files changed, 21 insertions, 20 deletions
diff --git a/dev-python/fields/fields-5.0.0-r2.ebuild b/dev-python/fields/fields-5.0.0-r2.ebuild
index ba56ac36ab2f..d3b1edcefe08 100644
--- a/dev-python/fields/fields-5.0.0-r2.ebuild
+++ b/dev-python/fields/fields-5.0.0-r2.ebuild
@@ -12,7 +12,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~mips ppc ppc64 ~s390 ~sparc x86"
+KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
IUSE="test"
DEPEND="test? (
diff --git a/dev-python/lazy-object-proxy/lazy-object-proxy-1.4.3.ebuild b/dev-python/lazy-object-proxy/lazy-object-proxy-1.4.3.ebuild
index a0480f171976..fcd68696504b 100644
--- a/dev-python/lazy-object-proxy/lazy-object-proxy-1.4.3.ebuild
+++ b/dev-python/lazy-object-proxy/lazy-object-proxy-1.4.3.ebuild
@@ -16,7 +16,7 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE="test"
RESTRICT="!test? ( test )"
diff --git a/dev-python/markupsafe/markupsafe-1.1.1.ebuild b/dev-python/markupsafe/markupsafe-1.1.1.ebuild
index 04c52c168e56..4d6c5ad7804e 100644
--- a/dev-python/markupsafe/markupsafe-1.1.1.ebuild
+++ b/dev-python/markupsafe/markupsafe-1.1.1.ebuild
@@ -16,7 +16,7 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild
index 58ce0d6ada8b..94d649a641b5 100644
--- a/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild
+++ b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild
@@ -12,7 +12,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm ~arm64 ~sparc x86 ~amd64-linux ~x86-linux"
IUSE="doc"
DEPEND="
diff --git a/dev-python/tox/tox-3.14.4.ebuild b/dev-python/tox/tox-3.14.4.ebuild
index 9fd84c43525e..188f784f7e8c 100644
--- a/dev-python/tox/tox-3.14.4.ebuild
+++ b/dev-python/tox/tox-3.14.4.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/tox-dev/tox/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 ppc64 ~sparc x86"
+KEYWORDS="amd64 ppc64 sparc x86"
# doc disabled because of missing deps in tree
IUSE="test"
diff --git a/eclass/flag-o-matic.eclass b/eclass/flag-o-matic.eclass
index d8111fb9e38f..9ef9ac3685e0 100644
--- a/eclass/flag-o-matic.eclass
+++ b/eclass/flag-o-matic.eclass
@@ -487,15 +487,11 @@ test-flag-PROG() {
printf "%s\n" "${in_src}" > "${test_in}" || die "Failed to create '${test_in}'"
- # Don't set -Werror as there are cases when benign
- # always-on warnings filter out all flags like bug #712488.
- # We'll have to live with potential '-Wunused-command-line-argument'.
- # flags.
- #
- # We can add more selective detection of no-op flags via
- # '-Werror=ignored-optimization-argument' and similar error options.
local cmdline=(
"${comp[@]}"
+ # Clang will warn about unknown gcc flags but exit 0.
+ # Need -Werror to force it to exit non-zero.
+ -Werror
"$@"
# -x<lang> options need to go before first source file
"${cmdline_extra[@]}"
@@ -503,7 +499,14 @@ test-flag-PROG() {
"${test_in}" -o "${test_out}"
)
- "${cmdline[@]}" &>/dev/null
+ if ! "${cmdline[@]}" &>/dev/null; then
+ # -Werror makes clang bail out on unused arguments as well;
+ # try to add -Qunused-arguments to work-around that
+ # other compilers don't support it but then, it's failure like
+ # any other
+ cmdline+=( -Qunused-arguments )
+ "${cmdline[@]}" &>/dev/null
+ fi
}
# @FUNCTION: test-flag-CC
diff --git a/eclass/tests/flag-o-matic.sh b/eclass/tests/flag-o-matic.sh
index 6dfacb04c077..229dff52af94 100755
--- a/eclass/tests/flag-o-matic.sh
+++ b/eclass/tests/flag-o-matic.sh
@@ -161,12 +161,10 @@ out=$(CC=clang test-flags-CC -finvalid-flag)
[[ $? -ne 0 && -z ${out} ]]
ftend
-### '-finline-limit=1200' is 'ignored' flag, not invalid.
-### We don't filter out ignored flags currently, bug #712488
-#tbegin "test-flags-CC (gcc-valid but clang-invalid flags)"
-#out=$(CC=clang test-flags-CC -finline-limit=1200)
-#[[ $? -ne 0 && -z ${out} ]]
-#ftend
+tbegin "test-flags-CC (gcc-valid but clang-invalid flags)"
+out=$(CC=clang test-flags-CC -finline-limit=1200)
+[[ $? -ne 0 && -z ${out} ]]
+ftend
tbegin "test-flags-CC (unused flags w/clang)"
out=$(CC=clang test-flags-CC -Wl,-O1)
diff --git a/sys-kernel/linux-headers/linux-headers-5.4.ebuild b/sys-kernel/linux-headers/linux-headers-5.4.ebuild
index 910d86b229b5..facf3ae94dcf 100644
--- a/sys-kernel/linux-headers/linux-headers-5.4.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-5.4.ebuild
@@ -15,7 +15,7 @@ SRC_URI="${KERNEL_URI}
${PATCH_VER:+https://dev.gentoo.org/~slyfox/distfiles/gentoo-headers-${PATCH_PV}-${PATCH_VER}.tar.xz}
"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
DEPEND="app-arch/xz-utils
dev-lang/perl"