summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/gnome2.eclass9
-rw-r--r--x11-libs/gtk+/gtk+-2.24.31-r1.ebuild4
-rw-r--r--x11-libs/gtk+/gtk+-3.22.5.ebuild4
3 files changed, 6 insertions, 11 deletions
diff --git a/eclass/gnome2.eclass b/eclass/gnome2.eclass
index d64b31b73c6b..bb538dd19182 100644
--- a/eclass/gnome2.eclass
+++ b/eclass/gnome2.eclass
@@ -16,13 +16,8 @@
# Run eautoreconf instead of only elibtoolize
GNOME2_EAUTORECONF=${GNOME2_EAUTORECONF:-""}
-if [[ ${GNOME2_EAUTORECONF} == 'yes' ]] ; then
- AUTOTOOLS_AUTO_DEPEND=yes
-else
- : ${AUTOTOOLS_AUTO_DEPEND:=no}
-fi
-
-inherit autotools eutils libtool gnome.org gnome2-utils xdg
+[[ ${GNOME2_EAUTORECONF} == 'yes' ]] && inherit autotools
+inherit eutils libtool gnome.org gnome2-utils xdg
case "${EAPI:-0}" in
4|5)
diff --git a/x11-libs/gtk+/gtk+-2.24.31-r1.ebuild b/x11-libs/gtk+/gtk+-2.24.31-r1.ebuild
index 9e3ef4c12d53..f6b201827863 100644
--- a/x11-libs/gtk+/gtk+-2.24.31-r1.ebuild
+++ b/x11-libs/gtk+/gtk+-2.24.31-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -36,7 +36,7 @@ COMMON_DEPEND="
introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
!aqua? (
>=x11-libs/cairo-1.12.14-r4:=[aqua?,svg,X,${MULTILIB_USEDEP}]
- >=x11-libs/gdk-pixbuf-2.30.7:2[introspection?,X,${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.30.7:2[introspection?,${MULTILIB_USEDEP}]
>=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
>=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
>=x11-libs/libXi-1.7.2[${MULTILIB_USEDEP}]
diff --git a/x11-libs/gtk+/gtk+-3.22.5.ebuild b/x11-libs/gtk+/gtk+-3.22.5.ebuild
index 33ba2614ec75..6187a227309e 100644
--- a/x11-libs/gtk+/gtk+-3.22.5.ebuild
+++ b/x11-libs/gtk+/gtk+-3.22.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -33,7 +33,7 @@ COMMON_DEPEND="
media-libs/fontconfig[${MULTILIB_USEDEP}]
>=media-libs/libepoxy-1.0[${MULTILIB_USEDEP}]
>=x11-libs/cairo-1.14[aqua?,glib,svg,X?,${MULTILIB_USEDEP}]
- >=x11-libs/gdk-pixbuf-2.30:2[introspection?,X?,${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.30:2[introspection?,${MULTILIB_USEDEP}]
>=x11-libs/pango-1.37.3[introspection?,${MULTILIB_USEDEP}]
x11-misc/shared-mime-info