summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/jedi/Manifest1
-rw-r--r--app-vim/jedi/jedi-0.11.0.ebuild80
-rw-r--r--profiles/arch/arm64/package.use.mask4
-rw-r--r--profiles/arch/x86/package.use.mask4
4 files changed, 89 insertions, 0 deletions
diff --git a/app-vim/jedi/Manifest b/app-vim/jedi/Manifest
index 294f4292ce86..d2964f694ff5 100644
--- a/app-vim/jedi/Manifest
+++ b/app-vim/jedi/Manifest
@@ -1 +1,2 @@
DIST jedi-0.10.0.tar.gz 36820 BLAKE2B a66f7c58564487d83867d61480d83364af0047cee713c41dbd5c67bff0b2ac33d066c2d0f4367c30059f46fb9f4916fc8d2eb9c64aa6a489e2c16a03f56b0b3c SHA512 65482505446b1001e92870ae64a147b38c0bb4d3151e464d325be741729506a191b284a491f4c3eb77dc46cb9bcd6b8e7bf8689ed95107e89a1f6a05c7fbc9ea
+DIST jedi-0.11.0.tar.gz 41606 BLAKE2B 146f60f43a3fc764c66e2ca94c2b4051be3e25b5a94ca3f6d82533b624433946013c7df38e61262e6ac40a00de9d3b9b0e647e794191b6deb8ed09124d2accc7 SHA512 a151fdf4d58adc36dbe9ede8e091ae00c8bd8237b66c512b4addfb6e7e436651848da2b3a0dbcbbef615bcc394e7e28a6e127e53f2205dc61f4d46a2ff0faa12
diff --git a/app-vim/jedi/jedi-0.11.0.ebuild b/app-vim/jedi/jedi-0.11.0.ebuild
new file mode 100644
index 000000000000..3afb7b0cf9b7
--- /dev/null
+++ b/app-vim/jedi/jedi-0.11.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit edo vim-plugin python-single-r1
+
+MY_PN="${PN}-vim"
+DESCRIPTION="vim plugin: binding to the autocompletion library jedi"
+HOMEPAGE="https://github.com/davidhalter/jedi-vim"
+SRC_URI="https://github.com/davidhalter/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '>=dev-python/jedi-0.18[${PYTHON_USEDEP}]')
+ || (
+ app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
+ app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ app-vim/vspec
+ )
+"
+
+DOCS=( AUTHORS.txt CONTRIBUTING.md README.rst )
+
+src_prepare() {
+ vim-plugin_src_prepare
+
+ rm doc/logotype-a.svg || die
+ rmdir pythonx/{jedi,parso} || die
+
+ # Disable failing tests
+ sed -i test/vspec/signatures.vim \
+ -e "/it 'highlights correct argument'/a SKIP 'fail'" || die
+}
+
+# Makefile tries hard to call tests so let's silence this phase.
+src_compile() { :; }
+
+src_test() {
+ local bindir="${S}"/venv/bin
+ local sitedir="${S}"/venv/lib/${EPYTHON}/site-packages
+
+ mkdir -p "${bindir}" || die
+ mkdir -p "${sitedir}" || die
+ ln -s "${PYTHON}" "${bindir}/${EPYTHON}" || die
+ ln -s "${EPYTHON}" "${bindir}/python3" || die
+ ln -s "${EPYTHON}" "${bindir}/python" || die
+ cat > "${bindir}"/pyvenv.cfg <<-EOF || die
+ include-system-site-packages = false
+ EOF
+
+ ln -s "$(python_get_sitedir)"/parso "${sitedir}"/parso || die
+ cp -r "$(python_get_sitedir)"/parso-*.dist-info "${sitedir}" || die
+
+ ln -s "$(python_get_sitedir)"/jedi "${sitedir}"/jedi || die
+ cp -r "$(python_get_sitedir)"/jedi-*.dist-info "${sitedir}" || die
+
+ export PATH="${bindir}:${PATH}"
+ unset PYTHONPATH
+
+ edo prove-vspec -d "${S}" test/vspec
+}
+
+src_install() {
+ vim-plugin_src_install pythonx
+ python_optimize "${ED}"/usr/share/vim/vimfiles/pythonx
+}
diff --git a/profiles/arch/arm64/package.use.mask b/profiles/arch/arm64/package.use.mask
index 516bfe79183b..655a09426c73 100644
--- a/profiles/arch/arm64/package.use.mask
+++ b/profiles/arch/arm64/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Anna Vyalkova <cyber+gentoo@sysrq.in> (2022-06-25)
+# Unkeyworded test dep
+app-vim/jedi test
+
# Conrad Kostecki <conikost@gentoo.org> (2022-06-05)
# Unkeyworded deps, bug #687830
app-metrics/collectd collectd_plugins_modbus
diff --git a/profiles/arch/x86/package.use.mask b/profiles/arch/x86/package.use.mask
index d40680f705f2..cc2431ca8f0a 100644
--- a/profiles/arch/x86/package.use.mask
+++ b/profiles/arch/x86/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Anna Vyalkova <cyber+gentoo@sysrq.in> (2022-06-25)
+# Unkeyworded test dep
+app-vim/jedi test
+
# Ben Kohler <bkohler@gentoo.org> (2022-06-07)
# Disable 64bit builds on x86
sys-apps/memtest86+ bios64 efi64 iso64