summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/go-module.eclass4
-rw-r--r--media-libs/Field3D/Field3D-1.7.3_p20230509.ebuild67
-rw-r--r--media-libs/Field3D/Manifest1
-rw-r--r--media-libs/Field3D/files/Field3D-1.7.2-boost-1.83-timer-header-deprecated.patch35
4 files changed, 105 insertions, 2 deletions
diff --git a/eclass/go-module.eclass b/eclass/go-module.eclass
index 701d36e012e2..5726d2f77d9a 100644
--- a/eclass/go-module.eclass
+++ b/eclass/go-module.eclass
@@ -1,4 +1,4 @@
-# Copyright 2019-2023 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: go-module.eclass
@@ -71,7 +71,7 @@ _GO_MODULE_ECLASS=1
inherit multiprocessing toolchain-funcs go-env
if [[ ! ${GO_OPTIONAL} ]]; then
- BDEPEND=">=dev-lang/go-1.18"
+ BDEPEND=">=dev-lang/go-1.20:="
# Workaround for pkgcheck false positive: https://github.com/pkgcore/pkgcheck/issues/214
# MissingUnpackerDep: version ...: missing BDEPEND="app-arch/unzip"
diff --git a/media-libs/Field3D/Field3D-1.7.3_p20230509.ebuild b/media-libs/Field3D/Field3D-1.7.3_p20230509.ebuild
new file mode 100644
index 000000000000..b21dc0fb64b2
--- /dev/null
+++ b/media-libs/Field3D/Field3D-1.7.3_p20230509.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="A library for storing voxel data"
+HOMEPAGE="http://opensource.imageworks.com/?p=field3d"
+SRC_COMMIT="b0ff0cd67893a4cbfa322676eb3eef10100d904d"
+SRC_URI="https://github.com/imageworks/Field3D/archive/${SRC_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc mpi test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/boost:=
+ >=dev-libs/imath-3.1.4-r2:=
+ >=media-libs/openexr-3:0=
+ sci-libs/hdf5:=
+ doc? ( app-doc/doxygen )
+ mpi? ( virtual/mpi )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.7.2-openexr-3-imath.patch"
+ "${FILESDIR}/${PN}-1.7.2-boost-1.83-timer-header-deprecated.patch"
+)
+
+S="${WORKDIR}/${PN}-${SRC_COMMIT}"
+
+src_prepare() {
+ sed -e "s#auto_ptr#unique_ptr#g" -i include/*.h || die
+ sed \
+ -e "s#DESTINATION \${CMAKE_INSTALL_PREFIX}#DESTINATION \${CMAKE_INSTALL_DOCDIR}#" \
+ -e "s#CMAKE_MINIMUM_REQUIRED( VERSION 2.8 )#CMAKE_MINIMUM_REQUIRED( VERSION 3.5 )#" \
+ -i CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Needed for now ("fix" compatibility with >=sci-libs/hdf5-1.12)
+ # bug #808731
+ append-cppflags -DH5_USE_110_API
+
+ local mycmakeargs=(
+ -DCMAKE_CXX_STANDARD=11
+
+ -DINSTALL_DOCS="$(usex doc)" # Docs are not finished yet.
+ -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen="$(usex !doc)"
+
+ "$(cmake_use_find_package mpi MPI)"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ ./unitTest || die
+}
diff --git a/media-libs/Field3D/Manifest b/media-libs/Field3D/Manifest
index dbf8d221f9c2..6b3139c3a094 100644
--- a/media-libs/Field3D/Manifest
+++ b/media-libs/Field3D/Manifest
@@ -1 +1,2 @@
DIST Field3D-1.7.2.tar.gz 502481 BLAKE2B 8d5fbac915b52b36e66250f8fcd2beb5fff9d2446696ad1829e3edf05c9810b5d54928c6ab4f5aa99c1338da24cea446134434a59aa1d053f3da3500c2800f59 SHA512 e4ea51310105980f759dce48830db8ae3592ce32a02b246214d8aed9df7a7f5c500314f2daf92196b7a76d648f2909b18112df4c5c3c8949c0676d710dfbf1f2
+DIST Field3D-1.7.3_p20230509.tar.gz 503942 BLAKE2B 30926a3229306b444a0267ff22c05d51bd3cd9804f9685608813bee5a738e498286d1e7b35c32e48214e949e5aa91a1604c9b92d5ab4dc3c71d3bb85bd5f5920 SHA512 fcc718c0b1629af36f5a403cc4a453c343d97d464fe5b1e7b6a6ac2b36a38e245f785735c91f7bc9abceffc522d5a20855310f04e006f83f8660253de6e4cdda
diff --git a/media-libs/Field3D/files/Field3D-1.7.2-boost-1.83-timer-header-deprecated.patch b/media-libs/Field3D/files/Field3D-1.7.2-boost-1.83-timer-header-deprecated.patch
new file mode 100644
index 000000000000..e583dfcb4a3f
--- /dev/null
+++ b/media-libs/Field3D/files/Field3D-1.7.2-boost-1.83-timer-header-deprecated.patch
@@ -0,0 +1,35 @@
+From: https://bugs.gentoo.org/912312#c10
+From: Attila Tóth <atoth@atoth.sote.hu>
+--- a/apps/sample_code/sparse_field_io/main.cpp 2023-08-24 11:30:05.951289118 +0200
++++ b/apps/sample_code/sparse_field_io/main.cpp 2023-08-24 11:30:32.491719405 +0200
+@@ -38,7 +38,7 @@
+ #include <vector>
+
+ #include <boost/lexical_cast.hpp>
+-#include <boost/timer.hpp>
++#include <boost/timer/timer.hpp>
+
+ #include <Field3D/SparseField.h>
+ #include <Field3D/SparseFile.h>
+--- a/test/misc_tests/access_speed/main.cpp 2023-08-24 11:30:05.963289314 +0200
++++ b/test/misc_tests/access_speed/main.cpp 2023-08-24 11:30:42.903885904 +0200
+@@ -38,7 +38,7 @@
+ #include <vector>
+
+ #include <boost/lexical_cast.hpp>
+-#include <boost/timer.hpp>
++#include <boost/timer/timer.hpp>
+
+ #include <Field3D/DenseField.h>
+ #include <Field3D/SparseField.h>
+--- a/test/misc_tests/threading_and_virtual_calls/main.cpp 2023-08-24 11:30:05.963289314 +0200
++++ b/test/misc_tests/threading_and_virtual_calls/main.cpp 2023-08-24 11:30:51.656025852 +0200
+@@ -38,7 +38,7 @@
+ #include <vector>
+
+ #include <boost/lexical_cast.hpp>
+-#include <boost/timer.hpp>
++#include <boost/timer/timer.hpp>
+ #include <boost/thread/thread.hpp>
+ #include <boost/date_time/posix_time/posix_time.hpp>
+