summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/perl-support/perl-support-5.4.ebuild15
1 files changed, 15 insertions, 0 deletions
diff --git a/app-vim/perl-support/perl-support-5.4.ebuild b/app-vim/perl-support/perl-support-5.4.ebuild
index 80a42f4e20a7..11fbe9c4a123 100644
--- a/app-vim/perl-support/perl-support-5.4.ebuild
+++ b/app-vim/perl-support/perl-support-5.4.ebuild
@@ -13,6 +13,8 @@ KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
VIM_PLUGIN_HELPFILES="perlsupport.txt"
RDEPEND="
+ !ppc? ( dev-perl/Devel-NYTProf )
+ dev-perl/Perl-Tidy
dev-perl/Perl-Tags
dev-perl/Perl-Critic"
@@ -29,3 +31,16 @@ src_install() {
vim-plugin_src_install
}
+
+pkg_postinst() {
+ elog "${PN} can utilize the following modules on top of the ones installed as"
+ elog "dependencies:"
+ elog
+ elog "Devel::SmallProf - per-line Perl profiler"
+ elog "Devel::FastProf - per-line Perl profiler"
+ elog "Devel::ptkdb - Perl debugger using a Tk GUI"
+ elog "Pod::Pdf - A POD to PDF translator"
+ elog "YAPE::Regex::Explain - regular expression analyzer"
+ elog
+ elog "You may need to install them separately if you would like to use them."
+}