summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/moarvm/Manifest1
-rw-r--r--dev-lang/moarvm/moarvm-2018.03.ebuild58
-rw-r--r--dev-lang/nqp/Manifest1
-rw-r--r--dev-lang/nqp/nqp-2018.03.ebuild159
-rw-r--r--dev-lang/rakudo/Manifest1
-rw-r--r--dev-lang/rakudo/rakudo-2018.03.ebuild72
-rw-r--r--dev-libs/libressl/libressl-2.3.10.ebuild6
-rw-r--r--dev-libs/libressl/libressl-2.4.5.ebuild6
-rw-r--r--dev-libs/libressl/libressl-2.5.0.ebuild6
-rw-r--r--dev-libs/libressl/libressl-2.5.4.ebuild6
-rw-r--r--dev-libs/libressl/libressl-2.5.5.ebuild6
-rw-r--r--dev-libs/libressl/libressl-2.6.0.ebuild6
-rw-r--r--dev-libs/libressl/libressl-2.6.1.ebuild6
-rw-r--r--dev-libs/libressl/libressl-2.6.2.ebuild6
-rw-r--r--dev-libs/libressl/libressl-2.6.3-r2.ebuild6
-rw-r--r--dev-libs/libressl/libressl-2.6.4.ebuild4
-rw-r--r--dev-libs/libressl/libressl-2.7.0.ebuild4
-rw-r--r--dev-libs/libressl/libressl-2.7.1.ebuild4
-rw-r--r--dev-libs/log4cplus/log4cplus-1.2.0.ebuild2
-rw-r--r--media-gfx/blender/blender-2.79-r1.ebuild2
-rw-r--r--media-gfx/openvdb/openvdb-4.0.2.ebuild4
-rw-r--r--media-libs/openimageio/openimageio-1.7.17.ebuild4
-rw-r--r--media-libs/opensubdiv/opensubdiv-3.3.0.ebuild4
-rw-r--r--media-libs/osl/osl-1.8.12.ebuild4
-rw-r--r--media-libs/partio/partio-1.1.0_p20170829.ebuild2
-rw-r--r--media-libs/ptex/ptex-2.1.28-r1.ebuild4
26 files changed, 338 insertions, 46 deletions
diff --git a/dev-lang/moarvm/Manifest b/dev-lang/moarvm/Manifest
index 9c6f0bae1b88..49f91e35ae17 100644
--- a/dev-lang/moarvm/Manifest
+++ b/dev-lang/moarvm/Manifest
@@ -1,2 +1,3 @@
DIST MoarVM-2018.01.tar.gz 4762110 BLAKE2B 643fc082ec1ba9b79bb5d0c13e66703850b75673a73e659fc8b2400cbb0d986b1882b7d23721a77773891649d709328ace1023d50d4ffacae5d75091a8976912 SHA512 2e558c92562096596992e6e0070092481e5a5d25ac3047110d023536deebc9a4db21d9844ecf3b7c0ae5cc6fa529cc48d9a8e98cdc2f5e23a8effc37b7509ef9
DIST MoarVM-2018.02.tar.gz 4769154 BLAKE2B 28eaf603c908c4d1fb5d9fc8e771e3a54165102288f566aca04df6740cfc307e2cea5beeeed9be490b9f4136e4dc8e9bb20249aab07d46e9f3bb9ab522f5a4a8 SHA512 3364a1af68b828de30affa4c21fe691d10353175cc18e815f962f8dcafb63947ce3fd3ae5c10c656b90f4cb02f3fd008a9a99f832d76098c12525b36e46924d0
+DIST MoarVM-2018.03.tar.gz 4859280 BLAKE2B 373ed24f30abc669aef914dd8e683a09f09831c82fa81784da78bd9ab31ee14bc6967afce1e2753cc6df7155bfbfba076062375348345d529872352a396a7c36 SHA512 be613e038747d771de03129e52d6e65712ddf6f73ed87eb008ae78968f2d516b4fded792a67e1ce031378c223408101ceaf25f90abf9ba35ee20c6e8401b46f1
diff --git a/dev-lang/moarvm/moarvm-2018.03.ebuild b/dev-lang/moarvm/moarvm-2018.03.ebuild
new file mode 100644
index 000000000000..405febb3308d
--- /dev/null
+++ b/dev-lang/moarvm/moarvm-2018.03.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+MY_PN="MoarVM"
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/${MY_PN}/${MY_PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+ S="${WORKDIR}/${P}"
+else
+ SRC_URI="http://moarvm.org/releases/${MY_PN}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="A 6model-based VM for NQP and Rakudo Perl 6"
+HOMEPAGE="http://moarvm.org"
+LICENSE="Artistic-2"
+SLOT="0"
+IUSE="asan clang debug doc +jit static-libs optimize ubsan"
+
+RDEPEND="dev-libs/libatomic_ops
+ dev-libs/libuv
+ dev-lang/lua:0[deprecated]
+ dev-lua/LuaBitOp
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ clang? ( >=sys-devel/clang-3.1 )
+ dev-lang/perl"
+
+DOCS=( CREDITS README.markdown )
+
+# Tests are conducted via nqp
+RESTRICT=test
+
+src_configure() {
+ use doc && DOCS+=( docs/* )
+ local myconfigargs=(
+ "--prefix=/usr"
+ "--has-libuv"
+ "--has-libatomic_ops"
+ "--has-libffi"
+ "--libdir=$(get_libdir)"
+ "--compiler=$(usex clang clang gcc)"
+ "$(usex asan --asan)"
+ "$(usex debug --debug --no-debug)"
+ "$(usex optimize --optimize= --no-optimize)"
+ "$(usex static-libs --static)"
+ "$(usex ubsan --ubsan)"
+ )
+ use optimize && filter-flags '-O*'
+
+ perl Configure.pl "${myconfigargs[@]}" || die
+}
diff --git a/dev-lang/nqp/Manifest b/dev-lang/nqp/Manifest
index 6cc0433a9672..352a136ff1d3 100644
--- a/dev-lang/nqp/Manifest
+++ b/dev-lang/nqp/Manifest
@@ -1,2 +1,3 @@
DIST nqp-2018.01.tar.gz 3798898 BLAKE2B 5dc492bc5561a674d3faabb63c881ad97bff3528bc3f8bd75caa7f2e78aa4464849f326c611936106c6f14ca56f4de5f4575407ab134d4218409829c22885b3a SHA512 0bfec280ed2c70bbf25b274632e830838526fef1e8f8c08387b1e79e1ef739dfaafe67dbab17eb24cf33c1b2aa984029dc0740fcc43e463e92f908dfb2360249
DIST nqp-2018.02.tar.gz 3759551 BLAKE2B 48713a0d300ec2e296b426784bb22f785969371043046251868c23c1f5710291c4b524d9d2d37fa4634eb910ad817c01e52bc132b3609cb292ae13cdd418c9bd SHA512 57c63d76ac0e44f1017c1cbdc9c128107c46c5339d468e3cb6e909df440cca0f37d2050e909c5cf1b10be7f08a9f33485c762150e5456317a777b14d15216225
+DIST nqp-2018.03.tar.gz 3778268 BLAKE2B 16e8e3924daa3aecf9987e9c39173fb32a769cd668add4b62bf04feb09755e5442224357610189ae8184c8c5c6fa35b2ce0d29cb708e8c5c0218963e2f918022 SHA512 d90fc8c933c31f1013bfdda5a02699c1c668ed5466167d58355c6baa65c294269cb4dbe072452bd14a9bbf180d83e61fedd3354b4404d590304be04e28489460
diff --git a/dev-lang/nqp/nqp-2018.03.ebuild b/dev-lang/nqp/nqp-2018.03.ebuild
new file mode 100644
index 000000000000..558b645a275b
--- /dev/null
+++ b/dev-lang/nqp/nqp-2018.03.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit java-pkg-opt-2 multibuild
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/perl6/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
+ inherit vcs-snapshot
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
+HOMEPAGE="http://rakudo.org/"
+
+LICENSE="Artistic-2"
+SLOT="0"
+IUSE="doc clang java +moar test"
+REQUIRED_USE="|| ( java moar )"
+
+CDEPEND="java? (
+ dev-java/asm:4
+ dev-java/jline:0
+ dev-java/jna:4
+ )
+ moar? ( ~dev-lang/moarvm-${PV}[clang=] )"
+RDEPEND="${CDEPEND}
+ java? ( >=virtual/jre-1.7 )"
+DEPEND="${CDEPEND}
+ clang? ( sys-devel/clang )
+ java? ( >=virtual/jdk-1.7 )
+ dev-lang/perl"
+
+pkg_pretend() {
+ if has_version dev-lang/rakudo || has_version dev-lang/nqp; then
+ ewarn "NQP is known to fail compilation/installation with Rakudo and/or NQP"
+ ewarn "already being installed. So if it fails, try uninstalling both"
+ ewarn "dev-lang/nqp and dev-lang/rakudo, then do a new installation."
+ ewarn "(see Bug #584394)"
+ fi
+}
+
+java_prepare() {
+ # Don't clean stage0 jars.
+ einfo "Cleaning upstream jars"
+ java-pkg_clean 3rdparty/
+
+ # Don't use jars we just deleted.
+ sed -i -r 's/(:3rdparty[^:]*)+/:${THIRDPARTY_JARS}/g' \
+ src/vm/jvm/runners/nqp-j || die
+}
+
+src_prepare() {
+ MULTIBUILD_VARIANTS=()
+ use moar && MULTIBUILD_VARIANTS+=( moar )
+ use java && MULTIBUILD_VARIANTS+=( jvm )
+
+ multibuild_copy_sources
+
+ # This will pull in conditional java_prepare
+ default
+}
+
+nqp_configure() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+ local myconfargs=(
+ "--backend=${MULTIBUILD_VARIANT}"
+ "--prefix=/usr" )
+
+ perl Configure.pl "${myconfargs[@]}" || die
+ popd || die
+}
+
+nqp_compile() {
+ if [[ "${MULTIBUILD_VARIANT}" = jvm ]]; then
+ emake -j1 \
+ -C "${BUILD_DIR}" \
+ THIRDPARTY_JARS=$(java-pkg_getjars --with-dependencies asm-4,jline,jna-4) \
+ JAVAC="$(java-pkg_get-javac) $(java-pkg_javac-args)"
+ elif [[ "${MULTIBUILD_VARIANT}" = moar ]]; then
+ emake -j1 \
+ -C "${BUILD_DIR}"
+ fi
+}
+
+nqp_test() {
+ emake -j1 \
+ -C "${BUILD_DIR}" \
+ test
+}
+
+nqp_install() {
+ # This is the actual reason we need multibuild.eclass.
+ # We need to distinguish the install procedure for MoarVM and JVM backends.
+ case "${MULTIBUILD_VARIANT}" in
+ moar)
+ emake \
+ DESTDIR="${ED}" \
+ -C "${BUILD_DIR}" \
+ install
+ ;;
+ jvm)
+ pushd "${BUILD_DIR}" > /dev/null || die
+ # Set JAVA_PKG_JARDEST early.
+ java-pkg_init_paths_
+
+ # Upstream sets the classpath to this location. Perhaps it's
+ # used to locate the additional libraries?
+ java-pkg_addcp "${JAVA_PKG_JARDEST}"
+
+ insinto "${JAVA_PKG_JARDEST}"
+ local jar
+
+ for jar in *.jar; do
+ if has ${jar} ${PN}.jar ${PN}-runtime.jar; then
+ # jars for NQP itself.
+ java-pkg_dojar ${jar}
+ else
+ # jars used by NQP.
+ doins ${jar}
+ fi
+ done
+
+ # Upstream uses -Xbootclasspath/a, which is faster due to lack
+ # of verification, but gjl isn't flexible enough yet. :(
+ java-pkg_dolauncher ${PN}-j --main ${PN}
+ dosym ${PN}-j /usr/bin/${PN}
+ dobin tools/jvm/eval-client.pl
+ popd > /dev/null || die
+ ;;
+ *)
+ die "Unknown MULTIBUILD_VARIANT ${MULTIBUILD_VARIANT}."
+ ;;
+ esac
+}
+
+src_configure() {
+ multibuild_foreach_variant nqp_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant nqp_compile
+}
+
+src_test() {
+ multibuild_foreach_variant nqp_test
+}
+
+src_install() {
+ multibuild_foreach_variant nqp_install
+
+ dodoc CREDITS README.pod
+ use doc && dodoc -r docs/*
+}
diff --git a/dev-lang/rakudo/Manifest b/dev-lang/rakudo/Manifest
index 049868463d69..cf6b3cc55d08 100644
--- a/dev-lang/rakudo/Manifest
+++ b/dev-lang/rakudo/Manifest
@@ -1,3 +1,4 @@
DIST rakudo-2018.01.tar.gz 3089785 BLAKE2B 6e74c17b44e489a5a1a60f177290962eac752ad5750dd5d6e64e5a9264d8b6ba7dfe4234087a1b1cbebd3933376b83dd305c3bd255ad39bc81b9c99b8e51b303 SHA512 5030089265f7c4d0bde663eb1d26a0e40ddc9b1dedfd7a350a2238f5136f08abb986d2568c05efe031248ecacdd19888be6e08b954bbeedc03e769d3016b17ea
DIST rakudo-2018.02.1.tar.gz 3478957 BLAKE2B 39568af458cc15705db48f607675a7ca4fe2d6430fdaac42e37b7096f0974d42788fa0965ee9da61c2ae56dafb27e3d759007c6600f291a07c0dc50dd1d34638 SHA512 59be2c41e6b1784fb9eaf7590ee77d8424c449d7c58e93c66f3adde5be3fe05260c41c01171c8fb59542b32bb5ee5064e1c9be69efc3e8cb20554b09b10240ea
DIST rakudo-2018.02.tar.gz 3478799 BLAKE2B 36f50a38c26e9b96a31d63566337315bed41bdd9b19e3b4e74dcdd1e0b56a060b0fcd7430078250e7e3b45473f7ee08ee0f059f10e1d01a24f0a3f08fe43c158 SHA512 743dbe01c20388e7c0f1af6f8175def283f9c92ac6f2c3b7d8c442c03d5204de8bd12d33f6ee99d75f9c0a171ca96cc2a3438b2ebfa0265d80441b353c64bbc4
+DIST rakudo-2018.03.tar.gz 3492524 BLAKE2B be2d9fbc8789e78025e18da873873d99872984815a56c0e255487b4250c900e142dbcdb5ce8eede496504401ca37c0e433fb9060fc5f4e8ac0b2778fc35cff62 SHA512 b644f333f6b9501631ee95949017b9e39416311853880a71bc714bb36f2da448fc57147f819d876f6d7ab207c2921474f94e25a4df90c735ba15f270f0c1fd7b
diff --git a/dev-lang/rakudo/rakudo-2018.03.ebuild b/dev-lang/rakudo/rakudo-2018.03.ebuild
new file mode 100644
index 000000000000..b442d4008798
--- /dev/null
+++ b/dev-lang/rakudo/rakudo-2018.03.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit java-pkg-opt-2
+
+DESCRIPTION="A compiler for the Perl 6 programming language"
+HOMEPAGE="http://rakudo.org"
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/rakudo/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://rakudo.perl6.org/downloads/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Artistic-2"
+SLOT="0"
+# TODO: add USE="javascript" once that's usable in nqp
+IUSE="clang java +moar test"
+REQUIRED_USE="|| ( java moar )"
+
+CDEPEND="~dev-lang/nqp-${PV}:${SLOT}=[java?,moar?,clang=]"
+RDEPEND="${CDEPEND}
+ java? ( >=virtual/jre-1.7 )"
+DEPEND="${CDEPEND}
+ clang? ( sys-devel/clang )
+ java? ( >=virtual/jdk-1.7 )
+ >=dev-lang/perl-5.10"
+
+pkg_pretend() {
+ if has_version dev-lang/rakudo; then
+ ewarn "Rakudo is known to fail compilation/installation with Rakudo"
+ ewarn "already being installed. So if it fails, try unmerging dev-lang/rakudo,"
+ ewarn "then do a new installation."
+ ewarn "(see Bug #584394)"
+ fi
+}
+
+src_configure() {
+ local backends
+ use moar && backends+="moar,"
+ use java && backends+="jvm"
+
+ local myargs=(
+ "--prefix=/usr"
+ "--sysroot=/"
+ "--sdkroot=/"
+ "--backends=${backends}"
+ )
+
+ perl Configure.pl "${myargs[@]}" || die
+
+ if use java; then
+ NQP=$(java-pkg_getjars --with-dependencies nqp)
+ fi
+}
+
+src_compile() {
+ emake DESTDIR="${D}" NQP_JARS="${NQP}" BLD_NQP_JARS="${NQP}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" NQP_JARS="${NQP}" BLD_NQP_JARS="${NQP}" install
+}
+
+src_test() {
+ RAKUDO_PRECOMP_PREFIX=$(mktemp -d) default
+}
diff --git a/dev-libs/libressl/libressl-2.3.10.ebuild b/dev-libs/libressl/libressl-2.3.10.ebuild
index c77caae8874f..e1b75b6f0b74 100644
--- a/dev-libs/libressl/libressl-2.3.10.ebuild
+++ b/dev-libs/libressl/libressl-2.3.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,8 +6,8 @@ EAPI=6
inherit eutils multilib-minimal
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
-HOMEPAGE="http://www.libressl.org/"
-SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
LICENSE="ISC openssl"
# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
diff --git a/dev-libs/libressl/libressl-2.4.5.ebuild b/dev-libs/libressl/libressl-2.4.5.ebuild
index ecaa889d4c15..b6baa377294b 100644
--- a/dev-libs/libressl/libressl-2.4.5.ebuild
+++ b/dev-libs/libressl/libressl-2.4.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,8 +6,8 @@ EAPI=6
inherit eutils multilib-minimal
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
-HOMEPAGE="http://www.libressl.org/"
-SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
LICENSE="ISC openssl"
# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
diff --git a/dev-libs/libressl/libressl-2.5.0.ebuild b/dev-libs/libressl/libressl-2.5.0.ebuild
index 8505fd8044f2..d6f2accacfa6 100644
--- a/dev-libs/libressl/libressl-2.5.0.ebuild
+++ b/dev-libs/libressl/libressl-2.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,8 +6,8 @@ EAPI=6
inherit eutils multilib-minimal
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
-HOMEPAGE="http://www.libressl.org/"
-SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
LICENSE="ISC openssl"
# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
diff --git a/dev-libs/libressl/libressl-2.5.4.ebuild b/dev-libs/libressl/libressl-2.5.4.ebuild
index c3786d800a14..af8b0f52c259 100644
--- a/dev-libs/libressl/libressl-2.5.4.ebuild
+++ b/dev-libs/libressl/libressl-2.5.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,8 +6,8 @@ EAPI=6
inherit eutils multilib-minimal
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
-HOMEPAGE="http://www.libressl.org/"
-SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
LICENSE="ISC openssl"
# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
diff --git a/dev-libs/libressl/libressl-2.5.5.ebuild b/dev-libs/libressl/libressl-2.5.5.ebuild
index d87e79cad652..a258ec87324d 100644
--- a/dev-libs/libressl/libressl-2.5.5.ebuild
+++ b/dev-libs/libressl/libressl-2.5.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,8 +6,8 @@ EAPI=6
inherit eutils multilib-minimal
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
-HOMEPAGE="http://www.libressl.org/"
-SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
LICENSE="ISC openssl"
# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
diff --git a/dev-libs/libressl/libressl-2.6.0.ebuild b/dev-libs/libressl/libressl-2.6.0.ebuild
index 1d08a6f71c95..44ecf27ddcb0 100644
--- a/dev-libs/libressl/libressl-2.6.0.ebuild
+++ b/dev-libs/libressl/libressl-2.6.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,8 +6,8 @@ EAPI=6
inherit eutils multilib-minimal
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
-HOMEPAGE="http://www.libressl.org/"
-SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
LICENSE="ISC openssl"
# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
diff --git a/dev-libs/libressl/libressl-2.6.1.ebuild b/dev-libs/libressl/libressl-2.6.1.ebuild
index ae81279ce6f1..bd357721d5c6 100644
--- a/dev-libs/libressl/libressl-2.6.1.ebuild
+++ b/dev-libs/libressl/libressl-2.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,8 +6,8 @@ EAPI=6
inherit eutils multilib-minimal
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
-HOMEPAGE="http://www.libressl.org/"
-SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
LICENSE="ISC openssl"
# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
diff --git a/dev-libs/libressl/libressl-2.6.2.ebuild b/dev-libs/libressl/libressl-2.6.2.ebuild
index ae81279ce6f1..bd357721d5c6 100644
--- a/dev-libs/libressl/libressl-2.6.2.ebuild
+++ b/dev-libs/libressl/libressl-2.6.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,8 +6,8 @@ EAPI=6
inherit eutils multilib-minimal
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
-HOMEPAGE="http://www.libressl.org/"
-SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
LICENSE="ISC openssl"
# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
diff --git a/dev-libs/libressl/libressl-2.6.3-r2.ebuild b/dev-libs/libressl/libressl-2.6.3-r2.ebuild
index 22abf48a53e9..f3531ab33515 100644
--- a/dev-libs/libressl/libressl-2.6.3-r2.ebuild
+++ b/dev-libs/libressl/libressl-2.6.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,8 +6,8 @@ EAPI=6
inherit eutils multilib-minimal
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
-HOMEPAGE="http://www.libressl.org/"
-SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
LICENSE="ISC openssl"
# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
diff --git a/dev-libs/libressl/libressl-2.6.4.ebuild b/dev-libs/libressl/libressl-2.6.4.ebuild
index d58d71cae12f..40bc42a9c268 100644
--- a/dev-libs/libressl/libressl-2.6.4.ebuild
+++ b/dev-libs/libressl/libressl-2.6.4.ebuild
@@ -6,8 +6,8 @@ EAPI=6
inherit eutils multilib-minimal
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
-HOMEPAGE="http://www.libressl.org/"
-SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
LICENSE="ISC openssl"
# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
diff --git a/dev-libs/libressl/libressl-2.7.0.ebuild b/dev-libs/libressl/libressl-2.7.0.ebuild
index e57761f47fe3..af207c40014f 100644
--- a/dev-libs/libressl/libressl-2.7.0.ebuild
+++ b/dev-libs/libressl/libressl-2.7.0.ebuild
@@ -6,8 +6,8 @@ EAPI=6
inherit eutils multilib-minimal
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
-HOMEPAGE="http://www.libressl.org/"
-SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
LICENSE="ISC openssl"
# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
diff --git a/dev-libs/libressl/libressl-2.7.1.ebuild b/dev-libs/libressl/libressl-2.7.1.ebuild
index e57761f47fe3..af207c40014f 100644
--- a/dev-libs/libressl/libressl-2.7.1.ebuild
+++ b/dev-libs/libressl/libressl-2.7.1.ebuild
@@ -6,8 +6,8 @@ EAPI=6
inherit eutils multilib-minimal
DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
-HOMEPAGE="http://www.libressl.org/"
-SRC_URI="http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
LICENSE="ISC openssl"
# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
diff --git a/dev-libs/log4cplus/log4cplus-1.2.0.ebuild b/dev-libs/log4cplus/log4cplus-1.2.0.ebuild
index 2ba2caac6fc9..bb4a84c08d97 100644
--- a/dev-libs/log4cplus/log4cplus-1.2.0.ebuild
+++ b/dev-libs/log4cplus/log4cplus-1.2.0.ebuild
@@ -9,7 +9,7 @@ SRC_URI="mirror://sourceforge/project/${PN}/${PN}-stable/${PV}/${P}.tar.bz2"
LICENSE="|| ( Apache-2.0 BSD-2 )"
SLOT="0/1.2-5"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~x86"
IUSE="iconv qt5 threads working-locale working-c-locale"
REQUIRED_USE="?? ( iconv working-locale working-c-locale )"
diff --git a/media-gfx/blender/blender-2.79-r1.ebuild b/media-gfx/blender/blender-2.79-r1.ebuild
index b7db3139bdae..588dd53d6067 100644
--- a/media-gfx/blender/blender-2.79-r1.ebuild
+++ b/media-gfx/blender/blender-2.79-r1.ebuild
@@ -18,7 +18,7 @@ MY_PV="$(get_version_component_range 1-2)"
SLOT="0"
LICENSE="|| ( GPL-2 BL )"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~x86"
IUSE="+bullet +dds +elbeem +game-engine +openexr collada colorio \
cuda cycles debug doc ffmpeg fftw headless jack jemalloc jpeg2k libav \
llvm man ndof nls openal opencl openimageio openmp opensubdiv openvdb \
diff --git a/media-gfx/openvdb/openvdb-4.0.2.ebuild b/media-gfx/openvdb/openvdb-4.0.2.ebuild
index aeac72948ca4..24ec7fce3e5b 100644
--- a/media-gfx/openvdb/openvdb-4.0.2.ebuild
+++ b/media-gfx/openvdb/openvdb-4.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/dreamworksanimation/${PN}/archive/v${PV}.tar.gz -> $
LICENSE="MPL-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~x86"
IUSE="+abi3-compat doc python"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
diff --git a/media-libs/openimageio/openimageio-1.7.17.ebuild b/media-libs/openimageio/openimageio-1.7.17.ebuild
index 163f0a64e763..3738dd9c1823 100644
--- a/media-libs/openimageio/openimageio-1.7.17.ebuild
+++ b/media-libs/openimageio/openimageio-1.7.17.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/OpenImageIO/oiio/archive/Release-${PV}.tar.gz -> ${P
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
+KEYWORDS="amd64 ~ppc64 ~x86"
X86_CPU_FEATURES=(
sse2:sse2 sse3:sse3 ssse3:ssse3 sse4_1:sse4.1 sse4_2:sse4.2
diff --git a/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild b/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
index f34298cd5960..31007283c41f 100644
--- a/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
+++ b/media-libs/opensubdiv/opensubdiv-3.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v${MY_PV}.t
LICENSE="ZLIB"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~x86"
IUSE="cuda doc opencl openmp ptex tbb"
RDEPEND="media-libs/glew:=
diff --git a/media-libs/osl/osl-1.8.12.ebuild b/media-libs/osl/osl-1.8.12.ebuild
index 7e3015859962..038b952f7f47 100644
--- a/media-libs/osl/osl-1.8.12.ebuild
+++ b/media-libs/osl/osl-1.8.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/imageworks/OpenShadingLanguage/archive/Release-${MY_
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~x86"
X86_CPU_FEATURES=( sse2:sse2 sse3:sse3 sse4_1:sse4.1 sse4_2:sse4.2 )
CPU_FEATURES=( ${X86_CPU_FEATURES[@]/#/cpu_flags_x86_} )
diff --git a/media-libs/partio/partio-1.1.0_p20170829.ebuild b/media-libs/partio/partio-1.1.0_p20170829.ebuild
index 00bb039c1b3b..db631a62fd64 100644
--- a/media-libs/partio/partio-1.1.0_p20170829.ebuild
+++ b/media-libs/partio/partio-1.1.0_p20170829.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/wdas/${PN}/archive/${MY_GIT_COMMIT}.tar.gz -> ${P}.t
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 x86"
+KEYWORDS="amd64 x86"
IUSE="doc"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
diff --git a/media-libs/ptex/ptex-2.1.28-r1.ebuild b/media-libs/ptex/ptex-2.1.28-r1.ebuild
index 494ddef43b0e..6b688c975e60 100644
--- a/media-libs/ptex/ptex-2.1.28-r1.ebuild
+++ b/media-libs/ptex/ptex-2.1.28-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/wdas/ptex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~x86"
RDEPEND="sys-libs/zlib:="
DEPEND="${RDEPEND}