summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-containers/syft/Manifest4
-rw-r--r--app-containers/syft/syft-0.54.0.ebuild34
-rw-r--r--app-containers/syft/syft-0.59.0.ebuild34
3 files changed, 0 insertions, 72 deletions
diff --git a/app-containers/syft/Manifest b/app-containers/syft/Manifest
index 3b7d246d3e3e..42744f4f6ed9 100644
--- a/app-containers/syft/Manifest
+++ b/app-containers/syft/Manifest
@@ -1,7 +1,3 @@
-DIST syft-0.54.0-deps.tar.xz 667262532 BLAKE2B f81c3bb54be16c40f3ec811d42c307ef0bf917a06f9f2925b7cce4a1f595092d9efbb7cb20a98a0a0672ca95c257117b2f3da29849fdec453ea054552019cc24 SHA512 e774abcec8786c2c655aa2a369206c79911ea4c706c281c96fb82ec1482c500deb1058bd353a1b107f783eaa41532efdb7a7d50c14c873d612716dc9d8503c57
-DIST syft-0.54.0.tar.gz 3770999 BLAKE2B f33679764fc1904b08f9112a3bfa10f6b8e4ab16c3e1bde81283ad7feede92d9eccf04cd6734dbe11f2d838c0ed45f6a62006f5670eea7271428bae45d5ff55c SHA512 c92991c4c48e60101b55a163506abd89b36f6b80312f9ca3f9953027ba7145dd4f5c5e11c86ca328360991a875637528803e41dcfbba91b204a461de1109c445
-DIST syft-0.59.0-deps.tar.xz 619149756 BLAKE2B acc5118a7d64f5a785d68852984a7c6ab48eb6f745ca53a05a29995b5979c78b574794ad4daceaafa98d489d6d7a2a1e3697bda3818dce5c0dae60d15ac8cb90 SHA512 f5b565c7f19b4825fb799e47bf7971cf9337d495ab110d541a26d35dfffea4599a09911598ee867597c88bf96d289cb4ded5f73f445d68f7b0a85d7f29e5c5f3
-DIST syft-0.59.0.tar.gz 3784520 BLAKE2B fd6336d886cd9c7052b44df2f86f5ec007ffd16e8e33da9d5bd246a4c0b600a5ecd39edd5e99995aee2ee22c04f5c1fd977bd7a70f799e2638d5bd30d078cda2 SHA512 ecf0eb9b9470bceca918b37895688394d3aa6419561437908d6b9f069f12357f1713d872d139fd704817bb4ea454e5aaa0d8f6c7c8a62d046787aa57606c2cb4
DIST syft-0.75.0-deps.tar.xz 449464772 BLAKE2B 60329a7054917079ea2ad683019933b5a5b02441f7ec6823f64b83fd5c353b7096a21113d91d3b9fc1ecaa0870ccef4ee39c60a250f193bef35e15ea1e1b5598 SHA512 1605a7dd830d648e48049bf918c67bbc542dc790c09097db52e578bb826c994ca0364cc42ae510a6411febd90e395715b8a5317e82d424481ae3b835fae98357
DIST syft-0.75.0.tar.gz 5714462 BLAKE2B 4513fb5ce8c9b432d9042e31c13032428db7ae2b7637f25d391c572094706a1bcfa7dc971a96a8630b3d226504000c79219c0cbc6e1372558c6d08c3ff41dfa4 SHA512 4b8f7cc2823ace1fb2a57a5a989690967ac2b0caf2358dd61a85eca418050ff3fb8ea0409fa694754e595f85168f7f2b192fd407f651f48e05932a73b18fa379
DIST syft-0.76.0-deps.tar.xz 457367140 BLAKE2B 8d05372361e6051b8102bec3b775eb00f9f24c5d6cddcee39d5d5b0a8f8db5260173d17aa3922b625885c1dddba42f2c2ecb6afe39b03c61a04a9a9577c4a9c6 SHA512 20f32db12c11a15eb323016fb0df09ec0ad823882344006fd30c4450e25feb9db17b8784581a01ed5a3fd68597ad05749082413c4196deff4b908af56c72b04e
diff --git a/app-containers/syft/syft-0.54.0.ebuild b/app-containers/syft/syft-0.54.0.ebuild
deleted file mode 100644
index 266f7cc93850..000000000000
--- a/app-containers/syft/syft-0.54.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module
-GIT_COMMIT=21eb77206020c04c9ca5316562e32179c73926a9
-
-DESCRIPTION="Generate a Software Bill of Materials from container images and filesystems"
-HOMEPAGE="https://www.anchore.com"
-SRC_URI="https://github.com/anchore/syft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-# tests require a running docker daemon
-RESTRICT="test"
-
-src_compile() {
- local BUILD_DATE
- BUILD_DATE=$(date -u +%Y-%m-%dT%H:%M:%SZ)
- ego build -o bin/syft -ldflags "
- -extldflags '-static'
- -X github.com/anchore/syft/internal/version.version=${PV}
- -X github.com/anchore/syft/internal/version.gitCommit=${GIT_COMMIT}
- -X github.com/anchore/syft/internal/version.buildDate=${BUILD_DATE}
- -X github.com/anchore/syft/internal/version.gitDescription=v${PV}
- " ./cmd/syft
-}
-
-src_install() {
- dobin bin/*
-}
diff --git a/app-containers/syft/syft-0.59.0.ebuild b/app-containers/syft/syft-0.59.0.ebuild
deleted file mode 100644
index 95b08781270d..000000000000
--- a/app-containers/syft/syft-0.59.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module
-GIT_COMMIT=41bc6bb410352845f22766e27dd48ba93aa825a4
-
-DESCRIPTION="Generate a Software Bill of Materials from container images and filesystems"
-HOMEPAGE="https://www.anchore.com"
-SRC_URI="https://github.com/anchore/syft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64"
-
-# tests require a running docker daemon
-RESTRICT="test"
-
-src_compile() {
- local BUILD_DATE
- BUILD_DATE=$(date -u +%Y-%m-%dT%H:%M:%SZ)
- ego build -o bin/syft -ldflags "
- -extldflags '-static'
- -X github.com/anchore/syft/internal/version.version=${PV}
- -X github.com/anchore/syft/internal/version.gitCommit=${GIT_COMMIT}
- -X github.com/anchore/syft/internal/version.buildDate=${BUILD_DATE}
- -X github.com/anchore/syft/internal/version.gitDescription=v${PV}
- " ./cmd/syft
-}
-
-src_install() {
- dobin bin/*
-}