summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-db/aerospike-server-community/Manifest1
-rw-r--r--dev-db/aerospike-server-community/aerospike-server-community-3.8.1.ebuild69
-rw-r--r--eclass/java-utils-2.eclass2
-rw-r--r--eclass/java-virtuals-2.eclass2
-rw-r--r--eclass/java-vm-2.eclass2
-rw-r--r--profiles/features/prefix/make.defaults4
6 files changed, 77 insertions, 3 deletions
diff --git a/dev-db/aerospike-server-community/Manifest b/dev-db/aerospike-server-community/Manifest
index e5d6803c90ce..879ce22fa6e2 100644
--- a/dev-db/aerospike-server-community/Manifest
+++ b/dev-db/aerospike-server-community/Manifest
@@ -1,2 +1,3 @@
DIST aerospike-server-community-3.7.5-debian7.tgz 10810815 SHA256 9177bc49b732534371a27544adafa6792504b90ecb2e1992de7882ed7b221c32 SHA512 55b78b1992fac52f85d0405ae78b590b8af60880da0fc307570e13c2468f7e83fc1b61c3425e4c98fdb955c3d19c96c3f8e557f803c6d8154ec9d3fd453b2ca9 WHIRLPOOL 5569dd54bf68ee68ebb4bc709d8a5d816115781dd3a05997685c1408dfc1129e83f251b973c4f5e736a728998cf8f54543f9800214c9efe6077f1a92c5f40cee
DIST aerospike-server-community-3.7.5.1-debian7.tgz 10811406 SHA256 8f6647c64a9431a7cdc92276ced5146fad6bba45d5cdec53474c739697ecf432 SHA512 125664a82f757ee647d80cf09f7874cec9cef2cb319dad2563b4aea7045c7797755474aacd3d35b52b1f0d1fd37cbf7ca85e985a3d0a29278ffa35fc92f13af2 WHIRLPOOL 1a8d55814567e49e1787de3d9b76641e4ff41a6dd15d913c6f93f3c6ec8e3a13f90c9365691bf8a74fb02c928eadc41ea9230b3137570e521bfc5312c2eeeda2
+DIST aerospike-server-community-3.8.1-debian7.tgz 10981771 SHA256 c10eaa991e24e256b5ce558ade94a6d7480a75a5de1ab78a7620757bf6e7bb7c SHA512 1f54d2dc7a2630981af749b25e4926cb52ab9b0396943e3d753457da79eadae1b4525abb5ebe878368bb5356a6727842a55b92a54d60db9215f696793a7bd6a6 WHIRLPOOL 282f17afeff5f3d458226848a6985b71abe4cf5c1f0eea6b39754fc54132be448e0823562d0522455fe2e467070eba374a0915977416a9e015d481e9b9354ae9
diff --git a/dev-db/aerospike-server-community/aerospike-server-community-3.8.1.ebuild b/dev-db/aerospike-server-community/aerospike-server-community-3.8.1.ebuild
new file mode 100644
index 000000000000..6327f9e2b561
--- /dev/null
+++ b/dev-db/aerospike-server-community/aerospike-server-community-3.8.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils user
+
+DESCRIPTION="Flash-optimized, in-memory, nosql database"
+HOMEPAGE="http://www.aerospike.com"
+SRC_URI="http://www.aerospike.com/artifacts/${PN}/${PV}/${P}-debian7.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="app-crypt/gcr"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}-debian7"
+
+pkg_setup() {
+ enewgroup aerospike
+ enewuser aerospike -1 /bin/bash /opt/aerospike aerospike
+}
+
+src_prepare() {
+ local server_deb="${P}.debian7.x86_64.deb"
+ local tools_deb="aerospike-tools-3.8.0.debian7.x86_64.deb"
+
+ ar x "${server_deb}" || die
+ tar xzf data.tar.gz && rm data.tar.gz || die
+
+ ar x "${tools_deb}" || die
+ tar xzf data.tar.gz && rm data.tar.gz || die
+
+ rm *.deb asinstall control.tar.gz debian-binary LICENSE SHA256SUMS
+ rm usr/bin/{asfixownership,asmigrate2to3}
+}
+
+src_install() {
+ insinto /opt/
+ doins -r opt/aerospike
+
+ fperms +x -R /opt/aerospike/bin/
+ fperms +x -R /opt/aerospike/lib/python/
+
+ for dir in '/etc' '/var/log'; do
+ keepdir "${dir}/aerospike"
+ done
+
+ insinto /etc/aerospike
+ for conf in 'aerospike.conf' 'aerospike_mesh.conf' 'aerospike_ssd.conf'; do
+ doins "${FILESDIR}/${conf}"
+ done
+
+ insinto /usr/bin
+ doins usr/bin/*
+ fperms +x -R /usr/bin/asd
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/aerospike.logrotate aerospike
+
+ newinitd "${FILESDIR}"/aerospike.init aerospike
+
+ fowners -R aerospike:aerospike /opt/aerospike/
+ fowners aerospike:aerospike /usr/bin/asd
+ fowners -R aerospike:aerospike /var/log/aerospike
+}
diff --git a/eclass/java-utils-2.eclass b/eclass/java-utils-2.eclass
index cb1c1d8b1301..65e7197ef427 100644
--- a/eclass/java-utils-2.eclass
+++ b/eclass/java-utils-2.eclass
@@ -37,7 +37,7 @@ has "${EAPI}" 0 1 && JAVA_PKG_PORTAGE_DEP=">=sys-apps/portage-2.1.2.7"
# This is a convience variable to be used from the other java eclasses. This is
# the version of java-config we want to use. Usually the latest stable version
# so that ebuilds can use new features without depending on specific versions.
-JAVA_PKG_E_DEPEND=">=dev-java/java-config-2.2.0 ${JAVA_PKG_PORTAGE_DEP}"
+JAVA_PKG_E_DEPEND=">=dev-java/java-config-2.2.0-r3 ${JAVA_PKG_PORTAGE_DEP}"
has source ${JAVA_PKG_IUSE} && JAVA_PKG_E_DEPEND="${JAVA_PKG_E_DEPEND} source? ( app-arch/zip )"
# @ECLASS-VARIABLE: JAVA_PKG_WANT_BOOTCLASSPATH
diff --git a/eclass/java-virtuals-2.eclass b/eclass/java-virtuals-2.eclass
index 0c92018c7bab..8018aa8c6c97 100644
--- a/eclass/java-virtuals-2.eclass
+++ b/eclass/java-virtuals-2.eclass
@@ -14,7 +14,7 @@
inherit java-utils-2
-DEPEND=">=dev-java/java-config-2.2.0"
+DEPEND=">=dev-java/java-config-2.2.0-r3"
RDEPEND="${DEPEND}"
S="${WORKDIR}"
diff --git a/eclass/java-vm-2.eclass b/eclass/java-vm-2.eclass
index 7a5ba834e518..d0de0d2950ed 100644
--- a/eclass/java-vm-2.eclass
+++ b/eclass/java-vm-2.eclass
@@ -15,7 +15,7 @@ inherit eutils fdo-mime multilib pax-utils prefix
EXPORT_FUNCTIONS pkg_setup pkg_postinst pkg_prerm pkg_postrm
RDEPEND="
- >=dev-java/java-config-2.2.0
+ >=dev-java/java-config-2.2.0-r3
app-eselect/eselect-java"
DEPEND="${RDEPEND}"
has "${EAPI}" 0 1 && DEPEND="${DEPEND} >=sys-apps/portage-2.1"
diff --git a/profiles/features/prefix/make.defaults b/profiles/features/prefix/make.defaults
index 4884f1fb6eb5..68835e0ac898 100644
--- a/profiles/features/prefix/make.defaults
+++ b/profiles/features/prefix/make.defaults
@@ -2,6 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
+# Michael Haubenwallner <haubi@gentoo.org> (19 Apr 2016)
+# We can not use xattrs by default in Prefix.
+USE="-xattr"
+
# Jeremy Olexa <darkside@gentoo.org> (30 Jun 2009)
# As of now, there does not exist a reliable working sandbox implementation on
# any Gentoo Prefix platform. Lately, sandbox has caused *many* issues that