summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/ffmpeg/ffmpeg-3.2.2.ebuild2
-rw-r--r--media-video/ffmpeg/files/chromaprint14.patch24
2 files changed, 26 insertions, 0 deletions
diff --git a/media-video/ffmpeg/ffmpeg-3.2.2.ebuild b/media-video/ffmpeg/ffmpeg-3.2.2.ebuild
index 38429b2c03cf..9b30ce43fb37 100644
--- a/media-video/ffmpeg/ffmpeg-3.2.2.ebuild
+++ b/media-video/ffmpeg/ffmpeg-3.2.2.ebuild
@@ -284,6 +284,8 @@ RESTRICT="
S=${WORKDIR}/${P/_/-}
+PATCHES=( "${FILESDIR}/chromaprint14.patch" )
+
MULTILIB_WRAPPED_HEADERS=(
/usr/include/libavutil/avconfig.h
)
diff --git a/media-video/ffmpeg/files/chromaprint14.patch b/media-video/ffmpeg/files/chromaprint14.patch
new file mode 100644
index 000000000000..d166247eca76
--- /dev/null
+++ b/media-video/ffmpeg/files/chromaprint14.patch
@@ -0,0 +1,24 @@
+commit 581f93f37ef2e7a00662828ed0348d1edb9041fe
+Author: Georgi D. Sotirov <gdsotirov@dir.bg>
+Date: Tue Dec 6 21:07:59 2016 +0100
+
+ lavf/chromaprint: Update for version 1.4
+
+ Fixes ticket #5997.
+
+diff --git a/libavformat/chromaprint.c b/libavformat/chromaprint.c
+index 8c9a6c0111..4da02bef76 100644
+--- a/libavformat/chromaprint.c
++++ b/libavformat/chromaprint.c
+@@ -39,7 +39,11 @@ typedef struct ChromaprintMuxContext {
+ int silence_threshold;
+ int algorithm;
+ FingerprintFormat fp_format;
++#if CPR_VERSION_INT >= AV_VERSION_INT(1, 4, 0)
++ ChromaprintContext *ctx;
++#else
+ ChromaprintContext ctx;
++#endif
+ } ChromaprintMuxContext;
+
+ static void cleanup(ChromaprintMuxContext *cpr)