summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/puremagic/Manifest1
-rw-r--r--dev-python/puremagic/puremagic-1.15.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/puremagic/Manifest b/dev-python/puremagic/Manifest
index 66d25090737a..ada560b5e1c6 100644
--- a/dev-python/puremagic/Manifest
+++ b/dev-python/puremagic/Manifest
@@ -1 +1,2 @@
DIST puremagic-1.14.gh.tar.gz 295823 BLAKE2B b505f34d6744a0c9aa3a0c43846c150c9e1101884a825507b0941da84b181c1ed620dcf5457a5e60ec1fa5c93203d755297c4e3b37d311537dc6a248daf3031e SHA512 00d008f70849179a67a1794740cb34bd28386036e54a9c3f54aefb24c7fb6adccb624e0546ca86863e913c7178b6590473c3ce4fda906e9fd9306be483de28ec
+DIST puremagic-1.15.gh.tar.gz 295922 BLAKE2B b78a691fe5843eec7be4874c11492565ce474a741bd80cb5787bbfacd4522363acf880071d4e9b3beab14287890e851da1e92eeea2aacce1161729287b99ce9e SHA512 46d8ad7e2aa309558e37589b8a9508ef4156a5d6768b738df5f8539cb9edc12d83ac46a2fd46ef48d9323c73dfeff0e6f5eee8046bdd910f6ea14bb5402e477e
diff --git a/dev-python/puremagic/puremagic-1.15.ebuild b/dev-python/puremagic/puremagic-1.15.ebuild
new file mode 100644
index 000000000000..73b1f5be482d
--- /dev/null
+++ b/dev-python/puremagic/puremagic-1.15.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python implementation of magic file detection"
+HOMEPAGE="
+ https://github.com/cdgriffith/puremagic/
+ https://pypi.org/project/puremagic/
+"
+SRC_URI="
+ https://github.com/cdgriffith/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( CHANGELOG.md README.rst )
+
+distutils_enable_tests pytest