summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/birthday/birthday-1.6.2.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/app-misc/birthday/birthday-1.6.2.ebuild b/app-misc/birthday/birthday-1.6.2.ebuild
index 600b93523b1b..c8f79f8f04da 100644
--- a/app-misc/birthday/birthday-1.6.2.ebuild
+++ b/app-misc/birthday/birthday-1.6.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -18,8 +18,12 @@ src_unpack() {
cd "${S}"
# Don't strip, install in correct share dir and respect CFLAGS
- sed -i -e "s:install -s:install:g" -e "s:#SHARE:SHARE:g" -e "s:-O2:${CFLAGS}:g" \
- Makefile || die
+ sed \
+ -e "s:install -s:install:g" -e "s:#SHARE:SHARE:g" -e "s:-O2:${CFLAGS}:g" \
+ -i Makefile || die
+ sed \
+ -e 's:grep -v:grep --binary-files=text -v:g' \
+ -i runtest.sh || die
}
src_compile() {