summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/evemu/Manifest1
-rw-r--r--app-misc/evemu/evemu-2.4.0.ebuild44
-rw-r--r--eclass/vim-plugin.eclass1
-rw-r--r--media-gfx/gimp/gimp-2.9.2-r2.ebuild6
-rw-r--r--media-gfx/gimp/gimp-2.9.4.ebuild6
-rw-r--r--media-gfx/gimp/gimp-9999.ebuild2
-rw-r--r--media-sound/xfmpc/Manifest1
-rw-r--r--media-sound/xfmpc/xfmpc-0.2.3.ebuild29
-rw-r--r--xfce-extra/thunar-vcs-plugin/Manifest1
-rw-r--r--xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.5.ebuild39
-rw-r--r--xfce-extra/xfce4-notifyd/Manifest1
-rw-r--r--xfce-extra/xfce4-notifyd/xfce4-notifyd-0.3.0.ebuild32
12 files changed, 160 insertions, 3 deletions
diff --git a/app-misc/evemu/Manifest b/app-misc/evemu/Manifest
index c83b7e1fb55d..6110031de0bb 100644
--- a/app-misc/evemu/Manifest
+++ b/app-misc/evemu/Manifest
@@ -1,2 +1,3 @@
DIST evemu-2.1.0.tar.xz 502240 SHA256 0c87360882751356e9f977ebf7438c00fe97deb232ac725dd86e5ba78203ee97 SHA512 16ed613aa465d85f617a5dd6b958b0480c55477836effc86c293facdb500152d5b387a79f14802f2db6a3c721cc754cac2e8fc605f5e689962742b8fc361c81b WHIRLPOOL bc4e9631eebe6329d726adf853e8ef716246d70cf4f3ee50497bec6d654c8483c9291a40f532d488813d0c2568cd106e03a131cfa6aab86f037ad3ee1f0a8d18
DIST evemu-2.2.0.tar.xz 492184 SHA256 e0f79808959d1b1f307a3d5add8ee9e5786d926e9aeb0045dadb85c7350d0a3c SHA512 638fa4962dae2aa88d70d1c30a244eab67ccc102af47a6de4b93f32b9f2b9d767d7f358efb71964c62f461e93c431bb679ad7019e2509f0cd4c02bd0e94a29d9 WHIRLPOOL 0f7cd045a8ad217a562fe640c5fc0f0bff890a725e1786741a5a412f24a866c997f18bf0dd404a804ed2e0718b85464797d21e1f8a3fdbee63216504d12ac09e
+DIST evemu-2.4.0.tar.xz 505848 SHA256 0706ea5a830203f9cdb30c0e10c8c41d2427128ba9041543a5ae157fa3b4a30e SHA512 e629a0eedb6ce58d3f088b279f45b87117b30b01af07e53dd5515ced7ea15293476fafe9aa9832e6758a6953ad7a462b0fae0a0996181eec327377176cf00c7a WHIRLPOOL ad909f5e074dfdd0d6c9f3660844024f94da587f97cf9181e5ab1232fe077c8df47cca045b598a472bbf6ec776c2cbf313908a800d95a539173770080fb388ce
diff --git a/app-misc/evemu/evemu-2.4.0.ebuild b/app-misc/evemu/evemu-2.4.0.ebuild
new file mode 100644
index 000000000000..18259c7e5c96
--- /dev/null
+++ b/app-misc/evemu/evemu-2.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="tools and bindings for kernel evdev device emulation, data capture, and replay"
+HOMEPAGE="https://www.freedesktop.org/wiki/Evemu/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ >=dev-libs/libevdev-1.2.99.902"
+DEPEND="app-arch/xz-utils
+ ${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable python python-bindings)
+}
+
+src_test() {
+ if use python ; then
+ if [[ ! ${EUID} -eq 0 ]] || has sandbox $FEATURES || has usersandbox $FEATURES ; then
+ ewarn "Tests require userpriv, sandbox, and usersandbox to be disabled in FEATURES."
+ else
+ emake check
+ fi
+ fi
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/eclass/vim-plugin.eclass b/eclass/vim-plugin.eclass
index e6aa02a458e1..d684c4e63529 100644
--- a/eclass/vim-plugin.eclass
+++ b/eclass/vim-plugin.eclass
@@ -5,6 +5,7 @@
# @ECLASS: vim-plugin.eclass
# @MAINTAINER:
# vim@gentoo.org
+# @BLURB: used for installing vim plugins
# @DESCRIPTION:
# This eclass simplifies installation of app-vim plugins into
# /usr/share/vim/vimfiles. This is a version-independent directory
diff --git a/media-gfx/gimp/gimp-2.9.2-r2.ebuild b/media-gfx/gimp/gimp-2.9.2-r2.ebuild
index 361eccee58d7..3748dcaa4310 100644
--- a/media-gfx/gimp/gimp-2.9.2-r2.ebuild
+++ b/media-gfx/gimp/gimp-2.9.2-r2.ebuild
@@ -43,7 +43,6 @@ RDEPEND=">=dev-libs/glib-2.30.2:2
aalib? ( media-libs/aalib )
alsa? ( media-libs/alsa-lib )
aqua? ( x11-libs/gtk-mac-integration )
- dev-util/gdbus-codegen
gnome? ( gnome-base/gvfs )
webkit? ( >=net-libs/webkit-gtk-1.6.1:2 )
virtual/jpeg:0
@@ -125,6 +124,11 @@ src_prepare() {
gnome2_src_prepare
}
+src_configure() {
+ gnome2_src_configure \
+ GDBUS_CODEGEN=/bin/false
+}
+
src_compile() {
addwrite /dev/nvidiactl # bug #569738
addwrite /dev/nvidia0 # bug #569738
diff --git a/media-gfx/gimp/gimp-2.9.4.ebuild b/media-gfx/gimp/gimp-2.9.4.ebuild
index 4d8622f5945f..6af71f4cc971 100644
--- a/media-gfx/gimp/gimp-2.9.4.ebuild
+++ b/media-gfx/gimp/gimp-2.9.4.ebuild
@@ -44,7 +44,6 @@ RDEPEND=">=dev-libs/glib-2.30.2:2
aalib? ( media-libs/aalib )
alsa? ( media-libs/alsa-lib )
aqua? ( x11-libs/gtk-mac-integration )
- dev-util/gdbus-codegen
gnome? ( gnome-base/gvfs )
webkit? ( >=net-libs/webkit-gtk-1.6.1:2 )
virtual/jpeg:0
@@ -127,6 +126,11 @@ src_prepare() {
gnome2_src_prepare
}
+src_configure() {
+ gnome2_src_configure \
+ GDBUS_CODEGEN=/bin/false
+}
+
src_compile() {
addwrite /dev/nvidiactl # bug #569738
addwrite /dev/nvidia0 # bug #569738
diff --git a/media-gfx/gimp/gimp-9999.ebuild b/media-gfx/gimp/gimp-9999.ebuild
index 040199d38714..6b5628950fcb 100644
--- a/media-gfx/gimp/gimp-9999.ebuild
+++ b/media-gfx/gimp/gimp-9999.ebuild
@@ -46,7 +46,6 @@ RDEPEND=">=dev-libs/glib-2.40.0:2
aalib? ( media-libs/aalib )
alsa? ( media-libs/alsa-lib )
aqua? ( x11-libs/gtk-mac-integration )
- dev-util/gdbus-codegen
gnome? ( gnome-base/gvfs )
webkit? ( >=net-libs/webkit-gtk-1.6.1:2 )
virtual/jpeg:0
@@ -70,6 +69,7 @@ RDEPEND=">=dev-libs/glib-2.40.0:2
postscript? ( app-text/ghostscript-gpl )
udev? ( virtual/libgudev:= )"
DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
sys-apps/findutils
virtual/pkgconfig
>=dev-util/intltool-0.40.1
diff --git a/media-sound/xfmpc/Manifest b/media-sound/xfmpc/Manifest
index 3998fc7d5a11..ff9e34ba6af6 100644
--- a/media-sound/xfmpc/Manifest
+++ b/media-sound/xfmpc/Manifest
@@ -1 +1,2 @@
DIST xfmpc-0.2.2.tar.bz2 404906 SHA256 ed0cc2940bd5928bb30fab1531c22185a97bd0cc5beacd9e3be4d4cd994a6862 SHA512 a90697bcd86e7f3952faa4d37800755a49a09886de7a95ae69b4e8a59b7750b1098d372b1734eadf3bb1d2c74fc5447707fc0203de435cfa51423530c663f6c7 WHIRLPOOL 69e43254f37dba722cc2e17864f8079a831a028f2af95deeaa88fcbd236fed533d5a5a83f59c07f86a18ce956299c4c340b25968069ef0843edcef69d4724c57
+DIST xfmpc-0.2.3.tar.bz2 414680 SHA256 4189c0c82b66b758a6d5bc651493b675d3d46329e5f1a76ff26c448125f4fcb0 SHA512 3f592fdd559817051f7720bafc07fc66b39f682cc20286c12d54c4bd607e85bb0a722c567264a29224971b4ac14db51b0b44b233a16cccd9d17579a50549a3be WHIRLPOOL c39b986e333b8ad0e59703bf2caf6c556388f75c81b6d300fdfbcd21fc118dff7ad8906afc7980e1db50455d46e3254892d0ffae38c48d51efb6d7be900b616d
diff --git a/media-sound/xfmpc/xfmpc-0.2.3.ebuild b/media-sound/xfmpc/xfmpc-0.2.3.ebuild
new file mode 100644
index 000000000000..0b88af1ae143
--- /dev/null
+++ b/media-sound/xfmpc/xfmpc-0.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Music Player Daemon (MPD) client for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/xfmpc"
+SRC_URI="mirror://xfce/src/apps/${PN}/0.2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.18:2=
+ >=media-libs/libmpd-0.15:=
+ >=x11-libs/gtk+-2.16:2=
+ >=xfce-base/libxfce4ui-4.8:=
+ >=xfce-base/libxfce4util-4.8:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=( $(xfconf_use_debug) )
+ DOCS=( AUTHORS ChangeLog IDEAS NEWS README THANKS )
+}
diff --git a/xfce-extra/thunar-vcs-plugin/Manifest b/xfce-extra/thunar-vcs-plugin/Manifest
index 3e9adb86d969..ac1da470e143 100644
--- a/xfce-extra/thunar-vcs-plugin/Manifest
+++ b/xfce-extra/thunar-vcs-plugin/Manifest
@@ -4,3 +4,4 @@ DIST thunar-vcs-plugin-0.1.4-ru.po.bz2 4323 SHA256 50f9f84162317e3bcc5243eb06882
DIST thunar-vcs-plugin-0.1.4-ug.po.bz2 4628 SHA256 ea50f843b721f7f1e31ec9abcba755a24c7834d2f3a64b309cf459e7a46f64e5 SHA512 563c6f235eb6e5a049846052e5bfad1ad6a40c598b013e83ad12d50c4a070bb3faec5362ec02c56bfac14d752918b65b7089bef729a1004245539c22d10255db WHIRLPOOL 2a4df5619f00580440308ceb0a6281ed67221ef3ca27ec4e88ec90dec6c5b73372f2c6cdd9c079a205677671844051069e40c7560a917dd3728a58f4da3acbe1
DIST thunar-vcs-plugin-0.1.4-uk.po.bz2 5469 SHA256 a43df313ce3a2968a83efa41a46193ef42b095913cbed27230d3ac092ca2b08a SHA512 e1b0b6ab444fb46d626c889b9b2509e21b00aa380c40da5b871a4e6c12fd34609bd0a74b2f7b5894601ad5fe4727fdb177ae7af0f0ef457f23021287d6dca8ff WHIRLPOOL afa9d171c22fdfa467958a1946ceb7d9b0726d7d3d80a8dacf1cd1241d45a5fa9e29f305d459a92656b9fb84c1c470ea36fdacf21e7922667b6790211a342c28
DIST thunar-vcs-plugin-0.1.4.tar.bz2 435835 SHA256 7dbbdb22113cec40f6dc46cf4fd113b47928af15ba64e9fc66305a01c4291d4c SHA512 037ca986ab9030146fc409d78d235a157b956b202449ef8e68de77dfce29ba2dd9a2dabc793215dd9ce455f97d8c5400ba51c8254b3c07b3e0d87572df672151 WHIRLPOOL ca5eafc6a3e0061c3b87afc93f1ede109b17919e8915565b004b3302d4e21493c1880b7645f90b2dcc288fde84c7249754f0652e8ebbe20139bab6d193b4ab1f
+DIST thunar-vcs-plugin-0.1.5.tar.bz2 478866 SHA256 7094f576865957397eefcdb1b05ba9be020a396c12949077507ea1573b1ef451 SHA512 0315613fe97d5cb2fa9589af49bdb5074f20c83b52d5f7d4a151091839679b4617e8e0b20df85914b7bcef2464173dc1bd2bc182312364c7d5a94171aba28983 WHIRLPOOL f5e90202bb852913414ff13de4bc2c0a35fd7cae572b7b64040cc0346bc83b16fc95b514f4f86cd73e6b6ca0b5faa19917af7bc76f9e27c0684665125131cd07
diff --git a/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.5.ebuild b/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.5.ebuild
new file mode 100644
index 000000000000..5ab8bba8f72f
--- /dev/null
+++ b/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Adds Subversion and GIT actions to the context menu of thunar"
+HOMEPAGE="http://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin"
+SRC_URI="mirror://xfce/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +git +subversion"
+
+RDEPEND=">=dev-libs/glib-2.18:2=
+ >=x11-libs/gtk+-2.14:2=
+ >=xfce-base/exo-0.6:=
+ >=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/thunar-1.2:=
+ git? ( dev-vcs/git )
+ subversion? (
+ >=dev-libs/apr-0.9.7:=
+ >=dev-vcs/subversion-1.5:=
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable subversion)
+ $(use_enable git)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
diff --git a/xfce-extra/xfce4-notifyd/Manifest b/xfce-extra/xfce4-notifyd/Manifest
index f03a28d438db..a4ca41d15715 100644
--- a/xfce-extra/xfce4-notifyd/Manifest
+++ b/xfce-extra/xfce4-notifyd/Manifest
@@ -1 +1,2 @@
DIST xfce4-notifyd-0.2.4.tar.bz2 361619 SHA256 8c7ed62f9496816d1391281f77d1b32216f9bf6fd22fbe4f6f3f4e07a6bbced0 SHA512 4cee6395ee925e41ec22baa0fca21b38261a547ddff32f6c140db91996e2aa39b86113ffbe42da3c98728513a10eadd99504a05f31100762eb5b19bf8a74ae7c WHIRLPOOL d3e33bae0292852f8645a83d469e0fc093edbc038210aec7f02a879aa28cce81b95ab937a63d890f3f5177008c070721d488076272705a76b66cafedf9f65919
+DIST xfce4-notifyd-0.3.0.tar.bz2 427170 SHA256 7076081424932b40d03366a7518daf495f81eb780f376819e59e76d65d811100 SHA512 774eb0daf935fcf3fdb8a40b03ef772b45c4b12408a5e84aff57c0e8c8490c0f3ec4753893dd07a31b7e8094fd065a8a86f56f2e6217ddd6432a8eda0dcb9f9f WHIRLPOOL fcba9a42ca476deec27d12e80953a87ca073418706cd282bfbcda96e3c058e3dbe87ef2fced6a679c96c72485067439020a0ef49548c6172eb4401c7141c94a6
diff --git a/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.3.0.ebuild b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.3.0.ebuild
new file mode 100644
index 000000000000..6434b5944154
--- /dev/null
+++ b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Notification daemon for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/xfce4-notifyd"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.42:2=
+ >=x11-libs/gtk+-3.14:3=
+ >=x11-libs/libnotify-0.7:=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfconf-4.10:="
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=( $(xfconf_use_debug) )
+ DOCS=( AUTHORS NEWS README TODO )
+}