summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/bcc/bcc-0.26.0-r1.ebuild (renamed from dev-util/bcc/bcc-0.26.0.ebuild)2
-rw-r--r--eclass/cmake.eclass4
-rw-r--r--eclass/dotnet.eclass4
-rw-r--r--eclass/mono.eclass4
-rw-r--r--eclass/unpacker.eclass8
-rw-r--r--profiles/base/make.defaults2
-rw-r--r--profiles/embedded/make.defaults2
-rw-r--r--profiles/package.mask4
-rw-r--r--sys-devel/mold/mold-1.7.1-r1.ebuild (renamed from sys-devel/mold/mold-1.7.1.ebuild)4
-rw-r--r--sys-devel/mold/mold-1.8.0-r1.ebuild (renamed from sys-devel/mold/mold-1.8.0.ebuild)4
-rw-r--r--sys-devel/mold/mold-9999.ebuild4
-rw-r--r--sys-fs/btrfs-progs/Manifest1
-rw-r--r--sys-fs/btrfs-progs/btrfs-progs-6.1.1.ebuild150
-rw-r--r--sys-fs/btrfs-progs/btrfs-progs-6.1.ebuild150
14 files changed, 24 insertions, 319 deletions
diff --git a/dev-util/bcc/bcc-0.26.0.ebuild b/dev-util/bcc/bcc-0.26.0-r1.ebuild
index f4e7887f0085..edac8187bcbe 100644
--- a/dev-util/bcc/bcc-0.26.0.ebuild
+++ b/dev-util/bcc/bcc-0.26.0-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
LUA_COMPAT=( luajit )
PYTHON_COMPAT=( python3_{8..11} )
-LLVM_MAX_SLOT=14
+LLVM_MAX_SLOT=15
inherit cmake linux-info llvm lua-single python-r1 toolchain-funcs
diff --git a/eclass/cmake.eclass b/eclass/cmake.eclass
index 094b6d706bc2..2c5620adede5 100644
--- a/eclass/cmake.eclass
+++ b/eclass/cmake.eclass
@@ -1,9 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: cmake.eclass
# @MAINTAINER:
# kde@gentoo.org
+# base-system@gentoo.org
# @AUTHOR:
# Tomáš Chvátal <scarabeus@gentoo.org>
# Maciej Mrozowski <reavertm@gentoo.org>
@@ -96,6 +97,7 @@ fi
# By default it uses current working directory (in EAPI-7: ${S}).
# @ECLASS_VARIABLE: CMAKE_VERBOSE
+# @USER_VARIABLE
# @DESCRIPTION:
# Set to OFF to disable verbose messages during compilation
: ${CMAKE_VERBOSE:=ON}
diff --git a/eclass/dotnet.eclass b/eclass/dotnet.eclass
index b92b9c1b4054..1fb288dd1094 100644
--- a/eclass/dotnet.eclass
+++ b/eclass/dotnet.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: dotnet.eclass
@@ -131,7 +131,7 @@ dotnet_multilib_comply() {
then
for exe in "${ED}/usr/bin"/*
do
- if [[ "$(file "${exe}")" == *"shell script text"* ]]
+ if [[ "$(file -S "${exe}")" == *"shell script text"* ]]
then
sed -r -i -e ":/lib(/|$): s:/lib(/|$):/$(get_libdir)\1:" \
"${exe}" || die "Sedding some sense into ${exe} failed"
diff --git a/eclass/mono.eclass b/eclass/mono.eclass
index ddea2d4b9c64..c096acc8c40e 100644
--- a/eclass/mono.eclass
+++ b/eclass/mono.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: mono.eclass
@@ -76,7 +76,7 @@ mono_multilib_comply() {
then
for exe in "${ED}/usr/bin"/*
do
- if [[ "$(file "${exe}")" == *"shell script text"* ]]
+ if [[ "$(file -S "${exe}")" == *"shell script text"* ]]
then
sed -r -i -e ":/lib(/|$): s:/lib(/|$):/$(get_libdir)\1:" \
"${exe}" || die "Sedding some sense into ${exe} failed"
diff --git a/eclass/unpacker.eclass b/eclass/unpacker.eclass
index 5ce681ebaa0d..326b2fa67524 100644
--- a/eclass/unpacker.eclass
+++ b/eclass/unpacker.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: unpacker.eclass
@@ -122,7 +122,7 @@ unpack_pdv() {
local tmpfile="${T}/${FUNCNAME}"
tail -c +$((${tailskip}+1)) ${src} 2>/dev/null | head -c 512 > "${tmpfile}"
- local iscompressed=$(file -b "${tmpfile}")
+ local iscompressed=$(file -S -b "${tmpfile}")
if [[ ${iscompressed:0:8} == "compress" ]] ; then
iscompressed=1
mv "${tmpfile}"{,.Z}
@@ -130,7 +130,7 @@ unpack_pdv() {
else
iscompressed=0
fi
- local istar=$(file -b "${tmpfile}")
+ local istar=$(file -S -b "${tmpfile}")
if [[ ${istar:0:9} == "POSIX tar" ]] ; then
istar=1
else
@@ -244,7 +244,7 @@ unpack_makeself() {
# lets grab the first few bytes of the file to figure out what kind of archive it is
local decomp= filetype suffix
- filetype=$("${exe[@]}" 2>/dev/null | head -c 512 | file -b -) || die
+ filetype=$("${exe[@]}" 2>/dev/null | head -c 512 | file -S -b -) || die
case ${filetype} in
*tar\ archive*)
decomp=cat
diff --git a/profiles/base/make.defaults b/profiles/base/make.defaults
index 332b189ec623..d7bc0fde9322 100644
--- a/profiles/base/make.defaults
+++ b/profiles/base/make.defaults
@@ -43,7 +43,7 @@ CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf"
# GOBIN needs to be cleaned as random values in GOBIN can affect the
# building of some packages:
# https://archives.gentoo.org/gentoo-dev/message/163010f83ae7819d80c0cfdf797cbfe0
-ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY CARGO_HOME XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_STATE_HOME XDG_RUNTIME_DIR PERL_MM_OPT PERL5LIB PERL5OPT PERL_MB_OPT PERL_CORE PERLPREFIX GOBIN GOPATH"
+ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY CARGO_HOME GDK_PIXBUF_MODULE_FILE XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_STATE_HOME XDG_RUNTIME_DIR PERL_MM_OPT PERL5LIB PERL5OPT PERL_MB_OPT PERL_CORE PERLPREFIX GOBIN GOPATH"
# Variables that are set exclusively by the profile
# and not by user configuration files.
diff --git a/profiles/embedded/make.defaults b/profiles/embedded/make.defaults
index 050826ef6951..5b6dc2b40640 100644
--- a/profiles/embedded/make.defaults
+++ b/profiles/embedded/make.defaults
@@ -70,7 +70,7 @@ CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf"
# GOBIN needs to be cleaned as random values in GOBIN can affect the
# building of some packages:
# https://archives.gentoo.org/gentoo-dev/message/163010f83ae7819d80c0cfdf797cbfe0
-ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY CARGO_HOME XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_STATE_HOME XDG_RUNTIME_DIR PERL_MM_OPT PERL5LIB PERL5OPT PERL_MB_OPT PERL_CORE PERLPREFIX GOBIN GOPATH"
+ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY CARGO_HOME GDK_PIXBUF_MODULE_FILE XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_STATE_HOME XDG_RUNTIME_DIR PERL_MM_OPT PERL5LIB PERL5OPT PERL_MB_OPT PERL_CORE PERLPREFIX GOBIN GOPATH"
# Tiziano Müller <dev-zero@gentoo.org> (2010-01-24)
# We usually don't want python to (re)write .py[co] files during phase runs
diff --git a/profiles/package.mask b/profiles/package.mask
index 88dbb6f6d99c..1b7fad0872e1 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -33,6 +33,10 @@
#--- END OF EXAMPLES ---
+# Sam James <sam@gentoo.org> (2023-01-05)
+# Breaks reverse dependencies: bug #889694, bug #888579.
+=sys-fs/btrfs-progs-6.1.1
+
# David Seifert <soap@gentoo.org> (2023-01-02)
# EAPI 6, pretty much no upstream activity, outdated, last upstream
# release over 3 years ago, no revdeps. Removal on 2023-02-01.
diff --git a/sys-devel/mold/mold-1.7.1.ebuild b/sys-devel/mold/mold-1.7.1-r1.ebuild
index 82b43f78b777..8063ade34f39 100644
--- a/sys-devel/mold/mold-1.7.1.ebuild
+++ b/sys-devel/mold/mold-1.7.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -22,7 +22,7 @@ SLOT="0"
RDEPEND="
app-arch/zstd:=
- >=dev-cpp/tbb-2021.7.0:=
+ >=dev-cpp/tbb-2021.7.0-r1:=
sys-libs/zlib
!kernel_Darwin? (
>=dev-libs/mimalloc-2:=
diff --git a/sys-devel/mold/mold-1.8.0.ebuild b/sys-devel/mold/mold-1.8.0-r1.ebuild
index 82b43f78b777..8063ade34f39 100644
--- a/sys-devel/mold/mold-1.8.0.ebuild
+++ b/sys-devel/mold/mold-1.8.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -22,7 +22,7 @@ SLOT="0"
RDEPEND="
app-arch/zstd:=
- >=dev-cpp/tbb-2021.7.0:=
+ >=dev-cpp/tbb-2021.7.0-r1:=
sys-libs/zlib
!kernel_Darwin? (
>=dev-libs/mimalloc-2:=
diff --git a/sys-devel/mold/mold-9999.ebuild b/sys-devel/mold/mold-9999.ebuild
index 82b43f78b777..8063ade34f39 100644
--- a/sys-devel/mold/mold-9999.ebuild
+++ b/sys-devel/mold/mold-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -22,7 +22,7 @@ SLOT="0"
RDEPEND="
app-arch/zstd:=
- >=dev-cpp/tbb-2021.7.0:=
+ >=dev-cpp/tbb-2021.7.0-r1:=
sys-libs/zlib
!kernel_Darwin? (
>=dev-libs/mimalloc-2:=
diff --git a/sys-fs/btrfs-progs/Manifest b/sys-fs/btrfs-progs/Manifest
index 4a9d913b6aed..72a4bc6c206d 100644
--- a/sys-fs/btrfs-progs/Manifest
+++ b/sys-fs/btrfs-progs/Manifest
@@ -1,4 +1,3 @@
DIST btrfs-progs-v5.15.1.tar.xz 2280796 BLAKE2B b460254a6261d3d04a2d265a3b4e05a89385888f7ea4f2b16ec5b73922646c7f47a546fc78ba7c009e65914125435cf38157eabffc74f5d00df2c21c844922e3 SHA512 68ed89e337ae857fdaf077eaa889e259e9f162ea2222bdaa03f4187783a8682c24d45c91b0559b901d81429ba2cd3f84087d032d354092d5512fb226bdf91549
DIST btrfs-progs-v6.0.2.tar.xz 2321220 BLAKE2B 391bd9dcc7ae2d40c339eb9b7fb466624c3f122149af640bc0ca73abfc85ca7bd076976d47ce2d4eab64fb3b9b1309e3446acdd78ba77e5cb583b939710f8b6c SHA512 8e01fa6e3373d95a8e8577003ceb94722e4dfdf24110bfea79191a9862daf5e6580d72e898fdea134b5e86beeda32948eed572072f7906226189c6f1ac8615e3
DIST btrfs-progs-v6.1.1.tar.xz 2329864 BLAKE2B f3f15829af88f83cdabca30b61dd0e53fc0913615028eac9501204adec5a5beb8654b037617a73bac96c901835a83e8c08d478b8b496518512fea3714e604cfc SHA512 996045bebc441eba269eb5159d6d13c7b1471ba88039389ef221f57d03c535647a5716e23e7a17a20efb4012003f58b4b768f66af633abbdc1fe481192ca1ace
-DIST btrfs-progs-v6.1.tar.xz 2331140 BLAKE2B ca5ba5c1b18bb7db0023e95b3540c6e4863a8bd606e0416d6e1548d4356690d08e09118539ac34e8134329f9b95f7c8f54ea37d3396c9fd8438fb0ba4efcf5f2 SHA512 e20f70ea00f593d90b95b6f0f6b105fc72551b3be0b493c07e92fb31a8db3884edac6344ff1c7ffdc3688948f7bce7c226eea1372ee9f31d5b0194dda6d65389
diff --git a/sys-fs/btrfs-progs/btrfs-progs-6.1.1.ebuild b/sys-fs/btrfs-progs/btrfs-progs-6.1.1.ebuild
deleted file mode 100644
index 2fcbaa6200a9..000000000000
--- a/sys-fs/btrfs-progs/btrfs-progs-6.1.1.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 2008-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit bash-completion-r1 python-single-r1 udev
-
-libbtrfs_soname=0
-
-if [[ ${PV} != 9999 ]]; then
- MY_PV="v${PV/_/-}"
- SRC_URI="https://www.kernel.org/pub/linux/kernel/people/kdave/${PN}/${PN}-${MY_PV}.tar.xz"
-
- if [[ ${PV} != *_rc* ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
- fi
-
- S="${WORKDIR}"/${PN}-${MY_PV}
-else
- EGIT_REPO_URI="https://github.com/kdave/btrfs-progs.git"
- EGIT_BRANCH="devel"
- WANT_LIBTOOL="none"
- inherit autotools git-r3
-fi
-
-DESCRIPTION="Btrfs filesystem utilities"
-HOMEPAGE="https://btrfs.wiki.kernel.org https://btrfs.readthedocs.io/en/latest/"
-
-LICENSE="GPL-2"
-SLOT="0/${libbtrfs_soname}"
-IUSE="+convert python +man reiserfs static static-libs udev +zstd"
-# Could support it with just !systemd => eudev, see mdadm, but let's
-# see if someone asks for it first.
-REQUIRED_USE="static? ( !udev )"
-
-# Tries to mount repaired filesystems
-RESTRICT="test"
-
-RDEPEND="
- dev-libs/lzo:2=
- sys-apps/util-linux:=[static-libs(+)?]
- sys-libs/zlib:=
- convert? (
- sys-fs/e2fsprogs:=
- reiserfs? (
- >=sys-fs/reiserfsprogs-3.6.27
- )
- )
- python? ( ${PYTHON_DEPS} )
- udev? ( virtual/libudev:= )
- zstd? ( app-arch/zstd:= )
-"
-DEPEND="${RDEPEND}
- >=sys-kernel/linux-headers-5.10
- convert? ( sys-apps/acl )
- python? (
- $(python_gen_cond_dep '
- dev-python/setuptools[${PYTHON_USEDEP}]
- ')
- )
- static? (
- dev-libs/lzo:2[static-libs(+)]
- sys-apps/util-linux:0[static-libs(+)]
- sys-libs/zlib:0[static-libs(+)]
- convert? (
- sys-fs/e2fsprogs[static-libs(+)]
- reiserfs? (
- >=sys-fs/reiserfsprogs-3.6.27[static-libs(+)]
- )
- )
- zstd? ( app-arch/zstd[static-libs(+)] )
- )
-"
-BDEPEND="virtual/pkgconfig
- man? ( dev-python/sphinx )"
-
-if [[ ${PV} == 9999 ]]; then
- BDEPEND+=" sys-devel/gnuconfig"
-fi
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- if [[ ${PV} == 9999 ]]; then
- AT_M4DIR="m4" eautoreconf
-
- mkdir config || die
- local automakedir="$(autotools_run_tool --at-output automake --print-libdir)"
- [[ -e ${automakedir} ]] || die "Could not locate automake directory"
-
- ln -s "${automakedir}"/install-sh config/install-sh || die
- ln -s "${BROOT}"/usr/share/gnuconfig/config.guess config/config.guess || die
- ln -s "${BROOT}"/usr/share/gnuconfig/config.sub config/config.sub || die
- fi
-}
-
-src_configure() {
- local myeconfargs=(
- --bindir="${EPREFIX}"/sbin
-
- --enable-lzo
- --disable-experimental
- $(use_enable convert)
- $(use_enable man documentation)
- $(use_enable elibc_glibc backtrace)
- $(use_enable python)
- $(use_enable static-libs static)
- $(use_enable udev libudev)
- $(use_enable zstd)
-
- # Could support libgcrypt, libsodium, libkcapi
- --with-crypto=builtin
- --with-convert=ext2$(usex reiserfs ',reiserfs' '')
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- emake V=1 all $(usev static)
-}
-
-src_install() {
- local makeargs=(
- $(usex python install_python '')
- $(usex static install-static '')
- )
-
- emake V=1 DESTDIR="${D}" install "${makeargs[@]}"
-
- newbashcomp btrfs-completion btrfs
-
- use python && python_optimize
-}
-
-pkg_postinst() {
- udev_reload
-}
-
-pkg_postrm() {
- udev_reload
-}
diff --git a/sys-fs/btrfs-progs/btrfs-progs-6.1.ebuild b/sys-fs/btrfs-progs/btrfs-progs-6.1.ebuild
deleted file mode 100644
index 73fcf46caa45..000000000000
--- a/sys-fs/btrfs-progs/btrfs-progs-6.1.ebuild
+++ /dev/null
@@ -1,150 +0,0 @@
-# Copyright 2008-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit bash-completion-r1 python-single-r1 udev
-
-libbtrfs_soname=0
-
-if [[ ${PV} != 9999 ]]; then
- MY_PV="v${PV/_/-}"
- SRC_URI="https://www.kernel.org/pub/linux/kernel/people/kdave/${PN}/${PN}-${MY_PV}.tar.xz"
-
- if [[ ${PV} != *_rc* ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
- fi
-
- S="${WORKDIR}"/${PN}-${MY_PV}
-else
- EGIT_REPO_URI="https://github.com/kdave/btrfs-progs.git"
- EGIT_BRANCH="devel"
- WANT_LIBTOOL="none"
- inherit autotools git-r3
-fi
-
-DESCRIPTION="Btrfs filesystem utilities"
-HOMEPAGE="https://btrfs.wiki.kernel.org https://btrfs.readthedocs.io/en/latest/"
-
-LICENSE="GPL-2"
-SLOT="0/${libbtrfs_soname}"
-IUSE="+convert python +man reiserfs static static-libs udev +zstd"
-# Could support it with just !systemd => eudev, see mdadm, but let's
-# see if someone asks for it first.
-REQUIRED_USE="static? ( !udev )"
-
-# Tries to mount repaired filesystems
-RESTRICT="test"
-
-RDEPEND="
- dev-libs/lzo:2=
- sys-apps/util-linux:=[static-libs(+)?]
- sys-libs/zlib:=
- convert? (
- sys-fs/e2fsprogs:=
- reiserfs? (
- >=sys-fs/reiserfsprogs-3.6.27
- )
- )
- python? ( ${PYTHON_DEPS} )
- udev? ( virtual/libudev:= )
- zstd? ( app-arch/zstd:= )
-"
-DEPEND="${RDEPEND}
- >=sys-kernel/linux-headers-5.10
- convert? ( sys-apps/acl )
- python? (
- $(python_gen_cond_dep '
- dev-python/setuptools[${PYTHON_USEDEP}]
- ')
- )
- static? (
- dev-libs/lzo:2[static-libs(+)]
- sys-apps/util-linux:0[static-libs(+)]
- sys-libs/zlib:0[static-libs(+)]
- convert? (
- sys-fs/e2fsprogs[static-libs(+)]
- reiserfs? (
- >=sys-fs/reiserfsprogs-3.6.27[static-libs(+)]
- )
- )
- zstd? ( app-arch/zstd[static-libs(+)] )
- )
-"
-BDEPEND="virtual/pkgconfig
- man? ( dev-python/sphinx )"
-
-if [[ ${PV} == 9999 ]]; then
- BDEPEND+=" sys-devel/gnuconfig"
-fi
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- if [[ ${PV} == 9999 ]]; then
- AT_M4DIR="m4" eautoreconf
-
- mkdir config || die
- local automakedir="$(autotools_run_tool --at-output automake --print-libdir)"
- [[ -e ${automakedir} ]] || die "Could not locate automake directory"
-
- ln -s "${automakedir}"/install-sh config/install-sh || die
- ln -s "${BROOT}"/usr/share/gnuconfig/config.guess config/config.guess || die
- ln -s "${BROOT}"/usr/share/gnuconfig/config.sub config/config.sub || die
- fi
-}
-
-src_configure() {
- local myeconfargs=(
- --bindir="${EPREFIX}"/sbin
-
- --enable-lzo
- --disable-experimental
- $(use_enable convert)
- $(use_enable man documentation)
- $(use_enable elibc_glibc backtrace)
- $(use_enable python)
- $(use_enable static-libs static)
- $(use_enable udev libudev)
- $(use_enable zstd)
-
- # Could support libgcrypt, libsodium, libkcapi
- --with-crypto=builtin
- --with-convert=ext2$(usex reiserfs ',reiserfs' '')
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- emake V=1 all $(usev static)
-}
-
-src_install() {
- local makeargs=(
- $(usex python install_python '')
- $(usex static install-static '')
- )
-
- emake V=1 DESTDIR="${D}" install "${makeargs[@]}"
-
- newbashcomp btrfs-completion btrfs
-
- use python && python_optimize
-}
-
-pkg_postinst() {
- udev_reload
-}
-
-pkg_postrm() {
- udev_reload
-}