summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-29 14:47:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-29 14:47:03 +0200
commit18bfd9f376cdff90b8e8071ed649e4c3a804c62e (patch)
tree7d74e7c483448d063dae36b8c0c9bfdee68ac4fd /xfce-extra
parentx11-misc/gigolo: Bump to 0.5.3 (diff)
downloadgentoo-18bfd9f376cdff90b8e8071ed649e4c3a804c62e.tar.gz
gentoo-18bfd9f376cdff90b8e8071ed649e4c3a804c62e.tar.bz2
gentoo-18bfd9f376cdff90b8e8071ed649e4c3a804c62e.zip
xfce-extra/xfce4-clipman-plugin: Bump to 1.6.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-clipman-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.5.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-clipman-plugin/Manifest b/xfce-extra/xfce4-clipman-plugin/Manifest
index c778aa9805b9..c8f586ee470b 100644
--- a/xfce-extra/xfce4-clipman-plugin/Manifest
+++ b/xfce-extra/xfce4-clipman-plugin/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-clipman-plugin-1.6.3.tar.bz2 486276 BLAKE2B f92c93e4ab57fbe37560c389620696f5c11fa8cbd328f29d4895c25c6f18fec88267cc152a1cab39084f08f8fdc070669b665cbad4089ae9577be776a3ad3663 SHA512 a117f64035a6656c2f8603d9b0adec18bcbe8e1ee6a80b838e4cc40480cc3510afe5f32815ff89b1936cbdbadadf8e1e645f0202d97cc877aec125b51b72064b
DIST xfce4-clipman-plugin-1.6.4.tar.bz2 480785 BLAKE2B adc04a41e373fa62f822f0f11a2eac5b684ba89f718806c3d64bb8ddb88eb7de1cc059e3b0dd5baf8201ac8e5c3879d3e4fe57a11ba07684d5fb590062889a15 SHA512 e2cb4068ad00e89d848c72ab4c1b7aac0d41bdd006b60afd09e0323fca1c903eeee3b04a68221f5a2cb6be1347eac8879dfa6bd8b0483c2a075eb36e8cf65ea7
+DIST xfce4-clipman-plugin-1.6.5.tar.bz2 483621 BLAKE2B 0c13126a17e0fc668945b479dab3919b3f6e03a0ad378050041f40ddc4d0f138ffec128be779275eac637daf42352de4ac143d43d26cb8f40ac4d754d8ee70fb SHA512 b0ae4a3928590346dd0f9786959c138f7e9cc03afa974eee558890fcd2b96c019bd4be67f7c231cac802fb6356c64b1e0394ef327aae6256fc433ced245fdff9
diff --git a/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.5.ebuild b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.5.ebuild
new file mode 100644
index 000000000000..a0d6402bf9d7
--- /dev/null
+++ b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A clipboard manager plug-in for the Xfce panel"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-clipman-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-clipman-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="X qrcode wayland"
+
+DEPEND="
+ >=dev-libs/glib-2.60.0
+ >=x11-libs/gtk+-3.22.29:3[X?]
+ >=xfce-base/libxfce4ui-4.14.0:=
+ >=xfce-base/libxfce4util-4.14.0:=
+ >=xfce-base/xfce4-panel-4.14.0:=
+ >=xfce-base/xfconf-4.14.0:=
+ X? (
+ >=x11-libs/libX11-1.6.7
+ >=x11-libs/libXtst-1.0.0
+ )
+ qrcode? ( >=media-gfx/qrencode-3.3.0:= )
+ wayland? (
+ >=dev-libs/wayland-1.15.0
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ X? (
+ >=x11-base/xorg-proto-7.0.0
+ )
+ wayland? (
+ >=dev-util/wayland-scanner-1.15.0
+ )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable qrcode libqrencode)
+
+ $(use_enable X libx11)
+ $(use_enable X gdk-x11)
+ $(use_enable X libxproto)
+ $(use_enable X libxtst)
+
+ $(use_enable wayland wayland-scanner)
+ $(use_enable wayland wayland-client)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}