summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-08 09:11:34 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-08 09:20:20 +0200
commit92ad2681793635aec17059de4c15a95419bc8d2a (patch)
treedcb1acb45be4c968945bd9419b60765421c49c8e /xfce-base
parentdev-python/grpcio-tools: respect CC in setup.py (diff)
downloadgentoo-92ad2681793635aec17059de4c15a95419bc8d2a.tar.gz
gentoo-92ad2681793635aec17059de4c15a95419bc8d2a.tar.bz2
gentoo-92ad2681793635aec17059de4c15a95419bc8d2a.zip
xfce-base/libxfce4ui: Bump to 4.15.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4ui/Manifest1
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.15.3.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index 60b000c257e2..e6d8026aa59a 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -1,2 +1,3 @@
DIST libxfce4ui-4.14.1.tar.bz2 756175 BLAKE2B d487cc0a04b6053ead6670eeb83cafe1c4098818d5ad6a94a81176720d78cfd65160156961cbb526baa1640ae66a5c6958f707b7078c412d81fcd24cc8cf4013 SHA512 f42f41da3a683a0c56c3b1e7ba420c4f50909d2613e681d053b09b50bc0eb7f750f44c892e94b0ee8b9207983a87c0cadbda1ad93d0df74ae351dc8812025407
DIST libxfce4ui-4.15.2.tar.bz2 740189 BLAKE2B 77263318afe376a9b50f129c6969fcb540685bb151f78a94f0024e27871cd8fb895d3edc41483ff8f3b8c8c28d24142252155c6ca68b614375c1fc93f08fdb45 SHA512 1ac2dea2200f00846bc5b5f86d02292f345dc904a121df86a662ca1844b1bdd9eea6bf0cd88dda97ff84e30d990b065bd9597cb563dbb75f639e820d41f83dbc
+DIST libxfce4ui-4.15.3.tar.bz2 756530 BLAKE2B ca2a9d5aae80d22a97b2fe932248756c9f34f71a13342670cdc0ad1c5393eb62d4f5bed8b21a45a60c762a83ebf1458deb7ef629c4dd3c894468ecf16a821dcf SHA512 a0e5a60c54df811fa2815238f9fe506700f6df8a6baa8172a6f8c68f005b54ba94ee31aba87d635fb506700da9c77e25f8c57268018fc8cfa5577f29aab58a6b
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.15.3.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.15.3.ebuild
new file mode 100644
index 000000000000..cddd13c8d5ef
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.15.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils vala
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade introspection libgtop startup-notification vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.42:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.12:=[introspection?]
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3.10 )
+ introspection? ( dev-libs/gobject-introspection:= )
+ libgtop? ( gnome-base/libgtop )
+ startup-notification? ( x11-libs/startup-notification )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable libgtop glibtop)
+ $(use_enable startup-notification)
+ $(use_enable vala)
+ $(use_enable glade gladeui2)
+ --with-vendor-info=Gentoo
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}