summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 06:27:10 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:48:15 -0400
commitf4e6242a6cfc760dfe65a5718967426372da9b2f (patch)
tree0874f61ce09dc0c6c426395bcfc6dcc8d34124bb /x11-wm
parentx11-wm/lwm: EAPI6->8, use https, fix license (diff)
downloadgentoo-f4e6242a6cfc760dfe65a5718967426372da9b2f.tar.gz
gentoo-f4e6242a6cfc760dfe65a5718967426372da9b2f.tar.bz2
gentoo-f4e6242a6cfc760dfe65a5718967426372da9b2f.zip
x11-wm/lwm: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Can still use clang & friends for everything else. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/lwm/lwm-1.2.4.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/x11-wm/lwm/lwm-1.2.4.ebuild b/x11-wm/lwm/lwm-1.2.4.ebuild
index 0a0a57a1a84e..e1d55b18003d 100644
--- a/x11-wm/lwm/lwm-1.2.4.ebuild
+++ b/x11-wm/lwm/lwm-1.2.4.ebuild
@@ -21,7 +21,9 @@ RDEPEND="
DEPEND="
${RDEPEND}
x11-base/xorg-proto"
-BDEPEND=">=x11-misc/imake-1.0.8-r1"
+BDEPEND="
+ sys-devel/gcc
+ >=x11-misc/imake-1.0.8-r1"
src_prepare() {
default
@@ -31,7 +33,7 @@ src_prepare() {
src_configure() {
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}
src_compile() {